Solved

Tape Drive "Dead" in VMWare Esx 4.1 using Tandberg LTO-4 drive

Posted on 2010-11-10
18
6,614 Views
Last Modified: 2013-11-14
I have an ESX 4.1 server running on a Dell R710 box.  I installed a Dell Single Channel Ultra 320 SCSI card a few weeks ago and attached our old HP LTO drive to it.  This worked fine.  Today I replaced the old HP LTO drive with a Tandberg LTO-4 drive.    The status of the tape drive is now "dead".  I look under "Storage Adapters" and the SCSI card shows up as 53c1030 PCIx Fusion-MPT Dual Ultra 320 SCSI card.  The path is listed as "   vmhba2:C0:T3:L0 Lun 0 Status=Dead.

I tried the command that someone else mentioned in another post - started with esxcli.  However, their card was an Adaptec.  Any thoughts on how to get the tape drive to show up?
0
Comment
Question by:Superfly2
  • 8
  • 7
  • 3
18 Comments
 
LVL 7

Expert Comment

by:Hatrix76
ID: 34109868
You maybe out of luck, the knowledgebase article for tapedrives connected via SCSI in vmware definitly states that only adaptec controller cards are supported.

The thing is a Tape over SCSI has issues if it's not having a super-nice, uninterrupted data-stream. I guess adaptec cards may integrate better data-buffering before sending it to the device itself, but this is only speculation.

To your actual problem of having the device as reported dead ... do you have exactly the same settings (like scsi id's etc.?). The scsi id on the tape does not conflict with other devices on the bus? Do you have proper SCSI termination? (is the the tape the last drive? maybe you forgot to put the terminater from the old Tape to the new one?

as well it could be that the cable is bad / to long, u320 scsi is very, very sensible to cables, try getting a intertwisted cable, if you have a flat-cable, it's probably a point of failure (google for SCSI and flat cable and you will find ton's of information regarding these problems.)

The ongoing problems with SCSI, Termination, Cable sensibility where in part responsible for the industry abondaning the development of the 640 SCSI standard in favor of SAS/SATA ...

best
Ray
0
 
LVL 7

Expert Comment

by:Hatrix76
ID: 34109916
0
 
LVL 55

Expert Comment

by:andyalder
ID: 34109962
Why on earth are VMware publishing articles about SCSI passthrough when PCI passthrough gets past most problems?
http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=1010789&sliceId=1&docTypeID=DT_KB_1_1&dialogID=123836570&stateId=0 0 132339262
0
 

Author Comment

by:Superfly2
ID: 34111655
FYI - When I plug an HP Ultrium LTO-1 drive in, it works fine.

The SCSI card is actually an LSI Logic LSI20320IE.  As I said, when I plug an old HP LTO-1 drive in everything works:

Shows up as: vmhba2
Model: 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI

Device: Local HP Tape   Runtime Name: vmhba2: C0:T3:L0   LUN=0  Type=Tape  Owner=NMP

However, when I plug in the Tandberg LTO-4,  it shows up as "dead".  I'm using the same controller, same cable, same SCSI ID.

Any thoughts?
0
 

Author Comment

by:Superfly2
ID: 34111710
FYI, I am a VMWare (and Linux) newbie, so forgive me if my comments sound illogical.  However, it appears to me that ESX has a driver for the HP tape drive, but not for the Tandberg. Maybe I need to install a specific driver for the Tandberg.  Does that make any sense?

Another thought--AndyAlder, What is PCI passthrough? Should I give this a try? Will my VM still be able to see the SCSI card and tape drive? As I understand it, if I enable SCSI passthrough, then the ESX server will no longer see the SCSI card and tape drive. Is that correct?

Thanks to all for the quick responses.  Your help is much appreciated.
0
 
LVL 7

Expert Comment

by:Hatrix76
ID: 34111736
As I said, it could be that the LTO-4 drive just does not support the cable, try a different one (especially if it is a flat-band cable). the older LTO-1 technology might is slower and does not have the needs of a LTO-4 drive.

also try to connect the LTO-4 with the same cable directly to another computer, is it working there? If not, try to connect it to different computer with a intertwisted cable, and check if it's working.

Make sure it works independently and then let's move forward to check why it's not working in VMWare

best
0
 
LVL 7

Expert Comment

by:Hatrix76
ID: 34111816
it's most likely NO driver issue, at least not in the sense of LTO Tape driver, these are all pretty standard and covered by the default linux drivers. You see, they communicate over SCSI which is a protocol, so this is all pretty generic (http://www.mjmwired.net/kernel/Documentation/scsi/scsi-generic.txt)

best
0
 

Author Comment

by:Superfly2
ID: 34112523
I did try two cables.  First, I tried the one that came with the Tandberg drive.  That didn't work.  Next, I tried the one that was already connected between the SCSI card and the old HP LTO-1.

Hatrix76, that makes sense.  Especially considering that ESX sees the SCSI card and the SCSI BIOS does see the Tandberg tape drive (I checked during a reboot).
0
 

Author Comment

by:Superfly2
ID: 34113061
FYI -- I just bought this SCSI controller and the Tandberg tape drive.  If anyone is aware of any other combination that will work, I could send these back and get a different controller and tape drive.  I would rather not, but I need to come up with a solution soon.  We are running with no recent backup.

Hatrix76, concerning your first comment, This is a PCI SCSI card with nothing else connected to it and I used the same SCSI ID as the HP LTO drive (the one that worked) when I connected the Tandberg.  Both drives use active termination and the Active Termination light was on (indicating active termination is on) in the case of both drives.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 7

Expert Comment

by:Hatrix76
ID: 34113225
Well, as I said, try to get the LTO-4 with the same cable to run with this SCSI card in a not-virtualized environment, if you are sure it is working, I would advice you to invest in a adaptec card supported from VMWare for this type of work.

If it's not working with this SCSI card without the vmware, it's an LTO-4 drive problem ... Either way, just for your information, we tried installing a LTO3 autochanger in vmware with an HP card which is exactly the same:

11:08.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev c1)


and we had to buy another server because, altough we got it running in VMWare, we could not create backups with files bigger than a few megabytes, small files where fine, but bigger files got a SCSI chksum error in the SCSI layer, so it would not restore. The errors where reported in the kernel log so the application (bacula) did not get information about the problem and the backup seemed fine. But when you tried to restore the chksum errors prevented it.

So, I would not recommend doing backups in a virtualized environment if your hardware is not supported by the virtualization provider, your backups are to important to gamble with them.

Best
Ray
0
 
LVL 55

Accepted Solution

by:
andyalder earned 500 total points
ID: 34113422
PCI passthru  (VMDirectPath I/O) passes through the HBA or whatever it is straight to the virtual machine, so you would see the native HBA under the virtual machine. Works with just about anything, not just SCSI HBAs.

http://www.experts-exchange.com/Software/VMWare/Q_26389860.html is worth a read, looks like exactly the same problem you've got although different SCSI card.
0
 

Author Comment

by:Superfly2
ID: 34115099
AndyAlder:  I read the link that you provided.  This sounds like a viable solution.  However, being a Linux newbie, I'm not sure how to change the command to match my SCSI card

Here is the command line from the post that you referenced.  I assume that I would use the same command except that the "driver" section would be different.  How do I find out the correct driver name for my card to replace "aic79xx"?  Keep in mind that my SCSI card driver is loading because I can see the HP drive, just not the Tandberg.

To fix the dead path issue
Enable local and remote support via the ESXi 4.1 console
Alt F1
Login as root
Run the following command
esxcli nmp satp addrule --satp VMW_SATP_LOCAL --driver="aic79xx" --description="Specific rule for Adaptec Card"
Reboot the ESX server
login to vcenter or vsphere client and you should now see your SCSI tape drives
0
 
LVL 55

Expert Comment

by:andyalder
ID: 34116003
Without looking in /dev I have no idea what the driver's name is.
0
 
LVL 7

Expert Comment

by:Hatrix76
ID: 34116236
the driver is mptspi

I hope you will get it to run, but I doubt it.

best
0
 

Author Comment

by:Superfly2
ID: 34123005
Based on the question that AndyAlder referenced, it sounds like the best thing to do is just replace the SCSI card with an Adaptec SCSI card.  Based on that article, I cannot see why the Tandberg LTO-4 with an Adaptec SCSI card would not work.  Any comments or worries before I take the plunge?
0
 
LVL 7

Expert Comment

by:Hatrix76
ID: 34125358
well, my posts above apply, go for it, but keep in mind that for tape-drives a virtualized environment may not be optimal.

I don't know if you can remember but a good analogy is when the first CD-Burners where affordable for home-usage, you had to turn off the screen-saver and you did not dare run any program to not disturb the data-throughput to the burner, if your virtualized hosts for some reason steal cpu from the virtual backup host, like, a runaway process consuming all the resources, it may produce corrupt backups.

Test your backups, try to test with the other vm's under load and stress. And try to restore them.

Sometimes it's better to just put a cheap box with a scsi card in charge of the backup, you do not need lot's ressources.

best
Ray
0
 

Author Closing Comment

by:Superfly2
ID: 34150228
I ended up just buying an Adaptec SCSI card so I could create the same scenario that was described in Q_26389860.  Once I did that, I now have the same SCSI adapter, the same tape drive, and the same version of ESX (4.1).  I used the command on ESX box that was specified in Q_26389860.  Now ESX sees the Tandberg LTO-4 tape drive and it functions perfectly with Backup Exec 12.5.
0
 

Author Comment

by:Superfly2
ID: 34150230
Thanks to all of you for your help.  It is much appreciated.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
Veeam Backup & Replication has added a new integration – Veeam Backup for Microsoft Office 365.  In this blog, we will discuss how you can benefit from Office 365 email backup with the Veeam’s new product and try to shed some light on the needs and …
Teach the user how to use create log bundles for vCenter Server or ESXi hosts Open vSphere Web Client: Generate vCenter Server and ESXi host log bundle:  Open vCenter Server Appliance Web Management interface and generate log bundle: Open vCenter Se…
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now