Solved

SBS 2008 - Random files opening very slowly, and sometimes as Read Only?

Posted on 2010-11-10
87
2,220 Views
Last Modified: 2012-10-09
I know this problem was solved  by the experts already and I followed the thread to a t, I think, but I am still having the problem.  I have been looking on the web and trying a number of ideas but nothing seems to work and the client is starting to run out of patience.  Please help, if possible.  
Anything I tried that failed I reversed the action immediately so I think I can say we are starting from the beginning.
system

Small site only 10 users.
Dell Power Edge T110
4gb ram, 250 gb disks raid 1
dell 10/100/1000 switch
3 machines with 100mb nics the rest have 1gb nics
SBS 2008 patches are current at server.
Workstations, Win 7 pro, Vista pro, win xp sp 3


Thank you for your time in advance.
gordon
0
Comment
Question by:gordoninhawaii
  • 48
  • 26
  • 5
  • +1
87 Comments
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34108867
4GB of RAM is not enough in a production environment. You will find that alone will cause performance issues. That is the bare minimum and really only to be used in a test environment with 1 or 2 users.

However there are some known networking performance issues:
1) A common problem is NIC drivers. Make sure you have the latest from the NIC manufacturer, not Microsoft, who tends to lag behind a bit.

2) There are some known issues with advanced NIC properties such as "large send offload", "Checksum offload", and Receive-Side Scaling which drastically affect performance of file share access if enabled and especially if you are running older drivers. Running the SBS Best Practices Analyzer (link below) will usually recommend disabling these. If new drivers are available they may make use of these features, otherwise they should be disabled.

http://blogs.technet.com/b/networking/archive/2008/11/14/the-effect-of-tcp-chimney-offload-on-viewing-network-traffic.aspx
http://blogs.dirteam.com/blogs/sanderberkouwer/archive/2008/05/15/backward-compatible-networking-with-server-core.aspx
http://support.microsoft.com/kb/951037
http://msmvps.com/blogs/thenakedmvp/archive/2010/02/23/rss-tcp-offloading-strikes-again-microsoft-should-kill-this-feature-for-the-masses.aspx

SBS 2008 BPA
http://www.microsoft.com/downloads/details.aspx?familyid=86a1aa32-9814-484e-bd43-3e42aec7f731&displaylang=en
0
 

Author Comment

by:gordoninhawaii
ID: 34108882
ok, I will try your suggestions tomorrow.  
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34109040
ps- you also need to reboot after the networking changes.
0
 

Author Comment

by:gordoninhawaii
ID: 34117665
Server and workstations right.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34117693
I have found doing the server the most important, but many others report it is necessary on both. Just try one problematic workstation.

The features you are disabling are intended to improve performance, however it seems most network adapters do not yet support them and it results it drastic performance hits. The better solution is a server grade NIC with the required driver updates when available, but that is often not the case, especially on standard grade servers such as Dell's with Broadcom adapters.
0
 

Author Comment

by:gordoninhawaii
ID: 34128618
Ok, well I tried the disabling of features you suggested.  Rebooted the server.  No luck.  I tried to set the parameters on an XP machine but I guess they are not available.  Got a response that the command was not valid.
0
 

Author Comment

by:gordoninhawaii
ID: 34128731
Also did the following
1.  Added 4gb of ram
2. turned off IP v6
3. turned off Windows firewall

Nothing changed.  Timings for opening the files are the same.  Only thing I can add is this;
1.  Open the file in a defined share, takes over a minute.
2.  Open the same file in the users home directory, on the network, takes about 5 seconds.

I am working on a XP client, it is the only one on, and can't find how to make same changes as the server or equivalent.

Is there anything else I can do?
0
 

Author Comment

by:gordoninhawaii
ID: 34128905
Hi RobWill,
I tried to upgrade the Dell Broadcom Netxtreme to no avail
current driver is 12.2.0,3 5/28/09
newest driver is 14.2.0, A03 7/6/2010

When attempting to install, program says it is not compatitable with system and closes.
If I try just using device manager to get the driver it says I have the best available.

Sort of stuck.

Gordon
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34128964
Did you reboot after making the changes to the NIC features (TCP Offload etc.)?
Also, do not disable IPV6 on the server.
0
 

Author Comment

by:gordoninhawaii
ID: 34129582
Yes i did.  Although I got  a slight improvement, maybe 10 seconds the problem is still there.  Again I am working on an XP machine and am not sure what to disable on the client side.  NIC's are Intel Pro.
0
 

Author Comment

by:gordoninhawaii
ID: 34129659
This is so wierd.  I did a test that opens the same file, that is in a share directory, a half dozen or so times and the file open slow, not as slow, fast, instant, slow, slow then slower.  How wierd is that.  All I did was select open than the the file, then close and repeated that a number of times.  So bizarre.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34131150
The options do not always exist depending on the NIC, but some are registry changes that you should make.

As for the speed varying, that is very typical of the problem.
0
 

Author Comment

by:gordoninhawaii
ID: 34132784
The exact NIc I have in the XP workstations is INTEL 82562v2 10/100
driver 9.8.20.0  4/13/2007.  I can't find anything later on the web.

Options to turn off are:
offload receive IP checksum
offload receive TCP checksum
offload transmit IP checksum
offload transmit TCP checksum

Do the above four come into play?  
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34133311
All 4 can affect performance. Generally you want to disable anything to do with "offload", and "Receive Side Scaling".

On a completely different note, from way back before the above issues existed:
Slow opening of files, especially Office files, is often related to Windows searching for old links that no longer exist. Finding these can sometimes be a bit time consuming. A few places to look:
-Network places. Look for links/connections that no longer exist.
  (I prefer to also turn off "automatically search for network folders and printers". Locate by going to the menu bar of my computer | tools | folder options | View | fist item)
-My computer. Look for mapped drives that are disconnected.
-Start menu "recent Documents". To clear; right click on task bar and choose properties | start menu tab | customize | advanced | clear list
-If the Word or Excel applications are slow opening the files from the menu, clear the recent document list within the application. To do so in Word; open the application | on the menu bar choose  tools | options | general | un-check "recently used file list | choose OK to apply | then you can go back in and re-enable. Excel is similar.
0
 

Author Comment

by:gordoninhawaii
ID: 34150150
I am about to do this for the person that is having the most trouble and will report back as soon as I have completed the task.
0
 

Author Comment

by:gordoninhawaii
ID: 34151861
Ok I have spent about two hours turning off any thing that had the world offload in the client nic.  Performed everthing you suggested and that was applicible.  No luck.  Still taking a minute and half to two minutes to open.  Word will display "not responding" top left, due to time delays.  This particular machine is a Win7 32bit, 4gb Dell Vostro 3300.  What bothers me is the NIC has a driver of 11/05/2009, and the downloads from Dell have 7/2010 date.  Problem is they will not install on the machine, stating they are not compatible with the machine.  The client jsut does not understand what kind of problem we have here and is getting a little angry over the situation.

Again appreciate your efforts and hope you have a little more up your sleeve.

Aloha
Gordon
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34154417
The only remaining though I have is the network itself.
-70% of slow connections are due to bad wiring. A simple stretched, kinked, or poorly terminated cable can cause drastic performance problems. This can only be tested with certification equipment. Can you try a different physical connection
-a bad switch port (un-likely)
-if a NIC or switch port is set to a fixed speed and/or duplex and switch port or NIC is set to auto or a different speed and/or duplex this can happen. They must be the same, preferably auto.
0
 

Author Comment

by:gordoninhawaii
ID: 34157691

I too have thought about that and tested for that first.  My test was, pull the files up from the home directory.  The files responded as they should, immediate.  This removes the physical aspect out, as I am using all the physical properties and the network and things are good.  It seems to me that the issue centers around shared folders.  The interesting thing I did last night was to build an equivalent environment at home.
Same hardware at the server and same OS.  Client workstations are different, I used a Vostro 3500 notebook with Win 7 pro, Inspiron 530 desktop with Win 7 Ultimate, Inspiron 4150 (oldie) with XP sp3.   All notebooks were tested with wire and wireless and the results were pretty close to the same...... instant.  I am pretty sure that the problem network is at the same patch level as I am.  They have all the tweeks you had me do and I don't have that at the test world.  What is still different and I can't get going is the drivers at the workstations.  I cannot seem to find an upgraded driver for any of the workstations that will install.
The vostro 3500 and 3300 notebooks should use the same nic but I am not sure.  What a pain.
 
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34158837
I assume you have tried getting drivers from the NIC vendor rather than just Windows updat?
0
 

Author Comment

by:gordoninhawaii
ID: 34158877
Yes, that is what I have been downloading and trying.  This is what is so confusing to me.  Actually I guess I should say I have been getting them from Dell not Intel or Realtek.
0
 

Author Comment

by:gordoninhawaii
ID: 34158883
The MS ones all say that I have the best one.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34159020
Intel or Realtek (not my favorite) may well have newer drivers. Intel are very good and they often update, but Dell can lag 3-12 months behind updating.
0
 

Author Comment

by:gordoninhawaii
ID: 34159116
ok, I will see what I can find.  Thanks
0
 

Author Comment

by:gordoninhawaii
ID: 34159507
Ok, finally figured out how to get a new driver into the server.  What a hassel.  Anyway the new driver is 5/21/2010 about a year to the new side.  The version is 14.02.x.x the old one was 12.2.03 5/28/2009.  Not going to be able to reboot the server until tonight and can't get at the workstation I was using for testing until tomorrow.  But a glimmer of hope.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34159568
Regardless of outcome that is good to have updated. To be quite honest I will be surprised if it helps.
Any of the TCP offload and receive side features that were disabled will be re-enabled but that may be OK on a driver that recent especially if that is the Intel.
0
 

Author Comment

by:gordoninhawaii
ID: 34159784
That is my feels too.  Unfortunately it is a Broadcom the one at my site is an Intel and it seems to be good as I cannot duplicate the problem at my site and from a hardware position that is the only thing that is different.  As far as I can recollect these are identical installs from an option standpoint.  Only difference is people and computers.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34159929
Very odd. I am running out of ideas.
0
 

Author Comment

by:gordoninhawaii
ID: 34167240
Hi RobWill,
Bad news.  After upgrading the NIC driver in the server to most current available and rebooting the server, the problem got worse by a factor of three.  It is really slow today.  I even went back into the server NIC's configuration and turned off everything that mentioned "offload" and rebooted the server, that did not help.  I did the same for the client workstation.  That did not help either.  I am dying over hear. Like you I am at a loss.  I am pretty sure the hardware is not the problem.  I am, and maybe to much, focused on something to do with shared files or possibly something in the old documents that is causing the problem.  I noticed one thing last night.  Documents that had little to no formatting did not seem to be affected.  Have no idea what to do with that information.

Aloha
Gordon
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34168690
Interesting, if the problem got worse when you updated the drivers it would sound like it is driver or NIC related. Can you choose "roll back driver" under the properties of the NIC in device manager (Driver tab).

What happens if you try accessing a file on another PC? i.e. PC-PC rather than PC-server?

I am guessing gordoninhawaii means you are working in Hawaii?
I am on the east coast of Canada. I think this sounds like a job I should fly out and help you with :-)  
Starting to get cool here. East coast is not like central Canada but it's not Hawaii.
0
 

Author Comment

by:gordoninhawaii
ID: 34170066
I will try your suggestion tonight.

Right now Hawaii feels like a million miles from anywhere, this problem is really starting to bug me.

Yes, I do live in Hawaii on the island of Oahu.  Great place to live and I am never really cold, although when the tempeture drops to about 65, I am in sweats. LOL, but true.  I thought it was crazy when I first moved here twenty years ago but after your blood thins out, you get cold fast.

0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34176846
I had two thoughts today.
-Might your workstation antivirus be scanning the network dive every tie you try to access a file. Can you disable it as a test?
-There have been numerous folk over the past few months discussing SMB 2 degrading network performance. Personally i haven't seen this but it is skilled technicians that are reporting it. The following outlines how to disable on server and workstation. You could try it as well as a test.
http://blogs.technet.com/b/askperf/archive/2008/05/30/two-minute-drill-overview-of-smb-2-0.aspx
0
 

Author Comment

by:gordoninhawaii
ID: 34177712
I thought about the anti-virus but let it go because the files in the users home directory, their home is on the server, were not displaying the slow file opening.  I will give it a try this evening.  will check out the link you gave me too.

aloha
Gordon
0
 

Author Comment

by:gordoninhawaii
ID: 34178614
Well, I tried the second part, disabling smb2 and enabling smb1, still have the problem.  Not sure if things are better, they seem a little faster, because I was using a different client computer and the OS is XP sp3.  Still open some docs and they are instant and others take 15 to30 seconds to open, but Word didn't get to a "not responding" status.  Will try the antvirus next.

aloha
Gordon
0
 

Author Comment

by:gordoninhawaii
ID: 34214059
Aloha RobWill,

I tried everything now and nothing seems to help.  The inconsistency is what is killing this effort.  Some files open fast and others don't.  Some files on shared directories open fast others don't.
Disabled smb 2 at the server and the workstation, it never seems to help the situation get better but does seems to make it worse when I disable features on the nic.  I am at a lose and don't have any new idea's.  Any suggestions on where to go from here?

Mahalo
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34215326
I am afraid at this point I have run out of ideas. You could click the "request attention" link and ask the moderators to try to draw the attention of some other "experts". I won't desert you but currently I have exhausted any ideas I might have. My apologies.
0
 

Author Comment

by:gordoninhawaii
ID: 34216285
THanks for trying to help me.  It is definitely an ugly problem
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 34225756
two things I have not see suggested here
1.  Please go to a command prompt on the server and run IPconfig /all and post the unedited results
2.  Download and run the SBS Best Practice Analyzer (www.sbsbpa.com)
0
 

Author Comment

by:gordoninhawaii
ID: 34226180
Will do.  I can't get to the system until later today or possibly tonight.
0
 

Author Comment

by:gordoninhawaii
ID: 34250288
Sorry I have taken so long, but pretty sick for a few days now.

Ipconfig /all
Windows IP Configuration

   Host Name . . . . . . . . . . . . : ACLAW-2
   Primary Dns Suffix  . . . . . . . : ABlawgroup.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ABlawgroup.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 00-26-B9-7C-93-BB
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::76c8:8499:2fcb:53f0%11(Preferred)
   Link-local IPv6 Address . . . . . : fe80::d8e5:c2d7:f7d0:cfb5%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.150.26(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.150.1
   DHCPv6 IAID . . . . . . . . . . . : 251668153
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-B8-CF-A7-00-26-B9-7C-93-BB
   DNS Servers . . . . . . . . . . . : fe80::76c8:8499:2fcb:53f0%11
                                       192.168.150.26
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 8:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{0999CD8B-919E-4EFA-857E-AB7E440B385B}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Ran the SBSBPA  it did  not bring anything to the surface that I can see.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 34250518
If the SBS BPA returned any items needing attention they should be attended to.
It may also be that you need to disable smb2 protocol
http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:gordoninhawaii
ID: 34251263
I think I have disabled the smb2 protocol, for sure on the server.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34253984
Gordon we addressed earlier RSS, Task Offloading an other performance items related to the NIC, did non of these get reported bt the BPA? Makes sure you click the "get updates" lisnk at the start of the wizard. I am surprised even if turne off on the NIC that you didn't get any of the following poining to the registry.

Receive Window Auto-Tuning Level is set to normal. To disable Receive Window Auto-Tuning Level, click Start, and in the Search box type "command." in the results, right-click Command Prompt, and then click Run as administrator. At the command prompt, run the following command:
netsh int tcp set global autotuning=disabled

For more information, see:

Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008
http://go.microsoft.com/fwlink/?LinkId=189029

Mail flow to certain domains does not work when you run Exchange Server 2007 on a Windows Server 2008-based computer
http://go.microsoft.com/fwlink/?LinkId=189028
________________________________________
Receive-Side Scaling State is set to enabled. To disable Receive-Side Scaling, click Start, and in the Search box type "command." in the results, right-click Command Prompt, and then click Run as administrator. At the command prompt, run the following command:
netsh int tcp set global rss=disabled
For more information, see:

Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008
http://go.microsoft.com/fwlink/?LinkId=189029

Mail flow to certain domains does not work when you run Exchange Server 2007 on a Windows Server 2008-based computer
http://go.microsoft.com/fwlink/?LinkId=189028
________________________________________
Task Offload is set to enabled. To disable Task Offload, click Start, and in the Search box type "command." in the results, right-click Command Prompt, and then click Run as administrator. At the command prompt, run the the following command:
netsh int ip set global taskoffload=disabled

For more information, see:

Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008
http://go.microsoft.com/fwlink/?LinkId=189029

Mail flow to certain domains does not work when you run Exchange Server 2007 on a Windows Server 2008-based computer
http://go.microsoft.com/fwlink/?LinkId=189028
________________________________________
Add-On Congestion Control Provider is set to ctcp. To disable Add-On Congestion Control Provider, click Start, and in the Search box type "command." in the results, right-click Command Prompt, and then click Run as administrator. At the command prompt, run the following command:
netsh int tcp set global congestion=none

For more information, see:

Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008
http://go.microsoft.com/fwlink/?LinkId=189029

Mail flow to certain domains does not work when you run Exchange Server 2007 on a Windows Server 2008-based computer
http://go.microsoft.com/fwlink/?LinkId=189028
0
 

Author Comment

by:gordoninhawaii
ID: 34254286
Aloha RobWill,

Not sure I understand what you wrote, but I did everything we discussed and , at least the thread I am reading, shows everything we did.  I assumed it got overlooked once I got the response back from the group.  I did turn everything we talked about off, or at least I though I had and I read everything you sent me, which made it easier to understand.

Aloha
Gordon
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34254290
Hi Gordon. I was just surprise the BPA came up completely clean.
0
 

Author Comment

by:gordoninhawaii
ID: 34254295
I will run it again too night and see what I might have missed.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34254358
Not a problem, it's just that it was a good suggestion by Cris and I was surprised nothing turned up. I have notice that some of the NIC performance I listed show up even when turned off on the NIC rather than the registry. As mentioned make sure you choose "check for updates" as the BPA has been updated in the last 6 months.
Cheers.
0
 

Author Comment

by:gordoninhawaii
ID: 34254913
ok this is what is in the BPA.
1.  Exchange server is at SP1 needs to go up to SP3
2. WSBS update Service not at default settings, so service shut off.
I will figure out how to get it back to default without reinstalling SBS2008, that was one of their solutions.
3. Backconnecthostname missing.
would have fixed but I don't have the level above it \lsa\MSV1_0
I think this is a sharepoint issue anyway.
4. Win SBS2008 Rollup 4 not installed.
Don't know what this is about but I will get it tonight.

That is all that is in the report.  Did I miss something?
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 34256650
The update rollup 4 for SBS fixes a great many issues.  http://support.microsoft.com/kb/979454
Repairing WSUS is actually pretty easy... see this excellent blog from Susan Bradley  SBS DIVA http://msmvps.com/blogs/bradley/archive/2009/08/27/repairing-wsus-3-on-sbs-2008.aspx
0
 

Author Comment

by:gordoninhawaii
ID: 34259821
Thanks Chris, will handle this evening.  But do you feel this will help the problem?  I am trying to minimize the disruptions to the client.  They take their machines home at night to work.  When I need to test they leave it, and, of course, complain.  No matter the problem needs to be solve and soon, management is starting to get anxious.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 34259986
If the application of SBS Update Rollup 4, the NIC tweaks which Rob has outlined in details, and the disabling of smb2 don't solve it, the other two options are, disable realtime scanning by AV on the workstations and server and if that doesn't do it, then this may be a networking hardware issue...and that can be loads of fun to track down

What are you running for AV?
0
 

Author Comment

by:gordoninhawaii
ID: 34260185
MS essentials for now.  Workstation is running AVG.  I am having trouble understanding why hardware would be an issue.  My reasoning is that a percent of the files, on the network, open with no problem.  The files that are a problem seem to be in shared directories.  I would point it directly at that issue except some files in shared directories open fast too.  Now the only other point I found was that the files that are defined as correspondence are the problem files and they have a number of different fonts embedded in the documents.  The files that don't have problems are word documents that are just plain text.  I do not seem to have issues with excel, as some others have claimed.  To me it feels like the documents have some kind of corruption and MS Word is fixing it before it displays.  This is just a gut feeling.  The other interesting point is that I can take a problem file and move it from a shared directory and put it either on the local or home directory, neither are shares, and the problem does not exist.  This is why my focus has been directed at the shares and whatever goes on there that I don't understand.  This is why I am here with you guys hoping to use the fresh eyes on the problem as mine are really getting blurry.
0
 

Author Comment

by:gordoninhawaii
ID: 34260242
One last point on the last discussion I posted.  The workstations had are the same as when the server was sbs2003 and the problem did not exist.  By the same I mean the same hardware and software.  I did not upgrade the AV any applications.  The only change here was the file server hardware and the OS, from sbs 2003 to sbs 2008 and the problem reared its head.  I was really careful on this point as I have been bite too many times from throwing to many variables into the pot.  Thanks again to you and Rob for your efforts.  Hopefully there is an answer to this ugly thing.

P.S, the workstations involved cross all os's, xp sp3, vista sp2, win 7
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 34260287
Just for grins...can you take one of the problem "correspondence" documents, copy to a new file.   Then open, change all fonts to arial or Times New Roman, save.  Open again...still take forever to open?

FYI, MS Essentials is not supported to be on the server, only workstations
0
 

Author Comment

by:gordoninhawaii
ID: 34260698
Sorry stand corrected, I am using what came with sbs 2008 on server, forefront for exchange, I think.  Was not too worried about it, because all workstations have av and the server is not used as a client by anyone but me.
0
 

Author Comment

by:gordoninhawaii
ID: 34260705
Will try your suggestion later today.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34262822
The problematic documents are Word files being opened by Word I assume and also they are not older .doc files being opened with Word 2007/2010? In other words it is not doing file format conversions on these specific files when opening are they?
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34262959
Another thought is Word and Excel (though you say the latter is fine) tend to scan for other older documents 'automatically', especially "recently opened" files. If the file locations have change (SBS2003 to SBS 2008) it may be looking for files that no longer exist, or at least in those locations. This can be resolved by eliminating:
-In Word clear the recent document list within the application. To do so in Word; open the application | on the menu bar choose  tools | options | general | un-check "recently used file list | choose OK to apply | then you can go back in and re-enable. Excel is similar.
-Start menu "recent Documents". To clear; right click on task bar and choose properties | start menu tab | customize | advanced | clear list
-On the PC's network places. Look for links/connections that no longer exist.   (I prefer to also turn off "automatically search for network folders and printers". Locate by going to the menu bar of my computer | tools | folder options | View | fist item)
-My computer. Look for mapped drives that are disconnected.

The following article may also be of some help, in particular its reference to removing Word temp files.
http://word.tips.net/Pages/T001328_Word_Slow_to_Open_Documents.html
0
 

Author Comment

by:gordoninhawaii
ID: 34263607
Check the mapped drive awhile back, no problem there.

The word article is interesting and I will need to look a lot further.

Will have the user do as you say and kill the most recently opened.

thanks for the ideas
0
 

Author Comment

by:gordoninhawaii
ID: 34263632
I would like to go back to the comment you made about document conversion.  All documents should be .doc but I am not sure.  I did not think MS would open a docx, we are using Office 2003 and defaulting to doc.  Without a viewer docx's can't be opened, can they?
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34263719
If you are using Word 2000/2003 you cannot open docx files unless you have the compatibility pack installed. With it you can open, read, and save as .doc, but not as docx. The point being Word 2000/2003 with the compatibility pack opening .docx files, or Word 2007/2010 opening .doc files are slower due to converting the file format to their respective native Word formats.

If not familiar with the 2007 compatibility pack add on see:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=4f97ab2f-1f7d-49a3-9123-7ca3e703b916&displaylang=en
The Microsoft viewers also work, but they do not allow you to edit the files.
0
 

Author Comment

by:gordoninhawaii
ID: 34263730
No I am good with everything.  I just thought I might have missed something.  thanks
0
 

Author Comment

by:gordoninhawaii
ID: 34316152
I guess there is a second thread out there that I  have been posting to and didn't realize the group was not see it.  
Basically I did a test last weekend that went like this.
1.  opened a slow document that resides in a shared directory.
2.  copied all of the data in the document into a wordpad file and saved it in the same shared directory.
3.  Opened the document, in wordpad and it opened fast.
4 opened the document, in word and it opened fast.

What is missing from the original document is the Header and footer or it is a template with the header and footer embedded.  By coping the data to wordpad, this information was dropped.  I think this is were the problem is.  Not sure if it is the fancy fonts or in the template.  

Any idea's how I can determine if my theory is correct?

Also, I plan to test a few more documents, I just need to get the user to leave his notebook at the office.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34318712
What happens if you open a word document, don't change anything, save it under a new name in the same location and try re-opening it?
Years ago after some sort of Office upgrade I recall a situation like this, but I can't remember the cause. I do remember the original file was quite large, but when re-saved it became significantly smaller.
0
 

Author Comment

by:gordoninhawaii
ID: 34320716
Hi RobWill,
Glad to have you back, started feeling a little  lonely out in this special part of the world, was getting no feedback for a few days.  I will try your suggestion later today.  Still does not make a lot of sense, I thought for sure the problem was shared folders.  Now it is pointing to files?????  Wish the user would get back so I could get my hands on his machine.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34320731
It is definately an odd issue.
I still think I should fly out and help, down to 40 degrees here now. :-)
0
 

Author Comment

by:gordoninhawaii
ID: 34337575
I am waiting for the client to get back from trip.  He has the notebook I have been using to resolve the problem.    Sorry working as fast as I can on the issue.  Please do not drop this issue, it is killing me.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34337772
No Problem. Just post something every couple of weeks (<21 days) and it will stay open indefinitely.
0
 

Author Comment

by:gordoninhawaii
ID: 34338305
Got an appointment tonight to give your request a try should have something tomorrow.
0
 

Author Comment

by:gordoninhawaii
ID: 34341057
Hey RobWill,
I tried your idea about copying the file into the same directory and open the copy file.  That did not help, but check this out.

I can create the problem and fix the problem, but on a file basis.  Here is how.

1. open the slow file and save it as an RTF file in the same directory.  After this is done the file opens pretty fast, about 3 seconds.
2. open the RTF file in Word and save it back as a DOC.  Opens in about 1 second.
Problem sort of fixed, but I can't do this to about 20,000 files.
What is causing this problem.  Since the test carries the fonts all with the copies, my idea is shot.  Something happens when I save the file to a RTF format that makes things work.  I say that because I tried your idea first, which was to make a copy of the slow file, word to word.

Any ideas?

Aloha
gordon
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34342557
It does sound like it has to do with the Word formatting within the document. I wonder if at this point it would be more productive to post a question with those specific results in the Word topic area:
http://www.experts-exchange.com/Software/Office_Productivity/Word_Processors/Word/
0
 

Author Comment

by:gordoninhawaii
ID: 34364984
ok, I submitted an ASK to that group, we will see and I will let you know if anything comes of it.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34365045
I subscribed to the question. I will follow along. I am interested to hear any responses.
--Rob
0
 

Author Comment

by:gordoninhawaii
ID: 34389104
Still waiting for client to get back.  He is on the mainland doing a depo in Calif.  Should be back on Monday and I will do the things requested to Word.
0
 

Author Comment

by:gordoninhawaii
ID: 34608019
I have tried a number of things and continue to follow down the paths given to me by the experts.  I continue to run into issues at the site itself, trying to get the computers I used to test with.  They are used by the attorneys and in some cases the notebook can't be given out due to the data being stored.  The problem has not gone away and I am continuing the efforts to fix the problem.  With no answer coming to the surface we are considering going to Microsoft to get it resolved.  I am saddened by this as every time until this problem the site has always come through with an answer.  If anyone else is out there that thinks they may have a solution please step forward.

I have been and will be responsible to the EE membership.

Gordon
0
 

Author Comment

by:gordoninhawaii
ID: 34740323
We have no solution at this time.  A call to Microsoft has been placed and a tech has been assigned.  I will post the results.  I think you show keep this poblem alive as the results could help a lot of people.
0
 

Author Comment

by:gordoninhawaii
ID: 34740326
please consider keeping open as the results I get from Microsoft may help others
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34741517
Yes if possible please do Lee. I am very curious as to the outcome as well.
Thanks,
--Rob
0
 

Accepted Solution

by:
gordoninhawaii earned 0 total points
ID: 34838843
This is working on the documents I have tried so far.  Will continue to test this weekend and post results.
Gordon

When opening Microsoft Excel 2003 files in Microsoft Office Excel 2007 without having Excel 2007 already running you may find that files that a long time to open (20-60 seconds) while Excel 2007 or even Microsoft Office Word 2007, PowerPoint 2007 files take only a portion of that time to load.
The solution to this problem is easy and does not require any additional software other than the standard Microsoft Windows Explorer.
1.Open Windows Explorer (explorer.exe)
2.Select Tools | Folder Options from the menu
3.Go to the File Types tab.Excel 2007 - Folder Options in Windows Explorer

4.Select list item XLS (Microsoft Office Excel 97-2003 Worksheet) and click on Advanced.
Excel 2007 - Folder Options in Windows Explorer, Editing Action for Microsoft Office Excel File Type
Excel 2007 - Folder Options in Windows Explorer, Editing Action for Microsoft Office Excel File Type (Rolled Up)
If the “Application used to perform action:” field the default value should be “C:Program FilesMicrosoft OfficeOffice12EXCEL.EXE” /e” . Change this to “C:Program FilesMicrosoft OfficeOffice12EXCEL.EXE” /e “%1¿ . Remember to enclose the full excel.exe path and %1 in parenthesis. Since Windows 95 this is a way to escape spaces in file names; %1 will return the file name of that file that is being opened by double-clicking.You can uncheck “U se DDE” but Microsoft Office Excel 2007 will bring it back to what you see above when you next open it.
 

5.Just confirm (hit “OK” ) on all the Microsoft Windows Explorer dialogs and next time you open a Excel 2003 file in Excel 2007 without having it already running you won’t have to wait!
6.If the above listed steps don’t fix the problem, simply add the Lookup Wizard add-in in Excel. Some readers have reported that solved the problem for them! To install it click the Office Button, Excel Options, Add-Ins, and then click Manage Excel Add-ins | Go on the bottom of the window, select Lookup Wizard and click OK!
0
 

Author Comment

by:gordoninhawaii
ID: 35033675
please see entry above yours.  This  solution came from a friend and it seems to be working.  Microsoft sucks they have done nothing for us.
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 35034389
Please go on and accept your own answer then. You are responsible for closing your questions when solved, and award points as appropriate.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
Office 365 is currently available in five editions. Three of them are for business use: Office 365 Business Essentials, Office 365 Business, and Office 365 Business Premium. Two of them are for home/personal use: Office 365 Home and Office 365 Perso…
In a previous video Micro Tutorial here at Experts Exchange (http://www.experts-exchange.com/videos/1358/How-to-get-a-free-trial-of-Office-365-with-the-Office-2016-desktop-applications.html), I explained how to get a free, one-month trial of Office …

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now