• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 977
  • Last Modified:

OSX Not seeing internal network

We have 1 mac on the network that is unable to get to OWA from inside the network, when it leaves the LAN it is able to reach OWA and the mx entry to get email in entourage.

This mac seems unable to resolve any internal DNS entries via ping, safari, or most programs, though when using MS RDP client it does seem to resolve the hosts. It has no problems making it to external hosts (like google)

I've restarted services on the server and of course the mac. Because it will not see the internal addresses I am unable to rejoin it to the active directory.

Other machines, and other macs are having no problems connecting.
0
ckoning
Asked:
ckoning
  • 3
  • 3
  • 2
  • +3
1 Solution
 
woolnoirCommented:
are you using one word hostnames or fully qualified for your servers, i.e

servername -or-

servername.domainname.com

if its single names, do you have a DNS suffix defined within network preferences ?
0
 
woolnoirCommented:
and what DNS server is the mac using internally ? can you do a nslookup and show the output when you type 'servername' for one of the servers you are trying to reach.
0
 
ckoningAuthor Commented:
the DNS is the local AD/DNS server is handling DNS

 It does list correctly with NSLookup, both for internal and external domains
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
woolnoirCommented:
so it works ok with nslookup, can you check your domain suffix, within system preference >> network. Check that it lists your domain there i.e

domain.com as one of the options.
0
 
marookCommented:
In terminal:
ipconfig getpacket en0
-> output what ever you got from the DHCP server via ethernet.
-> If you use AirPort, replace en0 with en1 Verify it's correct.

Do you by chance have a static DNS server set on that Mac?
Have anyone created a 'hosts' file? (/etc/hosts)

If you use nslookup or dig in Terminal, what server is providing the reply?
0
 
Parrish ChamberlainService and Delivery Quality and Take on Manager ITCommented:
Turn of IPv6  on Ethernet 1 options from Sytem preferences network
Disable/turn off Airport (if the device has airport), in the network device order move airport to the bottom.
If you use a proxy make sure you add entries to state no proxy for *.fqdn of the owa.
Restart teh mac and see if this makes a difference
0
 
ckoningAuthor Commented:
It lists correctly with both shortnames and full names with the nslookup.

It appears that update 10.6.5 could be the culprit, after updating it seems the next system is showing the same symptoms.
0
 
Parrish ChamberlainService and Delivery Quality and Take on Manager ITCommented:
There is an issue with 10.6.5 and the FQDN, DNS and username combination exceding 25 characters, the bonjour name also effects this.
Check al the naming conventions are the same for System options above.
 Did you check the network prefernces as listed in my last comment?

Technocity
0
 
blue-screenCommented:
This sounds like you are running a split DNS - Are your inside addresses of the form 10.x.x.x, 172.16.x.x or 192.168.x.x?  

My guess is that the MAC is set to use an external DNS server, and gets the "global" address instead of the local address when inside the network.  

The non-MACs probably use WINS to get around this problem

3 options:

- Tell the MAC to get DNS server info from the DHCP server.  I bet it has a statically configured (external) DNS server.

- Set up the MAC to use WINS.  It will use WINS inside, and DNS outside.

- Set up the firewall/router to do "DNS fixup" (this varies by vendor).  In the case, DNS replies referring to an external address will be altered to the appropriate internal address based on the mapping table.

Tests:

Look at the Network control panel on the MAC - Advanced settings - see if the DNS server is manually set.  
http://macs.about.com/od/networking/qt/configure-your-macs-dns.htm

Delete the manual DNS entries using "-" .

NEVER turn off IPV6.  You will be needing it in the future.

0
 
marookCommented:
>NEVER turn off IPV6.  You will be needing it in the future.

Ahh.. ALWAYS turn off IPv6 in a LAN, as it's NEVER used, and only add to troubleshooting.
And IPv6 has (had) some huge bugs that made some Mac's fails...

If you don't have any IPv6 in DHCP and Routing, why in the world enable it!?!
And if you at some point enable IPv6 on the LAN, I guess you will know and be able to turn it back on!
0
 
blue-screenCommented:
As an IT professional you should be ACTIVATING IPv6 up in your LAN, not disabling it.  Get used to it.  As IPv4 runs out, you will need to go to IPv6 in order to reach all useful resources on the greater Internet.  Getting in the habit of turning it off will put you behind the adoption curve.

0
 
Parrish ChamberlainService and Delivery Quality and Take on Manager ITCommented:
WHen the internal infrastructure has IPV6 running then you can turn it back on.  The enterprise I work for currently does not have IPV6 enabled on Servers or Switches.  This issue occurs on all macs if I dont turn of IPV6.  Ther is a significant increase in software application loading and network access.

This issue also occurs with Windows 7 on a network infrastructure that does not have IPV6 implemented.

You can try it, if it doesn,t work turn it back on.

Cheers
0
 
Kash2nd Line EngineerCommented:
have you tried using open DNS instead of your dedicated DNS and see if it works. 208.67.220.220, 208.67.222.222

could be a simple DNS resolution issue.
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

  • 3
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now