Solved

Limited or not connectivity across my network

Posted on 2010-11-11
31
583 Views
Last Modified: 2012-05-10
I know that this issues comes up a lot, but the specifics of this situation are quite unusual. I admin a network in my small office - 8 desktop terminals (wired), 2 laptops (wireless).

**ALL TERMINALS RUNNING WINDOWS XP SP3**

This morning, when turning on, like we do every day, nothing I am aware of having changed, two of the computers are able to connect to the network, but not to the internet (Limited or no connectivity coming up on the network icon in sys tray).

More over, one of the terminals acts as a file share system for other people to work out of - it is one of the terminals that cannot access the internet, but more over all the omcputers that CAN access the internet still cannot access the shared files on this PC.

You would think that this PC has a network issue, but weirdly, the one other computer that can't access the internet, CAN access the shared folders on it - suggesting network connectivity ok.

I know this is really complicated so I have drawn an image to help explain - this is a network map, with the status of each of the terminals illustrated:

 Map of Network with problems illustrated
THINGS ALREADY ATTEMPTED:
- Turning off the router and the switcher, restarting.
- Restarting computers having issues
- Changing network cables
- Manually setting network IP for terminals unable to get to internet

I probably haven't explained this perfectly, I think this issue seems complex so it is well worth the full 500 points if anyone can come to my aid!
0
Comment
Question by:gideonjones
  • 13
  • 9
  • 7
  • +2
31 Comments
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34110878
Looking at the diagram and may have tried this swap S1/T6 with T4/T5 you may have dead switch ports
0
 
LVL 2

Expert Comment

by:gentle0000
ID: 34110895
Hi,

You will to make tests to find out the resolution on this.

1. Ping from every machine to
   a. the S1
   b. the 74.125.79.147
   c. www.google.com

2. From S1 ping
   a. the Zyxel
   b. the 74.125.79.147
   c. the www.google.com

3. From S1 check the name resolution
    a. nslookup (enter)
    b. www.google.com

The results from this tests, will give the start of your solution.

If we assume that
1. There is no hardware problem on the Lan ports of the switch or router
     (test them by changing the position of s1 machine on switch port)
2. There is no problem with Windows Firewall (Disable them)

Then there is infection on the network. So start scan it.

With Regards,
 

 
0
 

Author Comment

by:gideonjones
ID: 34110927
Hey, thanks for commenting.

I've tried physically switching the network cable for T6 out of the socket it is in in the switcher, into the socket that T5 is using, but no difference. Also T5 continues to get full internet access, after this switch has occurred.
0
 

Author Comment

by:gideonjones
ID: 34111089
@gentle0000 - thanks! here are the results:

TESTS RUN ON ALL MACHINES:
1. Ping from every machine to S1:
TIMES OUT from T1 - T5
DESTINATION HOST UNREACHABLE on T6

2. Ping to 74.125.79.147
T1 - T5 4 packets sent, 4 received, all good
T6 & S1 - destination host unreachable


3. Ping to Google
T1 - T5 - Fine
T6 & S1 - Ping request could not find host... please check name

FROM S1
a. the Zyxel - DESTINATION UNREACHABLE
b. the 74.125.79.147 - DESTINATION UNREACHABLE
c. the www.google.com -  Ping request could not find host... please check name

FROM S1
nslookup (enter) gives: ****Default servers are not available, default servers unknown, address 127.0.0.1
-

sorry, I don't know how to do a name resolution on Google?


ADDITIONAL INFO -

Have tested with all firewalls down, no changes
Have tested physical switching of cables ect no changes there

****Usually the IP addresses of terminals on my network are all 192.168.1.XXX with each terminal just being an address at the end of this.... now S1 is claiming (using ipconfig) that it's IP address is 169.254.227.116 which I haven't seen before. Any relevance?
0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34111163
With your last comment, we can say you have an DHCP issue.
Probably on your network you had a DHCP server (the router probably), and now it is misconfigured (or stopped).

So, S1 try to contact a DHCP server, and fail. It uses APIPA address (169.254.x.y).
All others computers are configured with IP address 192.168.1.x
Therefore all others computers cannot reach S1 as they are not on the same subnet.

Try configuring your S1 with static IP address
IP: 192.168.1.x where x is not used by any other computer on your network
Mask: 255.255.255.0 most probably (verify on T1 to T5)
Gateway: IP of Zyxel router

DNS: Probably your ISP, verify on T1 to T5 to have the values. All these computers are correctly configured as they have access to Internet.

Hope this help.
0
 

Author Comment

by:gideonjones
ID: 34111294
@ Tasmant,

Thanks for the input - I'm not certain I can follow all your advice, so I might need some help.

When you say configure S1 to have a static IP, I have done the following, is this what you meant?
Opened Network connections - openede properties of the LAN, selected TCP/IP gone to those properties and then manually entered the suggested details.

On going this, I loose the "exclamation mark" signifying limited or no connectivity on the network status icon, however - I cannot access the internet, and a ping request from a terminal (T3) to S1 on its new static IP, results in "Request Timed Out"


With regard to your DNS comment, on all the terminals T1 to T5 the nslookup seems positive,  I get a response from Default server and it gives a non local IP address.
0
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34111376
If Tasmant does not work (I would suggest DNS set to zyxel) then on T6/S1 run command

netsh winsock reset
netsh winsock reset catalog
netsh interface ip reset C:\DAF-interface-resetlog.txt
netsh interface reset all
netsh firewall reset

then repair winsock if not resolved using this tool

http://www.softpedia.com/get/Tweak/Network-Tweak/WinSockFix.shtml

If the above work then need to scan for malware etc....



0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34111383
It's ok what you did.

T1 to T5 are probably configured with DNS server of you Internet Service Provider, which is a public IP address. You need to set up T6 and S1 to use this public IP address as DNS server.

But basically, i think they're an issue with Terminal configuration for the moment. Unless each terminal has firewall on them that unallow the ping request, you should be able to ping.

Could you verify your firewall settings, especially on T6 and S1.
If you lose the limited network connectivity icon, then i think your computer is able to go over Internet.
On S1, could you try to ping 8.8.8.8 (Google DNS server: outside your network).

Could you ping from S1 your gateway (Zyxel internal IP) ?
Thanks.
0
 

Author Comment

by:gideonjones
ID: 34111532
@ Problem solver:

thanks for that - I will implement once I have finished following Tasmant if not successful

@Tasmant

Firewall settings - I've turned them all off for now while trying to fix this. There was only Windows firewall on them anyway, and now it is disabled.

As before limited connectivity yellow exclamation mark is absent... (with the IP address defined), but no net connectivity, pinging 8.8.8.8 times out

When I ping Zyxel from S1 I get: request timed out.

I am currently forcing S1 to occupy 192.168.1.111
0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34111563
Could you provide us network configuration of:
- Zyxel Router
- One of the T1 to T5 terminal
- S1 configuration
0
 

Author Comment

by:gideonjones
ID: 34111577
sorry - don't understand exactly what you mean by the network configuration of any of those things... do you mean their IP addresses? I suspect you want more than that... if you could specify / let me know how to get the information that would be much appreciated. Thanks
0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34111610
ipconfig /all by example on each terminal
for the router i suppose you can configure it using http://iprouter: and review it's configuration the same way.

we need ip adress, mask, gateway, dns server for the Zyxel
0
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34111764
Just check
 IE menu... goto Tools... Internet Options... Connections... Lan settings.... and under 'Proxy Server'  make sure it is not ticked.

If it is I suspect malware or a rootkit is there; they tend to put a proxy in place as first defence against removal and often disable dhcp
0
 

Author Comment

by:gideonjones
ID: 34111777
ok thanks! I'll post when i get back from lunch...

01-Nov.-11-14.15.jpg
0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34111834
What is the Ethernet adapter Hamachi ?
Otherwise the other network adapter is ok. Waiting the others.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34112128
Hamachi is a VPN network like logmein
0
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34112184
Looking at the lease time, which indicates the DHCP server is working and issuing leases, I would tentatively suggest that whilst fixing the IP and DNS might resolve the problem it doesn't actually get to the cause as to why DHCP is failing on these 2 PCs. As such would suggest trying my previous suggestions.
0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34112582
Agree with you Problem Solver. the network map show T4 and T5 having access to Internet, so DHCP work across the swith. Need to wait S1 and T6 IP configuration to view more details. Proxy settings are a good idea to check. Winsock reset is a next step.
0
 

Author Comment

by:gideonjones
ID: 34113062
sorry for delay - and sorry for partial post above, was going to post all three together, forgot i started already! ok, so please see below the ipconfig /all for T6 and S1

I don't know how to give you the network settings for the router, other than to tell you that it sits at IP 192.168.1.1


S1-ipconfigALL.JPG
T6ipconfig-ALL.JPG
0
 
LVL 11

Expert Comment

by:Tasmant
ID: 34113296
It seems that the configuration you set up in a post is no more there ...

Try to run :
- ipconfig /release
- ipconfig /renew
on S1 and T6. It seems they're unable to have a correct IP.
- ipconfig /all
You should have the same things than for T2 (see the attached image), except for the last digit of IP Address.

If you're unable to get the same settings, i would suggest to configure those host with static IP
- Opened Network connections
- Opened properties of the LAN
- Selected TCP/IP gone to those properties and then manually enter the suggested details (following screen). Just enter different number in the red case for each host T6 and S1.
- Don't forget to click OK while you can.

Once done, verify the configuration with
- ipconfig /all, you should have the same settings as you just entered before.

As Problem solver said :
Go To:  IE menu... goto Tools... Internet Options... Connections... Lan settings.... and under 'Proxy Server'  make sure it is not ticked.
Nothing should be check, unless "detect automaticaly proxy ..." but it's not useful here, you can uncheck it.



01-Nov.-11-14.15.JPG
ipconfig.JPG
0
 

Author Comment

by:gideonjones
ID: 34119276
Apologies Tasmant, I did indeed remove those static IP settings I had previously set, as with them not there T6 was able to access the files on S1 (same subnet mask) which was required, so I temporarily reset them back to whatever s1 was choose by default.

However, I have now  run release and renew:

release worked, renew prompted the message (after some time) Failed... unable to connect to your DHCP server... timed out

I went back to input the static ip and DNS preferences you show above, the ipconfig now looks like:

 S1 inconfig all after foreced IP settings
I have also confirmed that there are no proxy settings (boxes are not checked) on  T6 and S1
0
 

Author Comment

by:gideonjones
ID: 34119280
oh... forgot to mention, the above did not fix the issue.

shall I proceed with those winsock reset instructions?
0
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34119364
Only briefly in before going out on road to some repair jobs. Yes proceed with winsock reset, but not forgetting obvious try a system restore first on the afflicted PCs.
0
 

Author Comment

by:gideonjones
ID: 34119373
system restore? Not sure what that is - other than just a restart? I'll run the winsock suggestions now, thanks for the continued support
0
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34119386
All Programs > Accessories > System Tools > System Restore

MS rollback feature to previous date when things worked
0
 

Author Comment

by:gideonjones
ID: 34119609
Using S1 as a test system:

Have applied system restore to a date when it was working - No symptoms fixed

Have entered into CMd all of the following

netsh winsock reset
netsh winsock reset catalog
netsh interface ip reset C:\DAF-interface-resetlog.txt
netsh interface reset all
netsh firewall reset

no change after that either.

I then downloaded and ran winsock fix, it ran, i restarted, no change there.

I have re run ipconfig /all an it is as per my last screen shot (as after the system restore I reapplied the fixed IP settings)

I have also, parallel to this (after your discussion of malware) uninstalled my paid AVG which i was running on T6 and installed kapersky anti virus 2011 and have run a scan of this machine - no threats of any kind were found.
0
 
LVL 8

Expert Comment

by:dosdet2
ID: 34123142
Can you try to boot S1 into Safe mode with networking and see if you can ping your default gateway IP?
0
 
LVL 2

Accepted Solution

by:
Problem_Solver earned 500 total points
ID: 34125580
Thanks for trying all this, seems hard work, but has to be done before this suggestion which will sound odd and possibly unaceptable. In the last 10 years I have had this happen on 3 machines as you describe, my fix was to install a second network card, which then worked fine. for the price of a few pounds or dollars it is worth doing. I had in one organisation 2 fujitsu siemens PCs hit 7 others by other manufacturers fine following a power cut. The symptoms were almost identical, had forgotten; getting old...

The other things have to be done first as thy are most common and possibility virus on a network takes priority, but network failure of the cards does occur, although rare. Your experiences fit with this.
0
 
LVL 2

Expert Comment

by:Problem_Solver
ID: 34342055
Any closure on this?
0
 

Author Comment

by:gideonjones
ID: 34710082
my apologies for not noticing I hadn't closed this question - Problem solver: I tried all the above, and finally did as you suggested - a new £10 network card installed on the two machines fixed the problem - thanks very much!
0
 

Author Closing Comment

by:gideonjones
ID: 34710093
thanks for the support
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Load balancing is the method of dividing the total amount of work performed by one computer between two or more computers. Its aim is to get more work done in the same amount of time, ensuring that all the users get served faster.
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now