Solved

Exchange 2003 problem

Posted on 2010-11-11
12
1,062 Views
Last Modified: 2012-08-13
I am using Exchange 2003 SP2.  Since a week, it as crash 3 time with this error: MAPI or on unspecified service provider.  ID no c1050476.  See image for complete error.



It seems to always happen during the backup.  We are using backup Exec to backup the store.  The backup seems always stop at the same spot.  After a server reboot, all is well again.

What can be the problem and how to resolve this?

Thank you. Complete error message.
0
Comment
Question by:pctechaegera
  • 5
  • 4
  • 3
12 Comments
 
LVL 9

Expert Comment

by:losip
ID: 34111815
Perhaps the Backup Exec service account does not have the right permissions to the Mdbdata folder and the root of the drive that contains the mdbdata folder.  You may need to check what account Backup exec is using and make sure that the ACLs on the Exchsrvr\mdbdata folder include at least Modify, Read and Execute, List Folder Contents, Read, Write permissions or that the appropriate account is a member of a group that has these rights.
0
 

Author Comment

by:pctechaegera
ID: 34112107
I double check and all is good.  After a reboot, the backup work fine as it always did for many mounts now.
0
 
LVL 9

Expert Comment

by:losip
ID: 34112116
So the problem has gone away?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:pctechaegera
ID: 34112176
The problem will reoccur.  It was fix with a reboot but reoccur after few days...
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 34112534
It could well be a corrupt mailstore.  Do you see an ESE errors on the Application Event log?
If you do - please dismount the store and run the following from a command prompt:
eseutil /p "x:\program files\exchsrvr\mdbdata\priv1.edb"
eseutil /d "x:\program files\exchsrvr\mdbdata\priv1.edb"
isinteg -s servername -fix -test alltests
Run isinteg until you see 0 errors and 0 fixes in the last line of the output.
When you dismount the store, users will lose access to the mailstore, so it is best done out of hours (if that is ever possible!).
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34112549
Please run the above commands from the c:\program files\exchsrvr\bin folder and substitute x: for the drive letter that the Exchange Database is located on.
You will need plenty of free space to run the commands - up to 110% of the mailstore database size to run the commands successfully.
0
 

Author Comment

by:pctechaegera
ID: 34112833
This are the error I am getting.  It turns out the error occur way before the backup start.  So there might not be any relation between the 2.


Event Type:      Error
Event Source:      ESE
Event Category:      General
Event ID:      482
Date:            11/10/2010
Time:            5:06:12 PM
User:            N/A
Computer:      SVR-AEG-06
Description:
Information Store (4380) Aegera_mtl_users: An attempt to write to the file "D:\Exchange_data\Aegera_mtl_users\E01.log" at offset 2737664 (0x000000000029c600) for 512 (0x00000200) bytes failed after 0 seconds with system error 1784 (0x000006f8): "The supplied user buffer is not valid for the requested operation. ".  The write operation will fail with error -1011 (0xfffffc0d).  If this error persists then the file may be damaged and may need to be restored from a previous backup.

For more information, click http://www.microsoft.com/contentredirect.asp.


-------------------------------------------------------------------------------------------------------------------------------------------------------
Event Type:      Error
Event Source:      ESE
Event Category:      Logging/Recovery
Event ID:      414
Date:            11/10/2010
Time:            5:06:12 PM
User:            N/A
Computer:      SVR-AEG-06
Description:
Information Store (4380) Aegera_mtl_users: Unable to write to section 0 while flushing logfile D:\Exchange_data\Aegera_mtl_users\E01.log. Error -1011 (0xfffffc0d).

For more information, click http://www.microsoft.com/contentredirect.asp.
-------------------------------------------------------------------------------------------------------------------------------------------------------
Event Type:      Error
Event Source:      ESE
Event Category:      Logging/Recovery
Event ID:      492
Date:            11/10/2010
Time:            5:06:12 PM
User:            N/A
Computer:      SVR-AEG-06
Description:
Information Store (4380) Aegera_mtl_users: The logfile sequence in "D:\Exchange_data\Aegera_mtl_users\" has been halted due to a fatal error.  No further updates are possible for the databases that use this logfile sequence.  Please correct the problem and restart or restore from backup.

For more information, click http://www.microsoft.com/contentredirect.asp.
------------------------------------------------------------------------------------------------------------------------------------------------------
Event Type:      Error
Event Source:      MSExchangeIS
Event Category:      General
Event ID:      9558
Date:            11/10/2010
Time:            5:06:12 PM
User:            N/A
Computer:      SVR-AEG-06
Description:
An error occurred while writing to the database log file of storage group "Aegera_mtl_users". Attempting to unmount all databases in this storage group.

For more information, click http://www.microsoft.com/contentredirect.asp.
------------------------------------------------------------------------------------------------------------------------------------------------------
Event Type:      Error
Event Source:      ESE
Event Category:      Logging/Recovery
Event ID:      471
Date:            11/10/2010
Time:            5:06:12 PM
User:            N/A
Computer:      SVR-AEG-06
Description:
Information Store (4380) Aegera_mtl_users: Unable to rollback operation #1049818 on database D:\Exchange_data\aegera_mtl_users\K-O.edb. Error: -510. All future database updates will be rejected.

For more information, click http://www.microsoft.com/contentredirect.asp.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34112956
If this error persists then the file may be damaged and may need to be restored from a previous backup.
Possible disk corruption, so I would take the server down after asking it to run a disk check on the volume where Exchange is installed.

0
 
LVL 9

Expert Comment

by:losip
ID: 34112964
Yes, sounds like database corruption.  Try Alan's suggestion
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34112984
0
 

Author Closing Comment

by:pctechaegera
ID: 34132958
Thanks, it worked.  Best regards,
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132965
Great news - glad it worked - thanks for the points.

Alan
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
Find out what you should include to make the best professional email signature for your organization.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question