Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Bad mask /29 for address

Posted on 2010-11-11
3
Medium Priority
?
2,836 Views
Last Modified: 2012-05-10
Today I switched from a dynamic IP to a block of 5 static IPs from AT&T.  I went into my config to change the int dialer 1 from dynamic to IP.

conf t
int dialer 1
ip address 99.28.107.224 255.255.255.248

and the router proceeded to tell me:

Bad mask /29 for address 99.28.107.224

Maybe I'm missing something in my config.  AT&T has confirmed both the IP address and the subnet.  Below is my current config.


Using 2333 out of 29688 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Grasshopper
!
logging queue-limit 100
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password parisfr
!
username admin privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
username iwindon privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
memory-size iomem 10
aaa new-model
!
!
aaa session-id common
ip subnet-zero
!
!
ip name-server 68.94.156.1
ip name-server 68.94.157.1
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
ip dhcp excluded-address 192.168.1.5
ip dhcp excluded-address 192.168.1.6
ip dhcp excluded-address 192.168.1.7
ip dhcp excluded-address 192.168.1.8
ip dhcp excluded-address 192.168.1.9
!
ip dhcp pool local
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
vpdn enable
!
vpdn-group pppoe
 request-dialin
  protocol pppoe
!
!
!
!
!        
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Dialer1
 mtu 1492
 ip address negotiated <<-- this is where I'm trying to change from dynamic to static.
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer pool 1
 ppp pap sent-username attreg@att.net password 0 attreg <<-- temp username and passwords
 ppp ipcp dns request
 ppp ipcp wins request
 ppp ipcp address accept
!
ip nat inside source list 1 interface Dialer1 overload
ip http server
ip http authentication local
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
!        
!
!
access-list 1 permit any
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
dialer-list 1 protocol ip permit
!
radius-server authorization permit missing Service-Type
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
privilege configure level 15 line
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 password xxxxxxxxxx
!
!
end

Any ideas?

Ivan
0
Comment
Question by:Ivan_Windon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 2000 total points
ID: 34112830
With 99.28.107.224/29 the first usable host IP address is 99.28.107.225 , the last usable address in that subnet is 99.28.107.230
99.28.107.224 is the address of the network itself, 99.28.107.231 is the broadcast address.
You can't use a network address as a host address!
wmp
0
 

Author Comment

by:Ivan_Windon
ID: 34112871
I must be tired.  I should have know that.  Now I feel stupid <G>.  Thanks for putting me back on track.
0
 

Author Closing Comment

by:Ivan_Windon
ID: 34115323
Thanks again for the help again.  Just needed to put the right IP in the router in the first place.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: rfc1180
The Maximum Segment size (MSS) is an important consideration when troubleshooting connectivity via the Internet/Intranet. As the packets are routed via the Internet/Intranet, the packets must traverse through multiple routers in the path between two…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question