Link to home
Start Free TrialLog in
Avatar of Ivan_Windon
Ivan_WindonFlag for United States of America

asked on

Bad mask /29 for address

Today I switched from a dynamic IP to a block of 5 static IPs from AT&T.  I went into my config to change the int dialer 1 from dynamic to IP.

conf t
int dialer 1
ip address 99.28.107.224 255.255.255.248

and the router proceeded to tell me:

Bad mask /29 for address 99.28.107.224

Maybe I'm missing something in my config.  AT&T has confirmed both the IP address and the subnet.  Below is my current config.


Using 2333 out of 29688 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Grasshopper
!
logging queue-limit 100
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password parisfr
!
username admin privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
username iwindon privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
memory-size iomem 10
aaa new-model
!
!
aaa session-id common
ip subnet-zero
!
!
ip name-server 68.94.156.1
ip name-server 68.94.157.1
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
ip dhcp excluded-address 192.168.1.5
ip dhcp excluded-address 192.168.1.6
ip dhcp excluded-address 192.168.1.7
ip dhcp excluded-address 192.168.1.8
ip dhcp excluded-address 192.168.1.9
!
ip dhcp pool local
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
vpdn enable
!
vpdn-group pppoe
 request-dialin
  protocol pppoe
!
!
!
!
!        
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Dialer1
 mtu 1492
 ip address negotiated <<-- this is where I'm trying to change from dynamic to static.
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer pool 1
 ppp pap sent-username attreg@att.net password 0 attreg <<-- temp username and passwords
 ppp ipcp dns request
 ppp ipcp wins request
 ppp ipcp address accept
!
ip nat inside source list 1 interface Dialer1 overload
ip http server
ip http authentication local
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
!        
!
!
access-list 1 permit any
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
dialer-list 1 protocol ip permit
!
radius-server authorization permit missing Service-Type
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
privilege configure level 15 line
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 password xxxxxxxxxx
!
!
end

Any ideas?

Ivan
ASKER CERTIFIED SOLUTION
Avatar of woolmilkporc
woolmilkporc
Flag of Germany image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Ivan_Windon

ASKER

I must be tired.  I should have know that.  Now I feel stupid <G>.  Thanks for putting me back on track.
Thanks again for the help again.  Just needed to put the right IP in the router in the first place.