Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2155
  • Last Modified:

Office 10 and Calibri font problems

We have a range of PC's which we upgraded from the previous Office version to Office 10.

After the upgrade the Calibri font does not print (on Xerox Phaser printers or into PDF's) correctly. It misses out some characters, for example X and K.

Calibri isn't embedded in the printers, but then it worked fine before Office 10.

The font does display correctly on screen.

If Calibri had been screwed up generally across Office 10 I would expect lots of hits on the problem in Google, but there doesn't seem to be a general problem, just us, hence the 500 points.
0
kcrane
Asked:
kcrane
  • 3
  • 3
1 Solution
 
athomsfereCommented:
You recently upgraded to Office XP? (Office 10 is XP or 2002, 2003 is 11)

Or 2010?

Is the calibri font installed on the print server, or is this direct attached?
0
 
kcraneAuthor Commented:
Ah, sorry. We upgraded to Office 2010.

Um, good question about print server. The Phasers are all network attached, and I'm pretty sure we talk to them through the SBS server... so it may not have Calibri, though we didn't change anything from when we used Office 2007, which did work OK.
0
 
kcraneAuthor Commented:
It is printing through the SBS server, which has SBS 2007 installed
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
athomsfereCommented:
Actually, it appears 2010 uses a new version of Calibri. This may be your issue.

So it appears you can either revert the system back to 5.0 that came with 2007 or install the newer version over the top on the server.

BUT, you mentioned PDFs too, so perhaps the need to is the old version after all.
0
 
athomsfereCommented:
Also another solution appears to be this, for exactly your problem.

Worth a shot:

   1. Click Start, and then click Run
   2. Type intl.cpl, and then click OK.
   3. Click the Languages tab.
   4. Under Supplemental language support, click to select the Install files for complex script and right-to-left languages (including Thai) check box.
   5. When you receive the following message, click OK to close the message:
      You chose to install the Arabic, Armenian, Georgian, Hebrew, Indic, Thai and Vietnamese language files. This will require 10 MB or more of available disk space. The files will be installed after you click OK or Apply on the Regional and Language Options dialog box.
   6. Click OK to close the Regional and Language Options dialog box.
0
 
kcraneAuthor Commented:
Well done athomsfere.

I haven't fixed it properly, but I'm on the way as when I set up to print direct and not through the SBS, it worked.

0
 
LeaditCommented:
Athomsfere that worked perfectly for me! Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now