Solved

Executing custom command from menu causes error

Posted on 2010-11-11
4
695 Views
Last Modified: 2012-05-10
With ACT 2011: I created a custom command linked to an ACT WP tpl file. I added it to a menu. When I click the menu entry the error below appears. The template works correctly if I use Write>Email Message (from template) or Write>Mail Merge.

Is there something else I need to do?
act-error.jpg
0
Comment
Question by:Scott Helmers
  • 2
4 Comments
 
LVL 7

Expert Comment

by:50cal
ID: 34118710
Can you show your custom command setup?
It will also merge to word rather than e-mail.

50cal.
0
 
LVL 5

Assisted Solution

by:HighlanderX
HighlanderX earned 100 total points
ID: 34119190
50Cal is correct, the issue may be that any custom commands you create will only allow you to use the word prosessor and and email.

Because email's are in HTML there are no page restrictions, despite the fact you may have created the template in the ACT WP which shows you an A4 page.  The effect of this can be seen in Microsoft Word if you take a document and change the view from Pint Layout to Web Layout - note the fact there are no margins or natural line breaks in Web Layout.

One workaround if you do want this mail-merged to the WP through your custom command, is to play with the margins of your original template, making them stupidly large and then stupidly small until you find the correct balance for the process to work correctly.
0
 
LVL 30

Author Comment

by:Scott Helmers
ID: 34119952
When I created the custom command I just browsed to the tpl file as you can see in the attached image. I've just discovered that if I enclose the path/file name in quotes I don't receive the error shown above and the document opens in edit mode in ACT WP. Apparently what caused the error was that my path name had spaces in it and ACT parsed it incorrectly.

Now that I've enclosed the path/file name in quotes, I guess the real question is: how do I get ACT to use this template to create an email? Do I prefix the path name with a command of some sort?
act-custom-command-dialog.jpg
0
 
LVL 7

Accepted Solution

by:
50cal earned 400 total points
ID: 34122160
Unfortunately you can't, it just opens in Word/Act Word Processor.

50cal.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A lot of users new to ACT!, especially those who don't get the benefit of a consultant, seem confused between when to share on a network and when to sync ... or, in fact, how to do either. So I thought I would attempt to explain the various options …
ACT LINK FOR PEACHTREE WON’T LINK PROBLEM       It always seems that when you upgrade Act or Peachtree Quantum in versions 2009, 2010, 2011, or 2012 then try to relink them it fails. Following the linking instructions-  Go to the peachtree tab in …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now