Outlook Data File Cannot Be Accessed Error: 0x8004010f

Hi,

In Windows 7, I moved the location of a user's My Documents to another drive (D) by right-clicking My Documents, then  Properties/Location Tab/Move. The My Documents folder contains the Outlook .pst data file for the user (I guess this is new in W7?). The user does NOT use Exchange, it is a PST file receiveing email via POP3 from a Yahoo business account.  

After I changed the location of My Documents, I restarted Outlook and as I expected it could not find the .pst file to load. I pointed Outlook to the right location in the D drive D:\Documents\Outlook Files\xxxx.pst and restarted Outlook. It then found the file and loaded the pst successfuly. However, when I hit send/receive I got an error: Task 'User Account Name - Sending' reported error 0x8004010F : 'Outlook data file cannot be accessed.'  There was also the same error for Receiving. I checked and its pointed to the right directory in the D drive.

Dont know if it helps, but I noticed that the first time Outlook started after the .pst move, it created a duplicate My Documents/Outlook Files directory but there was of course nothing in it because it was moved, so I deleted this additional directory.

Thanks
HPPLLCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

governor_arnoldCommented:
I would try re setting up the account in outlook and then import the data from the old pst into the pst that is newly created.

You can import by going to File>Import/export>Import from another program or file>Personal Folder File (.pst)> then locate the old .pst >replace duplicates> choose import to same folder outlook.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HPPLLCAuthor Commented:
The answer worked, however Outlook then wanted to download all over again all 5,000+ emails from the user's inbox so ended up with duplicate emails. But that is easy to correct with a de-dupe application and expert solved the original problem as asked, so A.

Thanks.
0
RonProtronicsCommented:
For an easier solution, try this:
After you have pointed Outlook to your “Data File” via the “Data File” tab.
1. Choose “E-mail Accounts” / “Accounts Settings”.
2. Click the the “E-mail” tab.
3. Look for “Selected account delivers new messages to the following location:”
4. Look for the “Change Folder” button. Beside it you must see a nominated Inbox and path to the selected data file folder. (If there is not shown any email account/folder and path, then Outlook will continually generate various different and confusing error messages such as "Outlook data file cannot be accessed. Repair/reinstall office...” & “Cannot display the folder. Microsoft Outlook cannot access the specified folder location.”) If an “Inbox” folder and path is not shown do the following:
5. Click the button: “Change Folder”.
6. In the “New E-mail Delivery Location” dialogue box, browse for the “Inbox” within your Outlook data file (or create new data file/folder).
7. Click “OK”.
The path to the selected data file should now be shown beside the “Change Folder” button.

Notes: For multiple accounts:
Choose a different folder WITHIN the Outlook datafile, click apply, and then change the delivery location back to the preferred “Inbox”.
If this does not work, Create a new, dummy PST file using the same Account Settings window and “Data Files” tab. Add a new temporary PST file. Then go back to step 4 above where you change the folder to where the selected account saves its email. Choose the PST that you have just added. Then click OK. Immediately go back into that dialog and change the folder location back to the original PST. Do the same for each account, then once done, remove the temporary PST.
If this does not work, you may have to delete and create/add a new e-mail account(s). In the “Account Settings”, select “New...” within in the “E-mail” tab. Select “Manually Configure Server Settings...” and in the “Internet Email” settings box you will see in the lower right corner, "Deliver New Messages to:" “New” or “Existing” Outlook data file. Select “Existing Outlook data file”. Browse to your file location and select your data file.
***********************************

Notes: For Exchange accounts:
If you getting an error on an Exchange account. Go to your Outlook ost and pst files folder. Delete the Exchange OST file and the OBI files. Then re-start Outlook.
0
mikeelamCommented:
RonProtronics... Great solution! Simple, quick and effective.
Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.