Solved

Cisco 2600 router with static IP and ATT

Posted on 2010-11-11
5
546 Views
Last Modified: 2012-05-10
I just changed over from a dynamic IP account with AT&T to a Static IP address.  I have 5 static IPs.  I would like to give one to my router and one for my exchange server for the MX record.

Everything worked fine on the Cisco router when it was on the dynamic side, however now it doesn't quite work.  The router can ping web sites no problem, however I'm not getting onto the internet from the clients anymore.  The router has DHCP setup.  I'm guessing this is a routing issue, but I'm not sure how to go about solving it and just need some help finishing this up.

I'm including my config.  My IPs I have been assigned are:
IP = 99.28.107.224 - 231 SN = 255.255.255.248  DG = 99.28.107.230



!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Grasshopper
!
logging queue-limit 100
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxxxxxxxxxxxxxxxxx
!
username admin privilege 15 secret 5 $xxxxxxxxxxxxxxxxxxxxxxxxxxx
username iwindon privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
memory-size iomem 10
aaa new-model
!
!
aaa session-id common
ip subnet-zero
!
!
ip name-server 68.94.156.1
ip name-server 68.94.157.1
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
ip dhcp excluded-address 192.168.1.5
ip dhcp excluded-address 192.168.1.6
ip dhcp excluded-address 192.168.1.7
ip dhcp excluded-address 192.168.1.8
ip dhcp excluded-address 192.168.1.9
!
ip dhcp pool local
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
vpdn enable
!
vpdn-group pppoe
 request-dialin
  protocol pppoe

!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Dialer1
 mtu 1492
 ip address 99.28.107.225 255.255.255.248
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer pool 1
 ppp pap sent-username xxxxxxxxxxxxxx@att.net password 0 xxxxxxxx
!
ip nat inside source list 1 interface Dialer1 overload

ip http server
ip http authentication local
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
!
!
!
access-list 1 permit any
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
dialer-list 1 protocol ip permit
!
radius-server authorization permit missing Service-Type
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!

!        
!
privilege configure level 15 line
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 password xxxxxxxxx
!
!
end

Thanks,

Ivan
0
Comment
Question by:Ivan_Windon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 2

Expert Comment

by:omesie
ID: 34117157
Just out of curiosity, when trying to connect to a website using the IP address from a client PC, does that work?  It's possible you haven't set up DNS forwarders to the right IP addresses seeing as you've changed from Dynamic to static, your ISP may have different DNS servers.
0
 
LVL 5

Accepted Solution

by:
BooSTid earned 500 total points
ID: 34117163
Your overload list is suspect.

Change it to

access-list 1 permit ip 192.168.0.0 0.0.0.255 any

Also, get rid of the internal route, not needed.

no ip route 192.168.1.0 255.255.255.0 FastEthernet0/0

I'm also not a fan of your zero route being an interface; send it to the gateway...

ip route 0.0.0.0 0.0.0.0 99.28.107.230
0
 
LVL 9

Expert Comment

by:ken2421
ID: 34117171
It also looks to me like the router is still configured with PPOE information which it will no longer need. It should just be a static ip.

HTH,
Ken
0
 

Author Closing Comment

by:Ivan_Windon
ID: 34117225
I believe it was the ip route 0.0.0.0 0.0.0.0 99.28.107.230 that did the trick.  I'm not 100% why yet (haven't had time to do the research), however on my router it doesn't like it if you say access-list 1 permit ip 192.168.0.0 0.0.0.255 any, it complains at the any part.  I have to just put access-list 1 permit any.  I didn't change it, left it as it was.  I did remove the ip route on the fa0/0 port however.  Soon as I put the ip route to the default gateway the web began to hum again.  Thank you for helping me with this.  I still have a ways to go before I'll be proficient with Cisco equipment, however I'm learning a lot these past few weeks.
0
 
LVL 5

Expert Comment

by:BooSTid
ID: 34121673
Default routes with an interface specified instead of a specific next hop can fail depending on what's on that network and what responds to proxy ARP requests. It works well if you have a single ip address and a single gateway; but outside of that it can be pretty hit or miss. This would explain why it failed as soon as you acquired a range rather then a dynamic host address
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question