Solved

Why can't BES Express 5.0 search/add new users ?

Posted on 2010-11-12
5
2,558 Views
Last Modified: 2012-05-10
We have recently installed a BES Express server on a Windows 2008 machine that has Exchange 2007 installed.  The install completed successfully and we can open up the Blackberry Administration service and see the various tasks etc which can be performed.  When we click on "User" and then "Add a user" to search for a user we receive the following message which I have attached as a screenshot:

"The BlackBerry Administration Service cannot find the records you were looking for. Verify the search criteria you specified and try again"

We are definitely adding in the right server name and the user has a mailbox.  Send As permission has been verified for the user also.

The strange thing is that this worked on Wednesday night immediately after we installed the Blackberry server as I was able to search for a user and send him out an Enterprise Activation password which he received.

Can anyone offer any advice as to how we can fix this please ?

Many thanks in advance
Administration-Service.jpg
0
Comment
Question by:PurityIT
  • 3
5 Comments
 
LVL 12

Expert Comment

by:mattclarified
ID: 34120190
Hi,

Take a look at this link and see if this helps with the issue you are having
http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB19451

M@
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 34120276
Another thing to check out... at the bottom of that screen do you see where it says "Refresh available user list from company directory"  click that.

the BES cache's the user list into the BESAdmin SQL Database so the user list is not real time.... (Really annoying)
0
 

Author Comment

by:PurityIT
ID: 34120459
Hi mattclarified,

It does sound like the same sort of issue we are having altough I did look in a log under C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Logs\20101112 called MAST but can't see any errors in there at all.

Hi Auric1983,

I have done this a few times but it doesn't seem to make a difference.  The problem seems to be that the Blackberry Admin Service can't find any users at all.
0
 

Accepted Solution

by:
PurityIT earned 0 total points
ID: 34121177
Hi again,

I noticed that the besadmin account didn't the correct server roles assigned so I logged on as made the account a dbcreator, serveradmin and sysadmin.

I restarted the SQL server and then the Blackberry Mail Store service and this fixed the issue
0
 

Author Closing Comment

by:PurityIT
ID: 34299289
The SQL roles hadn't been assigned properly during the install so this had to be done manually
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question