Solved

Why can't BES Express 5.0 search/add new users ?

Posted on 2010-11-12
5
2,557 Views
Last Modified: 2012-05-10
We have recently installed a BES Express server on a Windows 2008 machine that has Exchange 2007 installed.  The install completed successfully and we can open up the Blackberry Administration service and see the various tasks etc which can be performed.  When we click on "User" and then "Add a user" to search for a user we receive the following message which I have attached as a screenshot:

"The BlackBerry Administration Service cannot find the records you were looking for. Verify the search criteria you specified and try again"

We are definitely adding in the right server name and the user has a mailbox.  Send As permission has been verified for the user also.

The strange thing is that this worked on Wednesday night immediately after we installed the Blackberry server as I was able to search for a user and send him out an Enterprise Activation password which he received.

Can anyone offer any advice as to how we can fix this please ?

Many thanks in advance
Administration-Service.jpg
0
Comment
Question by:PurityIT
  • 3
5 Comments
 
LVL 12

Expert Comment

by:mattclarified
ID: 34120190
Hi,

Take a look at this link and see if this helps with the issue you are having
http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB19451

M@
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 34120276
Another thing to check out... at the bottom of that screen do you see where it says "Refresh available user list from company directory"  click that.

the BES cache's the user list into the BESAdmin SQL Database so the user list is not real time.... (Really annoying)
0
 

Author Comment

by:PurityIT
ID: 34120459
Hi mattclarified,

It does sound like the same sort of issue we are having altough I did look in a log under C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Logs\20101112 called MAST but can't see any errors in there at all.

Hi Auric1983,

I have done this a few times but it doesn't seem to make a difference.  The problem seems to be that the Blackberry Admin Service can't find any users at all.
0
 

Accepted Solution

by:
PurityIT earned 0 total points
ID: 34121177
Hi again,

I noticed that the besadmin account didn't the correct server roles assigned so I logged on as made the account a dbcreator, serveradmin and sysadmin.

I restarted the SQL server and then the Blackberry Mail Store service and this fixed the issue
0
 

Author Closing Comment

by:PurityIT
ID: 34299289
The SQL roles hadn't been assigned properly during the install so this had to be done manually
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question