[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 542
  • Last Modified:

Coldfusion Server and IE 8

Hi, I am developing a site which uses a number of jquery plugins. I am experiencing the following (seems bizarre) experience with it on the production server version, viewing with IE 8

The site works fine with my desktop environment - Coldfusion 8 and IE8 and Safari 5 and Google chrome. Everything is fine.

The site works fine from the production server (which I believe is coldfusion8) for all of the above EXCEPT IE8 !!! which exhibits two problems - The TEXT is larger and the jquery plugins are not working - eg menu bar does not show drop down menu

To see this pls go to

http://cannes-beaux-arts.com/abac_new/index2.cfm

I just can't understand that !!   Thanks for any help

james kane
0
jameskane
Asked:
jameskane
2 Solutions
 
macremCommented:
Pretty site.
Make sure you have no comments in your application.cfm file.
I have found they adversely affect html5 headers in MSIE.
0
 
jameskaneAuthor Commented:
Thks for the input Macrem. Not sure if that is the answer - as there are no problems when I run the page on my desktop coldfusion8 server, via IE8.

Turns out that my server provider has stuck me on a machine with coldfusion 7. Sneeky feeling that might me it. ??

James
0
 
duncancummingCommented:
Looking at your page source (in Firefox, I didn't even go so far as testing in IE8), you have this random HTML floating at the top of it, before the page loads properly.

<html>
<!-- <head>
<title>applicationpage</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head> -->


<body>

</body>
</html>

Open in new window


Suggest you locate where this comes from and eliminate it.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jameskaneAuthor Commented:
Thanks for taking the time to answer Duncan.

I confirm what you are seeing - however two points :

FIRST ... a mystery. I have double checked this and find that the page index2.cfm which you are looking at does not have that floating html when tested on my coldfusion server 8 on the desktop. Then I look at the page on the production server (which is coldfusion 7) and I confirm what your are seeing. Where that comes from I do not know. There is not a single page in the entire site which has a title of applicationpage

SECOND... Where it IS coming from is the APPLICATION.CFM page I have at the root of the server - not in the folder of the new site abac_new. Why that should wind itself into the index2.cfm page is beyond me. Here is the code of the application.cfm page.

THANKS AGAIN

james
<CFAPPLICATION NAME="finder" SESSIONMANAGEMENT="Yes"
sessionTimeout="#CreateTimeSpan(0, 0, 59, 0)#"
 applicationTimeout = #CreateTimeSpan(2, 0, 0, 0)# >
 <!--- tHE ABOVE SETS UP THE SESSION VARIABLES 6 EXPIRING AFTER 59 MINUTES AND THE APPLICATION VARIABLE
 IS SET TO EXPIRE AFTER 1 YEAR. --->
 
 <!--- <cferror type = "exception"
    template = "request_err.cfm"
    mailTo = "james.kane@wanadoo.fr"> ACTIVATE THIS FOR SERVER--->
      
      <!--- THE INDEX AND INDEX_ENG2 PAGES HAVE A CALL TO THE APPLICATION VARIABLE
      AT THE TOP OF THE PAGE. IF THE APPLICATION VARIABLE VALUE HAS EXPIRED IE NO VALUE THEN THE
      PAGES WILL NOT LAUNCH. RATHER THAN HAVE A NORMAL RUBBISH PAGE ANNOUNCE THE ERROR? THE PAGES
      REQUEST_ERR.CFM IS LAUNCHED 6 GIVING THE IMAGE TO THE USER THAT THE SITUATION IS MORE THAN
      CONTROL --->
 

 
<cfcontent type="text/html; charset=iso-8859-1">
<cfset setEncoding("form","iso-8859-1")>
<!--- The above two lines prevent corruption of french text  --->


<!--- <cfapplication    name = "application_name"  
loginStorage = "cookie" or "session"  
clientManagement = "Yes" or "No"  
clientStorage = "datasource_name" or "Registry" or "Cookie"  
 setClientCookies = "Yes" or "No"    
 sessionManagement = "Yes" or "No"  
 sessionTimeout = #CreateTimeSpan(days, hours, minutes, seconds)#  
 applicationTimeout = #CreateTimeSpan(days, hours, minutes, seconds)#  
 setDomainCookies = "Yes" or "No"> --->
 
 
 















<html>
<!-- <head>
<title>applicationpage</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head> -->
<!--- NOTE, the above has been killed because it superimposes itself on other index.cfml pages, regardless if they have their onw
name or not. The application.cfm should not have the head tags --->

<body>

</body>
</html>
0
 
duncancummingCommented:
does your abac_new folder have its own application.cfm or application.cfc?  I'd guess maybe not.  When any .cfm or .cfc file gets executed, CF Server will look in whatever the current folder is for an application.cfm/.cfc.  If it doesn't find one, it will recurse upwards through the directory tree until it finds one.  So it sounds like there isn't one in the site folder, so it goes up one level and uses the one in the web root.
0
 
jameskaneAuthor Commented:
Thats it exactly Ducan - but why should that worry IE8 and not the other browsers ??

I think I need to have them change me to CF8 from CF7. ??

James
0
 
duncancummingCommented:
No, you need to either create an application.cfm and put it in the abac_new folder, OR, remove that html from your root application.cfm.  Preferably create an application.cfc for each sub-site, which will be more useful for you in the longer run.

The reason IE8 fails is maybe it's less forgiving of invalid HTML than the other browsers you're testing with.
0
 
jameskaneAuthor Commented:
Duncan, that fixed it !!!!!!!!!!!!!!!!!!!!!!!!
I deleted the commented stuff and voila !!  

Thanks a million

James

PS   Internet Explorer is bizarre !!!!! you cant program tabs, no possibility of transparent Iframes  and now it does not like commented out source code .... ahhhh !!
0
 
jameskaneAuthor Commented:
THANKS again  ducan, and belated thanks also to you macrem !!
0
 
_agx_Commented:
(no points ..)

>> <html><body></body></html>

Welcome to the wonderful world of IE. But you may as well remove the extra html entirely.  It does not seem to serve any purpose. I'm not even sure pages with 2 <html> and  <body> tags would validate.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now