401 unauthorized crm periodically.

Hi!

I have a plugin installed on my CRM server called NN. This application basically is a button, which looks in an online company database to find information about the company which I am adding to my CRM.

Works fine, sometimes. Problem is that after sometimes 1 hour, some times 20 minutes, I get this error which I have attached.
Restart the CRM server normally works, and then the button stops working after some time again and i ahve to do another restart! What is causing this, its really frustrating!

Any help appreciated.
Error as seen on client
LVL 1
johnnybrianAsked:
Who is Participating?
 
johnnybrianConnect With a Mentor Author Commented:
We ended up resintalling the server totally. Couldnt find the problem.
0
 
Chinmay PatelEnterprise ArchitectCommented:
Hi johnnybrian,

I would like to clarify one thing that the button you see is not a plugin, this is an ISV add on.

It seems the issue with the custom code itself. By any chance do you have the code of that NN ISV add-on?
You might want to see how credentials are passed in it.

I am assuming the following scenario :
there is a possibliy they might have added the credentials to the session and after a while user is not interacting with CRM and it might expire the session and so the credentials are gone too. And next time when they try to hit the CRM service it will throw 401 'cause required credentials were not provided[4th line in stack trace].

We can be sure only after looking into the code of NN.

Regards,
Chinmay.
0
 
Chinmay PatelEnterprise ArchitectCommented:
Any updates on this one?
0
 
johnnybrianAuthor Commented:
We ended up reinstalling.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.