Coldfusion 7 and Flex 4 and https

Hello
i have a flex 4 app that is connecting to a cf 7 server using RemoteObject, all worked fine on dev then when we moved to prod we started to get problems like

The page must be viewed over a secure channel</h1>
The page you are trying to access is secured with Secure Sockets Layer (SSL).
...
Type https:// at the beginning of the address you are attempting to reach and press ENTER.

obvious the server is not open to connections that are not secure
does anyone know how to fix this , please note that i am using cf 7

i have seen this  article
http://blog.crankybit.com/flex-remoting-over-ssl/
which is good but is for cf8
jockmahon01Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Pravin AsarConnect With a Mentor Principal Systems EngineerCommented:
Look at the flex remoting config files [generally located in WEB_INF\flex directory.

It is a while, I migrated from CF7 to CF8/9.

If I recall correctly the

In the remoting-config.xml


<!-- On HTTPS (SSL) Sites, list the secure channel first -->
<default-channels>
            <channel ref="my-cfamf"/>
            <channel ref="my-cfamf-secure"/>
</default-channels>

<!-- On HTTPS (SSL) Sites, list the secure channel first  CF Specific -->


    <destination id="ColdFusion">
        <channels>
            <channel ref="my-cfamf"/>
            <channel ref="my-cfamf-secure"/>
        </channels>

Also check the services-config.xml

0
 
Pravin AsarPrincipal Systems EngineerCommented:
Also in your flex application, for the web-services/remoting call check the attribute

source="{serverURL}"

for resolving the endPoint for the Remoting Call.
0
 
jockmahon01Author Commented:
b
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.