?
Solved

Windows 7 connectivity problems

Posted on 2010-11-12
11
Medium Priority
?
1,003 Views
Last Modified: 2012-08-13
Our small business network has been having reproducible but unexplained connectivity problems lately.  Router is Linksys WRT54G (DHCP), machines on network run several flavors of XP, a couple Vista, and a handful Win7.  A Macbook also connects from time to time.  All, with the exception of the Mac are in the same workgroup.  We are not using homegroup.  I have disabled IPv6 on all Win7 and Vista machines by unchecking it in adapter properties.  I have made no registry changes in this regard although I have read about some that may be necessary.  Everything has been running smoothly until recently when an new Win7 Pro x64 machine was added.  There was already a similar machine on the network, but the new one replaced our Quickbooks (2008 Pro) server which had been XP.  Then things started to happen.  Other machines would lose internet.  Often they would be able to see local shares and interact with them but no internet.  Sometimes neither.  Tried reboots, ipconfig /renew, router power cycling, manually resetting winsock settings and combinations of the above.
eventually, the affected machine/s would reconnect.  Winsock changes/restart/router cycle seemed to be most effective.  What is odd, is that not all machines would be affected at the same time.  One might go down.  Or two or three, but never all and never the Quckbooks server.  In other words, the router and the new machine were always happy together.  Only one other machine accesses the Quickbooks data, but is on all the time.  It loses connectivity.
This is beginning to sound like a logic puzzle, sorry.  Conicidentally, another local business with a similar but smaller network, also running Quickbooks (2010 Pro) on a win7 machine is experiencing identical problems.  They are also using a Linksys router (wired only).  IPv6 is configured but not needed.  Both offices receive internet through the same local Wifi provider.
Often, they will lose internet on their server but retain local share access including QB access.
Hope you can offer some insight - I am out of ideas.
0
Comment
Question by:hvserv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 1

Expert Comment

by:wamanma
ID: 34119714
Try using Google public DNS 8.8.8.8, 8.8.4.4 along with the existing DNS provided by the local Internet WiFi provider. Some times DNS provided by local vendors fail to resolve IP addresses.

Regards,
Mandar Waman
0
 

Author Comment

by:hvserv
ID: 34119944
I should have added that one aspect of this problem, in most instances but not all, is loss of DHCP for some reason.  ie a computer is turned on, but fails to get an address.  Other machines, which had been on all along are still enjoying full connectivity.  A router restart does not fix the confused machine.  However, a winsock reset, router reset, and machine reboot does.  If the Win7 QB server is off, problem
does not occur with newly booted machines.  Here is a chronological outline of one instance:
Day 1 - server on, client machine on -everything fine
Day 1 - (later) client machine off, server happy
Day 1 - (later still) server shut off for the night, client machine still off
Day 2 - Server turned on, gets address, surfs, happy.
Day 2 - (a little later) client turned on, does not get address.
Day 2 - reset client winsock settings, restart, no DHCP, restart router, client gets address.
server has connectivity the whole time both before and after router restart.

I will implement the DNS recommendation - good idea.
0
 
LVL 6

Expert Comment

by:RootsMan
ID: 34127327
Are the clients that get no DHCP parameters connecting via wireless?
If so, you may have too much interference or too many Wi-Fi networks on the same channel.

Use inSSIDer 2 ( http://metageek.net/products/inssider ) to see which channel is not being used or has the fewest access points, and configure your WRT54G to use that channel.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:hvserv
ID: 34127763
all but the Mac are wired connections.

added google DNS and that's nice but a side issue as DHCP
loss is big part of puzzle and not related to DNS issues.

Did a minor firmware upgrade to router Linksys WRT54G hardware v6.0
went from v1.02.6 to v1.02.8 firmware.  Network has been stable since (48 hours)
support notes for firmware are as follow:

Firmware 1.02.8
- Resolves issue with UPnP denial of service security vulnerability.


Firmware 1.02.7
- Resolves issue with not being able to block IPSec pass-through.
- Resolves issue with router disconnecting from some particular online game servers.
- Resolves issue with user not being able to get incoming video and audio when video phone is connected to the LAN hosted by the router.
- Resolves issue with WEP 64-bit key not being properly validated when user enters the key.
- Resolves issue with disabling UPnP not being effective until the router is rebooted.
- Resolves issue with Wireless MAC Filter not working properly when there are more than 32 entries in filter list.
- Resolves issue with DNS vulnerability.
- Better handling of TCP packet with invalid option field.
- Updated TZO.com DDNS service support.
- Adds PPPoE service name support.
- HNAP 1.2 support.

not sure what might have been relevant here, will watch it for another day or so and report back.
If this is the fix, and someone can identify the firmware element/elements that made a
difference I would love to know what it was.

0
 
LVL 2

Expert Comment

by:cperry71
ID: 34127813
I see you have dhcp setup.  Is everything on dchp?  Do you have any static IP addresses?  You might want to setup static IP's on your server and any permanent workstations then change the range of DHCP address leases so that it doesn't include that range.  Example.  Static range of 10.0.0.1 - 10.0.0.20 for servers, default gateway, network printers and workstations with shares.  Dhcp lease range 10.0.0.21-10.0.0.50 or whatever will work for the size of your network.  Do you have a DNS server for internal clients?

When a computer loses connectivity find out what it's IP address is then do an nslookup on that IP to see if there is another computer with that address.  If it is a 169. address then it is not getting an address from the server.  

0
 
LVL 2

Expert Comment

by:cperry71
ID: 34127822
Another problem may be a rouge wireless access point or DCHP server.  You may be getting a bad address that is outside your network.  Checking IP's will help rule this out.
0
 

Author Comment

by:hvserv
ID: 34127986
router gets DHCP from Wifi provider's hardware outside of building on antenna.
machines on network get DHCP, within a specified range, from router.  192.168.199.xxx
If one or more machines lose their address (I don't know how) they show a 169.... number.
there is no rogue access point or DNS server downstream of the router.
0
 
LVL 2

Expert Comment

by:cperry71
ID: 34128651
Have you tried entering a static IP when they lose their address?  

Also have you looked at the logs on the router to see if you are getting dropped packets?  If you are getting a large about of tx/rx errors on port, the router will turn off the port to keep from shutting the whole system down.

How are they wired?  Home run to the Linksys or switches that connect to a linksys?  You could try switching ports when a computer loses an address to see if that port is being shutdown.  
0
 

Author Comment

by:hvserv
ID: 34128696
stations are wired home run to a single 24-port switch that
connects to the router.  have enabled logging - thanks for the
heads-up on that.  When a given machine loses its address, it
will not be assigned a new address unless I reset winsock settings,
restart machine, and restart router.  Other machines maintain
connectivity up until I restart the router.  Have tried switching
network drops for failed machine to give it a shot at a different
port in the switch, but this does not help.  will try static IP next time
one fails.
0
 

Accepted Solution

by:
hvserv earned 0 total points
ID: 34204381
solved the problem - adding a new machine to the network exceeded the total number of DHCP clients allowed on the network.  As the number of machines in use varied from day to day, but occasionally exceeded the max allowed, causing seemingly random connectivity problems.  increased the max allowed number in the router and everything got better.  
0
 

Author Closing Comment

by:hvserv
ID: 34228570
solved the problem - all my earlier assumptions were wrong.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question