Solved

How do Install the latest Citrix online plugin on the HP T5730

Posted on 2010-11-12
17
6,831 Views
Last Modified: 2012-05-10
I just received a new HP  t5730 with Windows Embedded Standard 2009 on it to use with Citrix Xendesktop 4. How do I install the new Citrix online plugin? The download for the online plugin on HP's website says it is for XP embedded (all of the downloads are for XP embedded) and when I try to run the installer and try to extract it to a folder on the c: drive, it says that drive "Z" does not have enough space. I have already uninstalled the Citrix application from the t5730 that came with it.

When I download and try to install the latest Windows plugin from Citrix' website, I receive this error at the beginning of the installation "this is not a valid win32 application".

Do I need to install the XP embedded image to get this to work?
0
Comment
Question by:yodasbrother
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 3
17 Comments
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 34122012
Not seen these particular models before but I'm assuming the Z: drive is in actual fact the RAMDRIVE.

You may have to delete everything out of it, or try setting your TEMP folder to a different location.

Added into this, don't forget the write filter - when it's enabled, all changes are lost at reboot.

The details of the new filter are here:

http://technet.microsoft.com/en-us/library/bb932158.aspx
0
 

Author Comment

by:yodasbrother
ID: 34122507
In general, do I have  shot at installing the software "updates" for XP embedded on the Windows embedded standard 2009 ? Or are those two different animals? HP has a lot of software updates for the t5730 but they all say they are for XPe.
0
 

Author Comment

by:yodasbrother
ID: 34122513
Forgot to ask How do I set the temp folder location?
0
Transaction Monitoring Vs. Real User Monitoring

Synthetic Transaction Monitoring Vs. Real User Monitoring: When To Use Each Approach? In this article, we will discuss two major monitoring approaches: Synthetic Transaction and Real User Monitoring.

 
LVL 26

Accepted Solution

by:
Tony Johncock earned 500 total points
ID: 34122562
Hmm I'm not certain to be honest as I've never seen Embedded 2009 in the flesh as it were, but my limited understanding of it is that it's based on Windows 7?

In the past, we actually just installed the full blown XP client, as XPe and XP were binary compatible (Microsoft's way of saying the same executables run on both).

So it is probably worth a try with the one on Citrix's website.

Easiest way to change the folder - if you go to a command prompt and type set <enter> you should see TMP & TEMP listed.

So from the prompt, if you then type
set tmp=c:\tmp <enter>
set temp=c:\temp <enter>

Ensuring that you created the folders first (they could even be the same folder).

So the process would be:
Disable the Enhanced Write Filter
Reboot
Set the temporary files location
Install the latest client
Delete the temporary files (the location will be reset on reboot, as it's an environment variable - that's the reason I said do it from cmd.exe) and the temporary folders
Reboot if necessary and configure the Citrix client with the relevant server settings etc
Enable the write filter
Reboot
Test

Note - it's a pain, but I'd always test after re-enabling the filter so there is nothing static written to the box.


Hope that works.
0
 

Author Closing Comment

by:yodasbrother
ID: 34123716
The XPe addon for Citrix online Plugin did get installed using Tony1044's steps. The file extraction worked well and then I needed to install the addon from the commandline using the -s parameter or I would still get an error about z: not having enough room.
0
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 34123985
Thanks for the points. Glad it worked.
0
 

Expert Comment

by:CarpeDiemTim
ID: 37635190
But...if you're running Windows Embedded 2009 you can't get a command prompt other than in Safe Mode, can you? And when I'm in safe mode and attempt these things, I keep getting "Access denied".
0
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 37635256
Yeah you should be able to. It sounds like it's logging on as user and not admin
0
 

Expert Comment

by:CarpeDiemTim
ID: 37635264
You're right, it is (automatically), but if I try to log off, it just goes right back in an 'User'. Did you run into this too?
0
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 37635301
Hmm it's been a while since I looked at the HP offerings - try holding Shift during the boot sequence to show the login screen

I think the default administrator logon is Administrator and either password or Administrator again
0
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 37635313
Ah something has just sprung to mind - if holding shift during the boot doesn't work, let it log on as user and then log off with shift held down.
0
 

Expert Comment

by:CarpeDiemTim
ID: 37635463
Thanks for your help. I'll definitely have to create a separate issue so I can give you points for your assistance.

With that said, even now that I'm logged in as admin and EWF is disabled, I still keep getting errors related to the SSL certificate. I've added it to the Trusted Root Certification Authorities\Local Computer store (and any other variation of other locations), but yet it still keeps prompting me with this certificate error (which we've never run into before on other OSs, including Windows 7 Thin Client).

I should also add that the machine came with a built-in Citrix plugin, but there again I'm getting "The server has an invalid root certificate, so this may be a malicious server. Connection dropped."

Any further advice?
0
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 37635492
I love the EWF. It is great at what it does, but sometimes working around it is such a pain.

Generally, I've found that disabling it isn't enough in its own right - you have to then reboot the client.

Only then will it allow you to install things.

I think you have the path for the cert right but I'd make sure I'd disabled the EWF, rebooted, installed the certificate (you might want to add any root and intermediates too, if you have them), reboot and check the certs are still present.

Don't worry too much about the points - getting it working is more important to me.
0
 

Expert Comment

by:CarpeDiemTim
ID: 37635703
You're right, this is definitely a pain! But thanks again for your assistance.

The thing still isn't taking since after reboot, I'm still getting prompted with the same errors. When I initially go to the CAG (https://citrix.domain.com), I see a page that says "There is a problem with this website's security certificate," and in the detail, it says "The security certificate presented by this website was not issued by a trusted certificate authority." I click 'Continue to this website (not recommended)' and then I'm taken to the CAG with the address bar being red and 'Certificate error' shown to the right of the URL.

If I click on the 'Certificate error' area and go to 'View certificates'. The certificate is issued by Go Daddy and doesn't expire until 2013, and like I mentioned before, I've installed this certificate any number of ways from letting it automatically select a certificate store to specifying a cert store to specifying the physical Local Computer store in Trusted Root Cert Authorities, Personal, Intermediate Certification Authorities, Trusted Publishers, and Third-Party Root Cert Authorities (desperately trying to get SOMETHING to work), but still to no avail.

 You mentioned intermediate certificates though, which I'm unfamiliar with. As I understand it, our cert is a root cert, but that's about the extent of my knowledge in that area.

 I could always try putting Windows 7 Embedded on these machines since I know that has no issue with Citrix or certificates whatsoever, but the whole idea was to have this thin client pre-installed, to save time. So if we can't get it worked out, it's not a huge deal, but it seems like this should be a pretty straight-forward process and it's frustrating to not be getting anywhere with it.

So if you happen to have any further input that may assist, I would be very appreciative.

If not, it's not the end of the world.

Thanks.
0
 

Expert Comment

by:CarpeDiemTim
ID: 37635790
I suppose I should also mention that if I try simply ignoring the certificate errors, I can log into Citrix, and then when I attempt to launch an app it specifies SSL Error 86: "The security certificate "citrix.domain.com" is not suitable for use in SSL connections." But again, this can't be true because we use this SSL connection all the time on other OSs.

Anyway, just thought I'd throw that out there.
0
 
LVL 26

Expert Comment

by:Tony Johncock
ID: 37639259
Ah I wonder if the OS doesn't recognise the GoDaddy chain - I've had similar issues with them on outlook web app in the past.

It might be worth checking the GoDaddy site to see if there is a root certificate you can download. If there is, install it into trusted root authorities and then try.
0
 

Expert Comment

by:CarpeDiemTim
ID: 37640463
Thank you for all your input. After speaking with my IT Director about the difficulties I've run into with this, he pointed out that in this particular instance, since this would be for public 'kiosk' PCs, they won't need Citrix access. So we're just side-stepping the issue and not worrying about it.

Hopefully this correspondence will help others who are researching the same issue though.

Just let me know if you want any points, and I'll set something up, but either way, thank you for your time and consideration. It's much appreciated.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question