Link to home
Create AccountLog in
Avatar of Mr_Shaw
Mr_Shaw

asked on

I just added a proxy to a Agent Job and got the following error.

I just added a proxy to a Agent Job and got the following error.

 Grant permission by calling sp_grant_proxy_to_subsystem or sp_grant_login_to_proxy

Does anybody know fix?

thanks
Avatar of subhashpunia
subhashpunia
Flag of India image

In which group you created the proxy and what type of command youa re using in Agent job?
Do the credential (used for proxy) have the permission for the resource used by job?
Avatar of EvilPostIt
Have you granted the relevant subsystem permissions to the proxy user. Ie if you are runnning an SSIS package then you will have to grant the user access to the SSIS subsystem.
The order in which you should set up a proxy is to add the user to Security > Credentials and then under "SQL Server Agent" > Proxies (Right Click) New Proxy and assign the subsystem permissions.
Avatar of Mr_Shaw
Mr_Shaw

ASKER

Ok past that error now... the new error is

Unable to start execution of step 3 (reason: Could not get proxy data for proxy_id = 41).  The step failed.

This is tricky...
Have you entered DOMAIN\USER in the credential?
Avatar of Mr_Shaw

ASKER

No I am using a sql account.
And what subsystem are you accessing? T-SQL?
Avatar of Mr_Shaw

ASKER

i am not sure what subsystem I am using....

I am using SQL Server 2005.
In the drop down in the job you have created you will see as per the screen shot. This is the subsystem. User generated image
Avatar of Mr_Shaw

ASKER

Oh Operation System (CmdExec)
Is your SQL Service running under "Local System" or is a user specified?
Avatar of Mr_Shaw

ASKER

I also tried it using SSIS
Avatar of Mr_Shaw

ASKER

>>Is your SQL Service running under "Local System" or is a user specified?

Everything is under local system.

What command are you running?
Avatar of Mr_Shaw

ASKER

"C:\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\DTEXEC.EXE" /SQL "\BReports\Invoicing" /SERVER AD1/MAXCONCURRENT " -1 " /CHECKPOINTING OFF /REPORTING E

This command work fine if i run the Job under the SA account.

When I use the proxy it does not work.

I have included sysadmin and SQLAgentUserRole in the principals of the proxy.
Sorry thinking about that is the SQL Server agent running under local system?
Avatar of Mr_Shaw

ASKER

Yes the agent is also running under local system.
Interesting that it worked with SA... I take it you dont want to use a windows account?
Avatar of Mr_Shaw

ASKER

I don't know which windows account to use... unless I ask for a new one to be created.
ASKER CERTIFIED SOLUTION
Avatar of EvilPostIt
EvilPostIt
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Mr_Shaw

ASKER

thank you so much for helping me through this issue.

A new domain account was created which I used in the proxy.

It all works now.
No probs.
Just saw the "Jew one" bit in my reply. Sorry was supposed to be "New one". Damn iPhone autocorrect.