Solved

Cisco 4948 enabling ports ports 22-24 in support of ESX storage

Posted on 2010-11-12
21
963 Views
Last Modified: 2012-05-10
see following example:



User Access Verification

Password:
Cat4000-NOCA>enable
Password:
Cat4000-NOCA#sh run
Building configuration...

Current configuration : 3192 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service compress-config
service sequence-numbers
!
hostname Cat4000-NOCA
!
enable secret 5 $1$Wy6.$hSSst1riu.j1bDejhKisR/
!
username bdadmin privilege 15 secret 5 $1$u8Vp$GWbxkfNlNmYnrCTZq2w2P/
vtp mode transparent
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 100
 name ESX_Storage
!
vlan 501
 name wvlesx
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet1/3
!
interface GigabitEthernet1/4
!
interface GigabitEthernet1/5
!
interface GigabitEthernet1/6
!
interface GigabitEthernet1/7
!
interface GigabitEthernet1/8
!
interface GigabitEthernet1/9
!
interface GigabitEthernet1/10
!
interface GigabitEthernet1/11
!
interface GigabitEthernet1/12
!
interface GigabitEthernet1/13
!
interface GigabitEthernet1/14
!
interface GigabitEthernet1/15
!
interface GigabitEthernet1/16
!
interface GigabitEthernet1/17
!
interface GigabitEthernet1/18
!
interface GigabitEthernet1/19
!
interface GigabitEthernet1/20
!
interface GigabitEthernet1/21
!
interface GigabitEthernet1/22
!
interface GigabitEthernet1/23
!
interface GigabitEthernet1/24
!
interface GigabitEthernet1/25
 description Unrouted Vlan 100
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/26
 description Unrouted Vlan 100
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/27
 description Unrouted Vlan 100
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/28
 description Unrouted Vlan 100
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/29
 description Unrouted Vlan 100
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/30
 description Unrouted Vlan 100
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/31
!
interface GigabitEthernet1/32
!
interface GigabitEthernet1/33
!
interface GigabitEthernet1/34
!
interface GigabitEthernet1/35
!
interface GigabitEthernet1/36
!
interface GigabitEthernet1/37
!
interface GigabitEthernet1/38
!
interface GigabitEthernet1/39
!
interface GigabitEthernet1/40
!
interface GigabitEthernet1/41
!
interface GigabitEthernet1/42
!
interface GigabitEthernet1/43
!
interface GigabitEthernet1/44
!
interface GigabitEthernet1/45
!
interface GigabitEthernet1/46
!
interface GigabitEthernet1/47
!
interface GigabitEthernet1/48
!
interface Vlan1
 ip address 10.1.98.3 255.255.0.0
!
interface Vlan101
 description subnet 101
 no ip address
 ip access-group 2101 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 shutdown
!
interface Vlan501
 ip address 10.100.1.3 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.1.2.1
ip http server
ip http authentication local
!
!
!
access-list 2100 remark subnet 100
access-list 2100 permit ip 192.168.100.0 0.0.0.255 any
access-list 2101 remark subnet 101
access-list 2101 permit ip 192.168.101.0 0.0.0.255 any
!
!
!
line con 0
 stopbits 1
line vty 0 4
 password r3lativitY
 login
!
end

Cat4000-NOCA#

I have created VLAN 501
and intend to use ports 21-24 to support my esx servers fiber storage. port 45 on this cisco 4948 switch connects to port 23 on a cisco 6513 switch using fiber and trunk is enabled however I can't talk to the devices connected on the ports 21-24. Any suggestions? In so far as the 4948 config is concerned?

Thanks

A quick response would be appreciated my boss is coming in soon and I would like to have this working ;)
0
Comment
Question by:cp361
  • 13
  • 8
21 Comments
 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
If this is a question on how to put the ports in the VLAN 501,

conf t
int range g1/21 - g1/24
switchport access vlan 501


or do each port individually.

0
 

Author Comment

by:cp361
Comment Utility
yep it is and I did do that I will show here:

interface GigabitEthernet1/22
 switchport access vlan 501
!
interface GigabitEthernet1/23
 switchport access vlan 501
!
interface GigabitEthernet1/24
 switchport access vlan 501

please look at the statement at the bottom and confirm this is correct:

interface Vlan501
 ip address 10.100.1.3 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.1.2.1
ip http server
ip http authentication local

Does this look ok too?

Thanks



0
 

Author Comment

by:cp361
Comment Utility
I just ran an ip scan of that subnet 10.100.1.1 from my desk and I can see there is life at 10.100.1.1 and 10.100.1.3 which is good just can't see anything on the individual ports. FYI
0
 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
from the switch can you ping anything in those subnets?

There is a litte more here then just getting them in the IP range,

What is 10.100.1.1? What is the gateway for the devices in that range? are you routing the IP on this switch or are your routing it else where?

across the trunk port are there additional ports in this 501 vlan?
0
 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
also do a sho int trunk on this switch? to verify the trunking?
0
 

Author Comment

by:cp361
Comment Utility
this is what I get with sh int trunk:

Cat4000-NOCA#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan
Gi1/45      auto         n-802.1q       trunking      1

Port      Vlans allowed on trunk
Gi1/45      1-4094

Port        Vlans allowed and active in management domain
Gi1/45      1,100,501

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/45      1,100,501

I will attempt to ping a device on vlan 501 from vlan 501
0
 

Author Comment

by:cp361
Comment Utility
I was able to sucesfully ping from within the vlan 501 to another device on the 10.100.1.x subnet
10.100.1.1. is the gateway
0
 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
So is everything working.
0
 

Author Comment

by:cp361
Comment Utility
actully no since I can't bing the device from 10.1.97.184 (my desk) ;)
0
 

Author Comment

by:cp361
Comment Utility
If I'm on the switch and in the vlan yes I can ping a neighbor but if I'm not directly on the switch I'm unable to ping any of the devices ips
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
Here is the next set of questions

How are you routing in to that network?  where is 10.100.1.1 is that a layer 3 device that has routes to your network?

and are all IPs in the 10.100.1.1 network in VLAN? 501 no matter what device they are on?
0
 

Author Comment

by:cp361
Comment Utility

On the router in the helper files the vlan 501 is defined let me show you the very long config on the 6513 switch upstream: actually I will limit the info to module 1

set vlan 501 name Woodnville_VM1 type ethernet mtu 1500 said 100501 state active

#module 1 : 24-port 1000BaseX Ethernet
set port name       1/1  Conn C4506-B
set port name       1/3  test
set port name       1/13 Trunk-B-4506
set port name       1/23 Trunk-4948-ESX

clear trunk 1/23 1006-1023
set trunk 1/23 on dot1q 1-1005,1024-4094



0
 

Author Comment

by:cp361
Comment Utility
Here is the rest of the info module one upstream 6513 switch

C6513-NOC-A> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 1/1      on           dot1q          trunking      1
 1/4      on           dot1q          trunking      1
 1/5      on           dot1q          trunking      1
 1/8      on           dot1q          trunking      1
 1/9      on           dot1q          trunking      1
 1/12     auto         n-dot1q        trunking      1
 1/13     on           dot1q          trunking      1
 1/16     on           dot1q          trunking      1
 1/17     on           dot1q          trunking      1
 1/18     on           dot1q          trunking      1
 1/23     on           dot1q          trunking      1
 1/24     on           dot1q          trunking      1
Port      Vlans allowed on trunk
--------  ---------------------------------------------------
 1/1      1-1005,1024-4094
 1/4      1-1005,1024-4094
 1/5      1-1005,1024-4094
 1/8      1-1005,1024-4094
 1/9      1-1005,1024-4094
 1/12     1-1005,1024-4094
 1/13     1-1005,1024-4094
 1/16     1-1005,1024-4094
 1/17     1-1005,1024-4094
 1/18     1-1005,1024-4094
 1/23     1-1005,1024-4094
 1/24     1-1005,1024-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 1/1      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/4      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/5      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/8      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/9      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/12     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/13     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/16     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/17     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/18     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/23     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/24     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 1/1      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/4      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/5      1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/8      1-2,10,105
 1/9      1-2,10,105
 1/12     1
 1/13     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/16     1,10
 1/17     1-2,105,210,998-999
 1/18     1,10
 1/23     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999
 1/24     1-4,10-13,15,20,30,40-41,50-51,60-61,70,80,90,95,101,105-106,210-211,5
01-502,509,998-999






0
 

Author Comment

by:cp361
Comment Utility
here is the info on the router related to vlan 501

interface Vlan501
 description myrouter
 ip address 10.100.1.1 255.255.255.0
 no ip redirects

0
 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
on both switches what does the IP route look like
0
 

Author Comment

by:cp361
Comment Utility
Access control list: on the 4948 switch

Vlan501 is up, line protocol is up
  Internet address is 10.100.1.3/24
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
igabitEthernet1/18 is up, line protocol is up
 Inbound  access list is not set
 Outgoing access list is not set
igabitEthernet1/19 is up, line protocol is up
 Inbound  access list is not set
 Outgoing access list is not set
igabitEthernet1/20 is up, line protocol is up
 Inbound  access list is not set
 Outgoing access list is not set
igabitEthernet1/21 is up, line protocol is up
 Inbound  access list is not set
 Outgoing access list is not set
igabitEthernet1/22 is up, line protocol is up
 Inbound  access list is not set
 Outgoing access list is not set
igabitEthernet1/23 is up, line protocol is up
 Inbound  access list is not set
 Outgoing access list is not set
igabitEthernet1/24 is down, line protocol is down
 Inbound  access list is not set
 Outgoing access list is not set
0
 

Author Comment

by:cp361
Comment Utility
you asked:
Cheever000:on both switches what does the IP route look like
I'm sorry must be getting tired but how do I bring up that info what is command syntax?

Thanks
0
 
LVL 9

Accepted Solution

by:
Cheever000 earned 500 total points
Comment Utility
Show ip route
0
 

Author Comment

by:cp361
Comment Utility
for the 4948:

Cat4000-NOCA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.2.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.1.0.0/16 is directly connected, Vlan1
C       10.100.1.0/24 is directly connected, Vlan501
S*   0.0.0.0/0 [1/0] via 10.1.2.1

for the upstream 6513:

C6513-NOC-A> (enable) sh ip route
Fragmentation   Redirect   Unreachable
-------------   --------   -----------
enabled         enabled    enabled

The primary gateway: 10.1.2.1
Destination      Gateway          RouteMask    Flags   Use       Interface
---------------  ---------------  ----------   -----   --------  ---------
default          10.1.2.1         0x0          UG      82695423    sc0
10.1.0.0         10.1.2.2         0xffff0000   U       184929      sc0
default          default          0xff000000   UH      0           sl0

btw you have the patience of Jobe to stick with this :)



0
 

Author Comment

by:cp361
Comment Utility
Ok I found the problem I was connecting from my laptop to the server and not from laptop to the port on the switch DOH!

you win and get the points thanks so much for your help!
0
 
LVL 9

Expert Comment

by:Cheever000
Comment Utility
Thanks hope I was enough help
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

This article is focussed on erradicating the confusion with slash notations. This article will help you identify and understand the purpose and use of slash notations. A deep understanding of this will help you identify networks quicker especially w…
This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now