Solved

Admin shares accessible to domain users

Posted on 2010-11-12
11
1,115 Views
Last Modified: 2012-05-10
We recently upgraded our SBS 2003 server to SBS 2008.  Since then we've discovered that all admin shares on all machines (servers and workstations) are accessible to all domain users from any other machine.

I've confirmed that the domain user group isn't in the administrator or domain admin groups or anything silly like that.  Also all of our domain users do NOT have local admin privileges.  

As far as I can tell there isn't anywhere to specifically modify admin share permissions.  

Any idea what's causing this & how to fix it?  
0
Comment
Question by:tcrtech
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 4

Accepted Solution

by:
patterned earned 250 total points
ID: 34122461
Check the Share permissions.

right click the shared folder, go to properties. click the share tab.  click advanced sharing and click the "Permissions" button.  If Everyone is listed with read permissions, they will be able to see the share.

Use the "Security" tab under properties to set the NTFS permissions.
0
 

Author Comment

by:tcrtech
ID: 34122519
The drives aren't specifically shared, it's just the admin shares that are accessible, so under Advanced Sharing the permission button is grayed out.  

On the Security tab I have:
Authenticated Users - Allow Special Permission
System - Allow All
Local Administrators - Allow All
Local Users - Allow Read & execute, Allow List folder contents, Allow Read.

I'm not sure I understand "special permissions" for the authenticated users.  What is that, where did it come from, & do I need it?  
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 34122556
Check that the guest account has not been enabled or anything crazy like that maybe.
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 
LVL 4

Expert Comment

by:patterned
ID: 34122627
Are you speaking of the C$ admin shares?

0
 

Author Comment

by:tcrtech
ID: 34122691
no guest accounts.
yes, all of the <drive>$ shares.  
0
 
LVL 4

Expert Comment

by:patterned
ID: 34122835
I can't even find official documentation for the default share ACEs or permissions.

Maybe disable the shares and re-enable?

Double check what groups the domain users are in.. and double check local user groups..
0
 
LVL 27

Expert Comment

by:Steve
ID: 34130624
use gpresult on a client while logged in as a normal user.

this will tell you what group policies are applying.
alternatively use the group policy results wizard on the server to see what is applied.

One of the settings in your group policies is assigning admin rights to all users.

alternatively, open a user in active directory and check what groups they are members of. follow each group to see which groups they are members of too, right up to the top level.  one of the groups may be nested and effectively be an administrator.
0
 

Author Comment

by:tcrtech
ID: 34250583
ok, it's definitely a problem with the NTFS shares, but I'm not sure how to fix it.  

On the domain computers the group "Domain Users" is in the local "Users" group.  Then on the NTFS permission of each computer, the local "Users" group has read access.  So that tells me that every user on the domain has access.

I assume that this setup is necessary for domain users to have access to the drive when they login to the machine, but how do I prevent remote domain users from accessing those drives via the <drive>$ shares?
0
 
LVL 27

Assisted Solution

by:Steve
Steve earned 250 total points
ID: 34256872
As advised above, you need to follow all groups as there are only really two possoible causes:

a) The permissions on the folders are wrong
b) the users are a member of a group they shouldnt be

check the permissions on the folders and post the results here so we can check they are correct.

Also trace the user groups as advised in the post above. Start on the PC and see which users & groups are a member of local users & groups>groups>administrators in local users & groups.
Post that list too and we'll help check them.

0
 

Author Comment

by:tcrtech
ID: 34270314
ok, so you were technically correct, just not complete.  The permissions were all correct and the groups were all correct. But walking through all of those & the process of elimination led me to the solution.  

Even though they are called "Admin Shares," anyone in the Backup Operators group also has access to them, not just administrators.  In our case most of our users have Acronis Backup & Recovery installed which requires users to be in either the local Administrators group or the Backup Operators group.  So we have a GPO that adds all domain users to the local Backup Operators group.  

Removing the users from that group fixes the Admin shares problem, but prevents them from using Acronis.  
0
 

Author Closing Comment

by:tcrtech
ID: 34270336
The information was mostly accurate, but incomplete.  Administrators are not the only group with access to the Admin shares.  And anyone in the Backup Operators group super-cedes individual drive permissions.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SBS 2011 Backup Drive 8 31
Domain Controller FSMO 7 40
Application Crash 2 23
WMI - Issue Server 2012 R2 1 9
Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
A safe way to clean winsxs folder from your windows server 2008 R2 editions
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question