Solved

Windows7 access to Netware 3.12 Bindery via XP Mode

Posted on 2010-11-12
8
4,751 Views
Last Modified: 2012-05-10
I have my first Windows 7 PC and need to connect it to my Netware 3.12 server.  I have been running Windows XP successfully with the server.

I have read on another post that people have used Virtual PC with a new installation of XP to gain access to Netware Binderies from a Windows 7 PC.  I am hoping to do the same using the included "XP Mode" in my Win7 Professional box.

I have enabled "XP Mode" in the Win7 PC and installed the Novell Client 4.91 SP5 for Windows XP.  
I still cannot get it to login to the server.  It will not detect any servers as available.  I don't know what I am missing.

I looked in the properties of the Local Area Connection (in XP Mode) and I do have the NWLink IPX/SPX/NetBIOS protocol installed.

I am unsure of why it is not connecting.  Is there a substantial difference between XP Mode and Virtual PC with a straight install of XP?  

It seems like the XP Mode is more tightly tied to and operates through the Win7 host OS.  I am not sure if the XP Mode has direct access to the hardware or if it has to communicate through Win7 (which does not understand IPX/SPX).


My next thought is to try a discrete NIC instead of the onboard adapter.  Maybe the card itself doesn't play well with ODI drivers and the like.  I have always had good results with Intel Pro100 cards on my PCI based machines.  I can find a PCIe equivalent and try it.

If anyone has any experience with this kind of "bridge to the past", please let me know.  
      

UPDATE:  I have tried giving XP Mode direct access to the LAN Interface via the "Tools" drop down menu at the top of the Virtual PC window.  The default is to use NAT (Network Address Translation) and masquerade as the host Win7 OS.

That didn't work either.

I have ordered a new Intel Pro1000 adapter that has support for DOS/ODI.  I will install it and see how that goes.  Maybe I will run two interfaces - the onboard for Win7 and the NIC for XP Mode.  I will know more next week when the card arrives.
0
Comment
Question by:TerryWeir
  • 5
  • 3
8 Comments
 
LVL 18

Accepted Solution

by:
ZENandEmailguy earned 125 total points
Comment Utility
Remember Microsoft stripped out IPX support in Vista.  The fact you see NWLINK... in XP mode is interesting.  When you installed the Novell 4.91.x client did you install as IPX Only?  You should also have chosen Bindery instead of eDirectory near the end of the choices.

I put XP on MS Virtual PC on Win7 and it works great except for printing.  Login, drive maps, saving files, and opening the major app needed from the NW3.12 server work great.

Scott
0
 

Author Comment

by:TerryWeir
Comment Utility
Scott,

Yes, I know that MS has killed all of us Netware legacy folks by taking out the IPX/SPX.  I wonder what the harm was in leaving it in...

When I installed the Novell Client inside XP Mode, the installation was just like normal. I did the custom installation and selected IP/IPX (which works fine on my WinXP laptop).  I have the default protocol set to IPX.  From what I can see when I compare the typical settings in my WinXP laptop to the XP Mode installation, it all looks identical.  It should work, assuming that there isn't a hardware issue.

I'll see how the new Intel Pro1000 NIC works.  If that doesn't do the trick then maybe I'll try to install XP on Virtual PC from scratch.

Is that what you did, install XP from a CD in the MS Virtual PC?  I just downloaded the "XP Mode" from Microsoft directly.  Do you have to have a separate license for the XP in your Virtual PC or does MS accept your Win7 license, like it does for the XP Mode?

0
 
LVL 18

Expert Comment

by:ZENandEmailguy
Comment Utility
I installed from the XP CD in a Virtual PC on Win7 Home Premium.  The client had purchased a Win7 Pro (or perhaps Ultimate) but we left it shrink wrapped.  XP Mode wasn't available to us in Win7 HP.  He had a spare XP license so we used that COA and it worked fine.  Didn't try to use the Win7 license in a "downgrade" mode or whatever it is called.

If I could get it to print (printer is parallel port connected to the Win7 host) I'd have a complete working virtual PC.  I can see the host printer and the job appears to go to it but nothing prints.
0
 

Author Comment

by:TerryWeir
Comment Utility
Are you trying to print using Netware PrintServer Queues or are you just trying to print to a local LPT1 using a CAPTURE statement?

I think that you can enable lots of Sharing between the Virtual PC and the Host OS.  You can probably have the VPC use all of the local printers as they are name in the Host OS.  Just make sure that you know what port the Host Win7 OS is using for the printer (i.e. LTP1 vs LPT3 or something).

For your Virtual PC setup, that is what I was afraid of.  I'm thinking that the "XP Mode" is somewhat neutered relative to a fresh install from CD.  I have no such CD available to me.  That could be the tricky part.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 18

Expert Comment

by:ZENandEmailguy
Comment Utility
The printer is connected to the host via parallel port and prints fine from the host.  It appears as LPT1 and in the settings for the VPC, I can use LPT1.  The job from the VPC appears to get to the printer "queue" on the host but doesn't actually print out.  I'm not completely positive if the extra LPTx card the client bought was put in correctly or not...I assume it was because I can print from the host.

I hope to figure this out for him sometime soon.  It hasn't been a pressing issue.
0
 

Author Comment

by:TerryWeir
Comment Utility
UPDATE :  After shutting down and restarting XP in the Virtual PC XP Mode, it seemed to find the NIC and is able to connect to my Netware 3.12 server!  This is setup giving XP Mode a direct connection to the onboard NIC.

I will try to set it up using the "Connection Sharing" feature.  If I can get that to work it might enable some access to the Netware Server files in Windows 7 via the shared connection through XP Mode.

We'll see.

At a minimum, I have a fully operational copy of XP in XP Mode that can access my server.  That is a HUGE relief!
0
 

Author Comment

by:TerryWeir
Comment Utility
Last Update:  The onboard ethernet is not a problem.  I did not have to install the Intel NIC that I bought.

As long as XP Mode has direct access to the ethernet adapter, it can login to Netware.  When I try to use the shared connection (using Network Address Translation through the Win7 host OS, I cannot access Netware.

So just use direct access in XP Mode and it should work fine.

My only other issues are getting XP Mode to login to Netware automatically when I boot it up.  For some reason it doesn't.  I have to login manually.  I would also like to be able to access the Netware file server in Win7 by creating a connection into XP Mode or some other share, but that is a trick for another post.

That is all.  I will close this question now.  Thank you.
0
 

Author Closing Comment

by:TerryWeir
Comment Utility
Just download the XP Mode from Microsoft and run it.  Remember to reboot it for all the settings to take effect.  Use direct access to the hardware, not NAT through Win7
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

This article will show you how to create an ISO CD-ROM/DVD-ROM image (*.iso), and MD5 checksum signature, for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5). It's a good idea to compare checksums, because many installations fail because of a corr…
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now