Avatar of mattkiran
mattkiranFlag for United States of America asked on

Change smtp port in exchange 2007

Hi , I  have a major issue.  Verizon FIOS decided to block port 25 in my area for commercial account. I an m running SBS2008 with exchange 2007. Is there anyway to change the smtp server port from 25 to 587. My email is queue is full of outbound email.

Thank you in advance for your help
ExchangeWindows Server 2008

Avatar of undefined
Last Comment
mattkiran

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Viral Rathod

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
SOLUTION
Akhater

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Alan Hardisty

SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Akhater

@alanhardisty how would that solve the issue of his outbound email queue ?

Other SMTP servers will still be expecting communication on port 25 so no matter what ports he change it to email won't pass thru
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Alan Hardisty

@Akhater - You can send out via whatever port you want - this has no bearing on the receiving port at the other end.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Akhater

@alanhardisty what you are changing is the destination port so the send connector will be using port, say 26, to communicate with the mail server of gmail.com instead of 25. the latter is not listening to 26

unless you are talking about something different like setting your own smart host relay outthere on 26 or so
Akhater

@viralrathod thanks for the sanity check
Alan Hardisty

@Akhater - so are you saying that if the Send Connector port is changed to port 26 (as an example), then that server can only communicate to server listening on port 26?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Akhater

@alanhardisty  yes exactly since the destination port of the packet should match the listening port of the destination
Alan Hardisty

Okay - that makes sense!  Sorry - I'm tired.

You can change the port - as long as you have a smart host on the other end listening on that port, so if Verizon can receive on port 587, then you can send them your mail to be delivered, otherwise switch ISPs to one that is not blocking port 25.
ASKER
mattkiran

Hi everyone, I must say that this blog is the best in the world.  I am impressed with the response. I wanted to update everyone. Verizon FIOS is converting their system to accept outbound emails on  outbound port from 25 to 587.  They claim that they are getting a lot of spam on port 25. I followed instruction in this answer to change the send connector port to 587 and then verizon FIOS gave me a smtp server (outgoing.verizon.net) ,user name and password that I had to put in the send connector. Now it is workin. They did not notify anyone. They are converting from state to state. Their smtp server listens on port 587. Thank you very much for your help. Its great.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Alan Hardisty

Sorry for the confusing posts - it's been a long week.

Glad you are sorted and mail is flowing.

Alan
Akhater

yes what counts is that it is working for you now :)

cheers
ASKER
mattkiran

YES...... I have to say it again that all of you are great help. I learned how to change send connector port. That was very important. I hate monopolies. Verizon can do what ever they want. Sucks. Sorry to close this on a negative remark. I wish I could give everyone 500 points. Have a great weekend.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Mark Damen

So my comment stands true, they are blocking Port 25 from their connections, but allowing you to relay out via their authenicated SMTP Server?
Alan Hardisty

Yes - your comment stands true - the extra part needed was the article on how to change the default port from 25 to 587.
Alan Hardisty

Assuming you have all that you need - please don't forget to close down the question accepting the best answer(s) that assisted you with solving your problem.

Alan
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
ASKER
mattkiran

Thank you for your help and sorry for the delay.