Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 868
  • Last Modified:

Unable to access sec.gov by name

We are having an issue accessing sec.gov website, it seems to be hit or miss.  No reports of any other websites not being accessible.  Am pretty sure it is nothing on their side, but something in our DNS.  We are able to get to the site if we connect to our external DSL line or I remote into my home machine.  We are using MS DNS server on our domain controllers. OS = 2008r2. Below are the steps I have gone through, doing "ipconfig /flushdns" and "ipconfig /registerdns" after most steps:

Unable to ping sec.gov
Unable to ping sec.gov by IP - most likely have responses turned off
Added googles public dns as a forwarder on our DNS servers (with our ISP provided DNS servers) and moved it to top of the list.
Removed our ISPs provided DNS server and left just the google DNS server  
Restart DNS server service

The below work, but are just work arounds not resolutions:
Statically set the DNS server in the NIC to googles public dns (8.8.8.8) and able to get out without issue.
Able to access the site by typing the IP address instead of the name

Any other assistance troubleshooting this would be great.  Thanks ahead of time.
0
DebelloCaminus
Asked:
DebelloCaminus
  • 3
  • 3
1 Solution
 
avilovCommented:
check if your DNS server has conditional forwarding set for that domain
0
 
DebelloCaminusAuthor Commented:
Avilov,
   Thanks for the response.  Checked conditional forwarding on both servers and there are none set.  Also for more information.  This does seems to be only happening in our 1 site, out of 4.  All DNS servers are suppose to be replicating with each other and they seem to be without issue.  I went through all settings of the dns server that seems to work ok and the one that isn't.

I turned on logging and attempted to access sec.gov again.  Everything seems to be ok to me.  I can attached log if needed.

Thanks again
0
 
Amit BhatnagarCommented:
Try this :

Run this command on the Server with this issue :

dnscmd /Config /EnableEDnsProbes 0

As per article. It is for 2003 but i have noticed and resolved similar issues in 2008 as well.

http://support.microsoft.com/kb/828731
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
DebelloCaminusAuthor Commented:
This article actually makes sense.  We are using a Cisco ASA device for our firewall and its an older version of the IOS.  My only question would be, is anything else dependent on the EDNS being enabled?  As a current work around I statically set an outside dns server (8.8.8.8) as in our DHCP options.
0
 
Amit BhatnagarCommented:
None..It's a feature which was started with Windows 2003 and I was working with Microsoft Networking Team at that time. We disabled this feature in almost 100% of all the issues that came by us and it worked. No one came back saying disabling it broke one of the other functionalities.

Do try it and let us know the result :)

-Amit Bhatnagar.
0
 
DebelloCaminusAuthor Commented:
Amit,
   Thanks for the info.  I ran the commands on both our DNS servers and removed the 8.8.8.8 entry from our DHCP options.  Ran ipconfig /flushdns and ipconfig /registerdns for good measure and am able to get to all the sites I wasn't able to before!

Thanks again
0
 
Amit BhatnagarCommented:
Glad it worked !! :)
-Amit.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now