• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 833
  • Last Modified:

Printer not found after adding Security to Linksys Router

Wireless printer (NX510) worked until I added WEP security to Linksys WRT54gs.  Epson status sheet shows:  link is connected, channel 6, wep-64 bit, mac address of router as access point, TCP/IP auto ip address, ip address 169.254.253.1, subnet 255.255.0.0, no default gateway, APIPA & Bonjour are enabled, Bonjour name is EPSON88F615.local.  and bonjour printer name is EPSON88F615, WSD enabled, MS Network disabled.

Linksys WRT54gS shows:  Status Local Network has ip range of 192.168.1.100 thr 149 (does this affect the high printer ip address?), DHCP is enabled.  The DHCP table shows ip addresses and mac addresses for router and each Mac and PC - but not the printer;   Status Internet shows login:  auto DHCP, with proper ip addr, subnet, default gate - and has two DNS entries.  Parental control is disabled;  no time/access restrictions by day/hr;  port range is blank;  Server settings for DHCP is enables and max of 50 users, no entries in Status DNS nor in WINS.  Starting ip is 192.168.1.100.  Wireless network mode is mixed, channel is 6-2.437 GHz, SSID broadcast is enabled;  Wep encryption strings are 10 digits each, WEP 64, and same upper case was entered on the printer's control interface for the wep key.  Wireless MAC filter is disabled (tried enabling using Mac address of printer & PCs - but same results).  Authentication type is Auto;  

Removed printer and drivers on Mac OS 10.6 and installed again.  Also tried 1st time install on Win XP - all computers fail to find the printer using the Print Net utility.  Router does not include the printer mac address nor ip addr in the DHCP table - so I'm thinking the router isn't accepting the printer.  The printer status page seems to think it sees the router and is connected (the printer does have 'green' light showing the wireless connection is active).

Help please....  I don't know if the printer needs to be in the same ip range of 100-149, nor if it should show up like the computers do on the DHCP table on the router.  Nothing has been done regarding ports on any of the devices.   I'm in a bind, as I added the security to help out a friend that I still want to keep as a friend...  :-)
 
0
mjashley
Asked:
mjashley
  • 5
  • 2
2 Solutions
 
TronnixCommented:
In the router UI treat the printer just like you would any computer, It has a network card wth a mac address. What it sounds like is you didn't add the security password to the printers network settings. The printer has to know your using wep if it doesn't already auto detect it. Then it should ask for the wep key/password you created for the network. Untill it does that the router and the printer will not connect.
0
 
mjashleyAuthor Commented:
Hi Tronnix - I did add the WEP to the printer.  The printer status page details above, explain that the printer is connected to the router using WED, and has an ip address that is outside the range of the DHCP ipaddress range...   The printer seems to think it is connected to the router - I don't know how to verify the security was accepted - except that I used a verified WEP code, and the printer - the green wireless light on the printer indicates it is connected also.
0
 
mjashleyAuthor Commented:
I meant the details are shown as connected using WEP - not WED....
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
TronnixCommented:
the printer is using its standard ip because it not connected to anything. If the router doesn't see the mac address of the printer its not connected. It would show up just like a computer, because all the router cares about is the mac address not whats behind it. I would clear the printer wireless setting completly and start over. Imput it agian and make sure everything is correct. Also check that the printer is using the correct protocals and signal. So make sure its on wep and not wep2 and its on the same wireless b,g,n that your using with the router. Check the basics on this issue because untill the router reports the printers MAC address its not connected.
0
 
mjashleyAuthor Commented:
I will try - I know it's on WEP and the router is set to "both: versus b,g - Thanks for the info on the 'std ip'.  I can't try tonight - but I'll try to either do this tomorrow or on Monday - and dig up more info on how to detail more settings on the printer.  I'll get back to you/this site as soon as I can find out more and get access to the router/printer again.
0
 
mjashleyAuthor Commented:
Tronix was very helpful, because it pointed out that the printer was NOT getting the ipaddress back from the router.

The problem turned out to be the following, after working with tech support at Epson and after nothing helped, working with Linksys:

1)  The epson printer worked with straight decimal numbers as the security code - no alphas that are contained in the hex code I was trying to use.  
2)  The firmware on the router was corrupted -- after the many resets that were needed to work thru all the basics with Linksys and Epson.
0
 
mjashleyAuthor Commented:
See my final comment for the final solution.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now