Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 792
  • Last Modified:

Firefox and x-frame-options:deny

I have a tool I use on my own website, for doing research, that uses frames.

When I use it with IE, on google.com sites, I get this:

"This content cannot be displayed in a frame"

I understand this has something to do with clickjacking and X- FRAME-OPTIONS: DENY.  But I don't know much more than that.  

I've downloaded firefox, I don't get that message, but the page that I am trying to access just doesn't load

Question: is thier a plugin or setting I can change so that I can get around this and access the pages in a frame?

Thanks,   Chris
0
St_Aug_Beach_Bum
Asked:
St_Aug_Beach_Bum
  • 5
  • 4
1 Solution
 
Michel PlungjanIT ExpertCommented:
Are there no errors in the javascript console in Fx?
0
 
St_Aug_Beach_BumAuthor Commented:
Hi,

Not in FF, but in internet explorer there is.  Let me give you an example here:

http://www.sure-start.com/testing.html 

In my actual application, I have a third frame for writing about what I find, but pared it down to make this easier.

If you click on one of the links in the left frame, it works fine.  But then if you click on one of google's links, like the 'top stories' or 'all (number) articles', I get a blank page.
0
 
Michel PlungjanIT ExpertCommented:
In Fx I get links and can click them

I will look on Monday at IE8
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
St_Aug_Beach_BumAuthor Commented:
hmm, even the links below the grouping of articles that say something like  'all 27 news articles ยป'?

It's those and the other links to google that don't work for me on either ff or ie.

Thanks for taking a look.
0
 
St_Aug_Beach_BumAuthor Commented:
I *think* it's related to this:

http://blog.mozilla.com/security/2010/09/08/x-frame-options 

though I'm not positive.  So I was hoping to find a plugin/addon that would allow me to turn that firefox feature 'off'.

Chris
0
 
Michel PlungjanIT ExpertCommented:
Yet another inconsistency
0
 
St_Aug_Beach_BumAuthor Commented:
I'm not sure what you mean...

I'm thinking that if there isn't a way to do this, I may just downgrade to an earlier version of firefox just for use when I am diong using this page.
0
 
Michel PlungjanIT ExpertCommented:
yeah. Sounds like a plan. What I meant with inconsistency was that your initial view works but not the second click
0
 
St_Aug_Beach_BumAuthor Commented:
That's what I'll do then, thanks for jumping in to help, Chris
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now