• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 669
  • Last Modified:

Windows and Linux Problem IP Address

We have this scenario here. we have the .NET server which is having an IP 31 which is on windows 2003 and a squid proxy server on red hat linux with IP:3

Now on this .net server we have domain controller installed as well and we have made a dns server as well. So if we create any website then we have to add that entry into the DNS.

now the configuration of each client window machine is as follows :

ip: a unique ip.
subnet:255.255.255.0
gateway :192.168.1.1

primary dns:192.168.1.31 (the server where we created dns)

and the IP configuration for server with ip 31 is :

ip:31
subnet:255.255.255.0
gateway : BLANK

Primary DNS:127.0.0.1

all these computers are getting internet from proxy which is IP 3 so entry is done in browsers(both server and client machines). Now gateway in server is not given because if we given gateway 192.168.1.1 in server then clients machines can open Gmail.com which we have blocked in proxy.

Why we have given gateway in client machine because Internet still works even if we remove gateway in client machine?

The reason is we have to give access to our employees to our company email accounts whose incoming and outgoing pop servers are mail.companyname.com
Now if we dont give gateway in client machines, we are unable to configure mail.companyname.com email ids in Outlook because i think some kind of settings is done in SQUID not to allow mail.mail.companyname.com.com which we did some time back because we were unable to take backups of each client machine emails. Now we are able to take email backups so that is done. so we want to remove this restriction in squid.

Why this problem came?

Now if we are opening any .net website from client machine which is installed on 31 server and that page has Recaptcha control in it , it gives error that it is unable to contact recaptcha server . so we want technousa.com to be accessed from proxy and then we will add the gateway at server 192.168.1.1 and remove this gateway from clients. so technousa.com email accounts will come from proxy and recaptcha will contact the recaptcha server directly without going through the proxy.

Please help us with this problem as we have to solve recaptcha problem as soon as we can .

thanks
Johnny.
0
technicalsys
Asked:
technicalsys
1 Solution
 
garyhak2009Commented:
Hi

Does the domain controller have a default gateway? How are your doing external dns name resolution? I have never used SQUID before put all proxies have a setting to bypass proxy for local addresses.
What browser are you using you can set proxy settings in browser to bypass proxy for local addresses.
0
 
wamanmaCommented:
Most probably recaptcha server or the port from which recaptcha is used is blocked in squid proxy.

You can check the access.log file to check what is blocking recaptcha. To do this do the following..

1. on the squid proxy server cd to squid log location (default is /var/log/squid)
2. enter the command "tail -f access.log | grep x.x.x.x ( x.x.x.x. being ip address of the client from where you would run your web application to check recaptcha)
3. find which address or port s denied)

you will have to allow access to the blocked content in squid..

If this does not help, post the output of the above command.

Take care..




0
 
technicalsysAuthor Commented:
Did not get the proper solutiosns
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now