Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 837
  • Last Modified:

Setup a new Exchange 2010 Server

I am working on a test system at home.  I have everything setup where I think it should work, however I seem to have an issue.  The way the network is setup is static IPs, one for the router, and one for the Server, which is running Windows 2008 R2, it is a domain controller, DNS, Exchange 2010 Server, IIS7 Server.  It does it all.  Have to as I only have one computer to use at this time.  IIS7 works fine, as I can get to a web page on the server, so routing is working.  Exchange 2010 seems to be working fine internally as I can send emails to one account to another just fine.  However if I send a message outside nothing happens, the email just goes off and never arrives.  If I sent a message inbound it bounces back with the following error:

This is the mail system at host smtp15.relay.dfw1a.emailsrvr.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                  The mail system

<iwindon@450p.com>: host 99.28.107.226[99.28.107.226] said: 530 5.7.1 Client
   was not authenticated (in reply to MAIL FROM command)
Reporting-MTA: dns; smtp15.relay.dfw1a.emailsrvr.com
X-SMTP-Server-Queue-ID: F3D253001F6
X-SMTP-Server-Sender: rfc822; iwindon@ghpstudios.com
Arrival-Date: Sat, 13 Nov 2010 10:06:59 -0500 (EST)

Final-Recipient: rfc822; iwindon@450p.com
Original-Recipient: rfc822;iwindon@450p.com
Action: failed
Status: 5.7.1
Remote-MTA: dns; 99.28.107.226
Diagnostic-Code: smtp; 530 5.7.1 Client was not authenticated
Return-Path: <iwindon@ghpstudios.com>
Received: from localhost (localhost.localdomain [127.0.0.1])
      by smtp15.relay.dfw1a.emailsrvr.com (SMTP Server) with ESMTP id F3D253001F6
      for <iwindon@450p.com>; Sat, 13 Nov 2010 10:06:59 -0500 (EST)
X-Virus-Scanned: OK
Received: by smtp15.relay.dfw1a.emailsrvr.com (Authenticated sender: iwindon-AT-ghpstudios.com) with ESMTPA id 9567130017C
      for <iwindon@450p.com>; Sat, 13 Nov 2010 10:06:59 -0500 (EST)
From: Ivan Windon <iwindon@ghpstudios.com>
Content-Type: multipart/alternative; boundary=Apple-Mail-1--31502846
Subject: test
Date: Sat, 13 Nov 2010 09:07:05 -0600
Message-Id: <B52DBECF-AC38-46FA-90A1-FCB2C32D4EB9@ghpstudios.com>
To: iwindon@450p.com
Mime-Version: 1.0 (Apple Message framework v1081)
X-Mailer: Apple Mail (2.1081)

I have an MX record pointing to the public IP address of the server.

I ran some SMTP tests as well and it says something along the lines of Client
   was not authenticated.  I'm thinking I need to setup Exchange to allow anonymous connections?  Is this the route I need to go?

Thanks,

Ivan
0
Ivan_Windon
Asked:
Ivan_Windon
  • 4
  • 2
2 Solutions
 
Viral RathodConsultantCommented:
0
 
Viral RathodConsultantCommented:
If you don't have an Edge server then you do not have a connector with anonymous authentication enabled. You need to adjust the properties of the Default Receive Connector to allow anonymous access. You do not need to create a new Receive Connector.

Ref :
http://msexchangeteam.com/archive/2006/11/17/431555.aspx
http://www.petri.co.il/forums/showthread.php?t=24460 

0
 
Ivan_WindonAuthor Commented:
Well progress is being made.  I can now receive emails.  I created a send connector, however still can't get emails out.  Is there something else I should look at as to why emails won't go out, they look like they get sent, but never arrive at the destination.

0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Viral RathodConsultantCommented:
Have you configured a Send Connector?
Under Organisation Configuration > Hub Transport > Send Connector
you need to setup a connector with an address space of * to use either DNS or smarthost.

If you use DNS then you need to configure a rDNS(PTR) record for say mail.yourdomain.com an A record in your external DNS for mail.yourdomain.com that points to the external IP of your network (Find out what your external IP is by going to http://whatsmyip.org )

Then on the FQDN section of your send connector enter mail.yourdomain.com

ypu will also need to setup an SPF record see: http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/

Hope this helps.
0
 
Viral RathodConsultantCommented:
Also refer
http://www.petri.co.il/configuring-exchange-2007-send-external-email.htm

If you face any issues then check the Toolbox -> Mail Flow Troubleshooter for more clues about what's going on
0
 
Ivan_WindonAuthor Commented:
Emails now work both ways.  Just needed to create an A record pointing to my public IP.  Thanks for all your help again.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now