Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Exchange Moved, new subnet, now Iphone/ipad Exchange connection fails?

Posted on 2010-11-13
20
Medium Priority
?
657 Views
Last Modified: 2012-05-10
Hi Everyone thanks in advance for the assistance.

Heres the issue!!

I have moved the Exchange server to a new site with a different subnet. ever since that i cannot get iphone or ipad exchange mail, contacts, calendar connection/sync working.

outlook web access works, rpc works on laptops.
if i go to oma acces in broswer i get a "  A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator." error.

i checked the forms based issue.. and that is disabled. plus i have the new ip address of the server in the IIS settings of the website.

exchange is sending an recieving emails in the queue...everything else seems to be working.

any ideas? i can get info if more is required.
0
Comment
Question by:BooWii
  • 9
  • 8
  • 3
20 Comments
 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34129304
Are you sure that port isn't blocked or a firewall is stopping you?

Can you refer the following article from Alan and make sure you are not missing anything
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34129332
Please Ignore Previous

First check this out
ActiveSync not working after Exchange 2003 IP Change and make sure you are not missing anything

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26242416.html
0
 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34129333
Please Ignore Previous

First check this out
ActiveSync not working after Exchange 2003 IP Change and make sure you are not missing anything

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26242416.html
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:BooWii
ID: 34132941
I went through those...and cant see anything that pops out...i did the exchange test and get this.
      
Attempting the FolderSync command on the Exchange ActiveSync session.
 The test of the FolderSync command failed.
 Tell me more about this issue and how to resolve it
       
Additional Details
 Exchange ActiveSync returned an HTTP 500 response.

looking at what that says in the KB article none of those things have changed....
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132960
Is your Exchange part of SBS 2003?

How is the certificate named?  Does it have the IP Address in the certificate name or is it named correctly?

HTTP 500 errors are usually fixed by following KB883380 mentioned in my article that viralrathod has already posted:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 

Author Comment

by:BooWii
ID: 34132972
Its not part of SBS 2003
and the certificate is named after the FQDN of the server.

i'll give method 2 a shot then... and see if it fixes it. cheers.

i'll let you know how i go.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132974
Thanks.

Before you do - is the default website using an IP Address or All Unassigned?  Ideally it should be All unassigned.
0
 

Author Comment

by:BooWii
ID: 34133020
All unassigned. when i first moved it i changed it from the old ip to the new one and then when i came across on of your other articles i swapped it to unassigned...but still didnt help.

and i just finished method 2 doesnt seem to have made any difference.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34133025
Okay - not great news.

If you right-click on the Exchange virtual Directory and select Browse - what happens?
0
 

Author Comment

by:BooWii
ID: 34133033
says it has to be viewed over a secure connection.
it wants https://
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34133063
Good - in that case - can you open a browser on the server and view https://localhost/exchange

Do you get a sign-on screen and if you sign on - do you see your mail?
0
 

Author Comment

by:BooWii
ID: 34133071
yeap that works without any issues....but if i type in oma afterwards to test the mobile part it comes up with the error above in the first post.

plus rpc for outlook works aswell...external machines to the network get access to exchange.

this has only been a issue since ip change.
0
 

Author Comment

by:BooWii
ID: 34133094
and from the iphone i get a
"Cannot Get Mail"
the connection to the server failed
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 1000 total points
ID: 34133101
As per the following section in my article:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Exchange 2003 (Not part of Small Business Server):

Exchange Virtual Directory
•      Authentication = Integrated & Basic
•      Default Domain = NetBIOS domain name - e.g., yourcompany (no more than 15 characters)
•      Realm = yourcompany.com
•      IP Address Restrictions = Granted Access
•      Secure Communications = Require SSL NOT ticked (very important)

Microsoft-Server-Activesync Virtual Directory
•      Authentication = Basic
•      Default Domain = NETBIOS domain name - e.g., yourcompany (no more than 15 characters)
•      Realm = NETBIOS name
•      IP Address Restrictions = Granted Access
•      Secure Communications = Require SSL and Require 128-Bit Encryption IS ticked

Please remove the Require SSL setting on the Exchange Virtual Directory, run IISRESET and test again.
0
 

Author Comment

by:BooWii
ID: 34133109
should i have SSL enabled in any other sections...ie the exchange web access?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34133113
Do you mean the OMA virtual directory?
0
 

Author Comment

by:BooWii
ID: 34133115
seems to be working...i took SSL off on the Exchange Virtual Directory and left it turned on for all the rest.

Thanks heaps looks like everything is coming up.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34133121
Great news - SSL on the Exchange Virtual Directory should not be enabled normally although not sure how it managed to turn itself on changing the IP settings!

Alan
0
 

Author Comment

by:BooWii
ID: 34133123
It could have been something i had done in teh process of trying to get everything to work....i have messed around with a lot of settings lol!!!!

again thanks!!!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34133129
Oh well - tread carefully next time : )

You are welcome.

Alan
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

783 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question