[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

unable to delete messages in OWA after exchange 2010 SP1 install

Posted on 2010-11-13
22
Medium Priority
?
3,656 Views
Last Modified: 2012-05-10
after installing SP1 for Exchange 2010 when we try to delete any messages in OWA the following error is displayed:
The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem continues, contact your helpdesk.

does anyone know how to resovle this?

thx - S.
0
Comment
Question by:siber1
  • 12
  • 9
22 Comments
 
LVL 8

Accepted Solution

by:
ShareefHuddle earned 1500 total points
ID: 34129834
Here is what to do:

Try deleting or renaming the web.config file in your ...inetpub\wwwroot folder


http://social.technet.microsoft.com/Forums/en-GB/exchange2010hosters/thread/e45d7277-b205-4791-a430-631b163a5072
0
 

Author Comment

by:siber1
ID: 34129847
actually, that is not a good solution for me as this file contains the redirect that i need to use to HTTPS
also, i would think there must be a better solution that deleting a key file on the server.

0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129885
Ok well try this:

Rename the web.config file.

Then follow the steps in Brian's blog for your redirection.

http://briandesmond.com/blog/redirecting-owa-urls-in-exchange-2010/
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129890
Forgot to also add backup your default web site to :)
0
 

Author Comment

by:siber1
ID: 34129901
just tried that, and the same problem occurs.
when i rename the web.config file, and re setup the redirect, a new web.config file is generated. I still have the same issue. cannot delete messages or move to personal archive. the exact message is:

The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem continues, contact your helpdesk.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129916
Does it work on owa lite?
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129925

Open IIS Manager and select the Default Web Site. On the right hand side, under actions, click bindings. On one of the http bindings is the Internal FQDN for OWA and removing this fixed the problem.
0
 

Author Comment

by:siber1
ID: 34129926
yes, works in OWA lite.

I just took off the redirect and deleted the web.config file completely. still having the same issue.
0
 

Author Comment

by:siber1
ID: 34129930
not sure i follow, under the HTTP bindings i am not specifying a host header value, so no internal FQDN is present.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129938
Hmmmmmm....
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129942
And you did iisreset? I know it's a dumb question but just want to make sure :)
0
 

Author Comment

by:siber1
ID: 34129943
yes, several times.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129945
Is this in your web.config?

<system.webServer>
<httpRedirect enabled="true" />
</system.webServer>

If so remove it and iisreset
0
 

Author Comment

by:siber1
ID: 34129952
I have deleted the web.config all together. it no longer exists. i also removed the redirects i had in place. still the same issue.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129955
Check your /exchange and verify that it doesn't state redirect request to it
0
 

Author Comment

by:siber1
ID: 34129963
no luck. same issue.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129964
Do you have your ssl port set to all unassigned or ip specific?
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34129974
Well it is late here. If you find the fix please post.

Have you looked at this msexchange forum?

http://forums.msexchange.org/m_1800538473/mpage_1/key_/tm.htm#1800538473
0
 

Author Comment

by:siber1
ID: 34133391
Hi Sharee, i ended up calling MSFT and the issue is now resolved. I ended up having to change the way i was redirecting, as well as reset the virtual directories.

cheers!

S.
0
 

Author Closing Comment

by:siber1
ID: 34133394
ended up calling MSFT to resolve.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34133718
Do you mnd posting the steps they walked you through for the redirector?
0
 

Expert Comment

by:swbruce21
ID: 34676118
I resolved this issue using by uninstalling the CAS role and reinstalling it.  It took about 45 minutes total because 4 hotfixes have to be reinstalled before you can reinstall CAS.  Each hotfix asks for a reboot.

There is also a temporary workaround that got me by for a couple of days before I fixed it. Disable "SSL Required" on the EWS virtual directory.  The connections still seem to be in an SSL session.  Some other applicaiton error events are caused by this temporary workaround.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

868 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question