Solved

VPN Server on Vista /Windows7 using remote detault gateway

Posted on 2010-11-14
14
748 Views
Last Modified: 2012-05-10
Hi
I am trying to setup a VPN Server on my Vista and Windows 7 and it connects ok from remote location.

My Problem is that i want to use the remote site (my home) as default gateway due to me running applications that check mp ip and it needs to match my home ip to run when I am out traveling.

on the host PC i only seem to be able to set IP address, and not Default gatway, so when i try to connect to my host from remote site, it connects, it tries to use the remote default gatway but as not set, i get no internet.

I have tried to right click on my Host VPN and Properties again, but I can only set IP

Is there a way around this?
0
Comment
Question by:morten444
  • 5
  • 4
  • 2
  • +2
14 Comments
 
LVL 68

Expert Comment

by:Qlemo
ID: 34130466
I don't get why you should not be able to set the default gateway at your host PC? In the TCP properties of your network driver, you can set IP, netmask, default gateway, and two DNS servers.

However, I don't think that helps you. You still need to set up your host as a router to allow to use the remote default gateway. Else it allows only access to the host itself.
0
 

Author Comment

by:morten444
ID: 34130494
Hi Thanks for reply
For the incomming connection, I can only set IP address. Nothing else.
See attached picture

I was sure if I conected to my hope PC via VPN, I become on lan just like i was sitting at home.
I would get an IP of my local lan (I do get this) and if I configure default gateway, I should be about to write my home routers IP as gatway and I should be able to use internet that way.
Is that not correct?

I have setup VPN host on Win2003 and it works with that. I just dont have a Server here so therefore I am trying with Windows Vista/7
vpnhost.jpg
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 34130518
You cannot provide the default gateway in "Incoming connections", that much is true.
The issue is that the host PC will either try to push its own IP or its configured LAN default gateway to the connecting client. RAS should do that itself if you tick the "Use remote gateway" setting in your RAS client config.
If you cannot get it to work, you will need to set your default gateway manually while connected. But that is unlikely and cumbersome.
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 34130521
Have you tried ipig ? its free and easy to setup :)

http://www.iopus.com/ipig/

You need to get the iping express server and the client.
0
 

Author Comment

by:morten444
ID: 34130804
Hi
I have tried to setup ipig. Seems very easy so i feel quite stupid having issues with it!!

on my lan i have a vista and windows 7 pc

Server:
Installed on vista
created user and pass
no cadlock infront of username
server port 11888
rest default
restarted

Client
Installed in Windows 7
restarted
Typed in my user and pass
Under "Advanced settings" i changed pc to local ip 192.168.2.3 port 11888 (vista pc)

I now try to connect but it says "unknown server 192.168.2.3/11888
I tried the other way around (vista as client and windows 7 as server) same thing

I then thought that there might be problem on using it on lan

I configured server using WAN ip
In router i forwarded all trafic on 11888 to 192.168.2.3
Logged onto a remote server away from home
Installed the Client
Restarted
Typed in user and pass and WAN ip
Still exactly the same thing

I must be missing something
My Windows 7 works as webserver, windows vpn can dail in, rdp can access in through firewall. I have no firewall on my pc

Does it soulds right what I am doing or am i missing something
0
 
LVL 1

Expert Comment

by:suvalinenimi
ID: 34135399
You can also toggle the "Use default gateway on remote network" on your VPN settings (see screenshot). Use default gateway on remote network
0
 

Author Comment

by:morten444
ID: 34135416
Hi
Thanks for the reply :)
Yes I have the same setting enabled. Thats why my internet is not working when connected, becasue there is no way I can see how to assign "default gateway" on the server for the VPN connection
If i do a "ipconfig" when connected, It shows gateway as 0.0.0.0 and I can not figure out how to set that.

On a normal netcard, you right click -Properties - TCP/IP - Properties and type it in.
On the VPN connection, thats not an option.

How do you do this?

Kind Regards
Morten
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 68

Accepted Solution

by:
Qlemo earned 500 total points
ID: 34136735
Issue a    route add 0.0.0.0 mask 0.0.0.0 192.168.2.1    while connected (in a command prompt).
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 34139889
There seems to be some other issue with your connection or router. Id recommend trying something else.

http://www.teamviewer.com

This might solve all your routing issues. Install Teamviewer on your host computer and set up a user name and password.

Then install the client on your client pc and connect to the host using the VPN option.

I have used this some time back and it worked fine. Give it a shot and try it out. Its free for home users.
0
 
LVL 2

Expert Comment

by:cperry71
ID: 34139965
Don't know if this will work or not but you can add another default gateway by clicking on the advanded button in the TCP/IP properties box.  Add the default gateway of your home network on your client computer.  It's worth a shot.  (make sure you current default gateway is in there as well or you may not connect to the vpn at all.)

Also when you are connected to the vpn run a cmd prompt and ipconfig -all.  See what shows upfor a default gateway and ip address.  
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 34140522
Adding another default gateway is always useless with Windows. The intended behaviour is that if the primary gateway is found dead (unresponsive or unreachable), the secondary should be used. But that is not working.
0
 

Author Closing Comment

by:morten444
ID: 34157926
That did it for me.
Thanks
0
 
LVL 2

Expert Comment

by:cperry71
ID: 34158557
Yeah, that adds another gateway.  check your ipconfig /all and you will see it listed under default gateways.
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 34158606
Not exactly. There has been no default gateway defined before. So the route add does not add an additional but the only gateway. As I have told already, additional gateways do not work.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now