Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 971
  • Last Modified:

Error when Deleting or Copying files when desktop and documents are redirected.

We are currently experiencing an issue when offline files is enabled and either the Desktop or My Documents is redirected to our SAN via GPO.   The redirects are  \\server\users\%USERNAME%\documents   and \\server\users\%USERNAME%\DESKTOP.  If I go to My Documents or browse to the unc patch \\server\users\%USERNAME%\documents and attempt to delete a file we get the following error: “Cannot delete ‘file name’: Cannot find the specified file. Make sure you specify the correct path and file name.” The file however, does get deleted off of the server. If we proceed to disable offline files and manually go to \\server\users\me and create files and attempt to delete them we have no issue. The issue is not replicated on Windows 7 Clients.

We also have an issue when copying from a redirected share or UNC name to a drive mapped on a regular server.   When copying from \\server\users\%USERNAME%\DESKTOP to say a mapped P drive, we get the following error:  Cannot Copy <file> Cannot find the specified path.  Make sure you specify the correct path and file name.   If we copy the file one by one this does not happen.  But if we attempt to copy an entire directory that will happen.  It does however, create the directory on the destination server.  User has full permissions to the destination file share as well.  They can manually create a folder and file.

User has Full permissions to their network folder and have been granted ownership

Specs:
Windows Storage Server 2008
Issue on Windows XP.
0
getzjd
Asked:
getzjd
  • 4
1 Solution
 
MarinertekCommented:
I had a similar issue with MyDocs redirection using server 2008 R2 and XP / 7 Clients. Our issue was that after migrating active directory and the data from 32-bit 2008 to 2008 R2 we were able to browse to the path of the MyDocs, but they were not automatically mapping to the client.

To solve the issue in Group Policy we ended up changing the option of "Move Contents of Documents to New Location" from "enabled" to "disabled" - once we had done this everything started functioning normally. I would double check your options settings - specifically make sure that "Also apply redirection policy to Windows XP operating systems" is also enabled (under User Config > Folder Redirection > Documents > Options)
0
 
getzjdAuthor Commented:
I guess I should have added this....    I have the same policy applied to 3 sites and it maps based on group membership.    One site has the 2008 storage server as the file server, one has a 2008SP2 file server and one has 2003 file server.  The only site with the issue is the site with 2008 storage server.  If i remove the policy users can then users on the 2008 storage server copy and paste, delete, etc from the network drives on the 2008 storage server just fine
0
 
getzjdAuthor Commented:
I already have the "move the contents of the Documents to the new location" box unchecked.  As well as having the "also apply redirection policy to windows 2000...." box checked.
0
 
getzjdAuthor Commented:
FINALLY! After months of digging... this registry change on the 2008 Storage server fixed the issue


Value Name: noaliasingonfilesystem
Type: reg_dword
Setting: 0
Registry Key: HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

0
 
getzjdAuthor Commented:
Figured it out on my own.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now