?
Solved

Exchange 2010 Server not sending emails

Posted on 2010-11-14
14
Medium Priority
?
1,603 Views
Last Modified: 2012-05-10
It worked for a short time, and then for some reason it just stopped.  I can't figure out why either.  I'm obviously missing something and it's begging to irritate me.

So here is how everything is setup.

The public IP of the server is 99.28.107.226

There is just one server, Windows 2008 R2 with Exchange 2010.
A send connector has been setup to allow all smtp traffic.

I am going to be allowing multple domains to send emails, right now I just have a few setup just to test things out.

The server runs as a domain server, web server, and exchange server.

This system is setup at home, for testing purposes, so that's why there is only one server.  I can receive emails just fine.

On my registrar I have DNS setup like this:

A records

www.450p.com 86400 IN A 99.28.107.226  
test.450p.com 86400 IN A 99.28.107.226  
ftp.450p.com 86400 IN A 99.28.107.226  
mail.450p.com 86400 IN A 99.28.107.226  
*.450p.com 86400 IN A 99.28.107.226  
450p.com 86400 IN A 99.28.107.226  

MX Record

450p.com   IN MX 10 99.28.107.226

The main domain name of the server in question is ghp.lcl
The user accounts have email accounts setup for 450p.com and 450p.com is an allowed domain in exchange.

On the DNS side of my server I have the following:

(same as parent folder)  Start of Authority (SOA) [17], ghp-server.ghp.lcl, hostmaster.ghp.lcl
(same as parent folder) Name Server (NS)  ghp-server.ghp.lcl
ftp  Host(A)  192.168.1.2
mail Host(A) 192.168.1.2
test Host(A) 192.168.1.2
www Host(A) 192.168.1.2
(same as parent folder) Host (A) 99.28.107.226

The main domain of the server has the DNS records of:

(same as parent folder)  Start of Authority (SOA) [35], ghp-server.ghp.lcl, hostmaster.ghp.lcl
(same as parent folder) Name Server (NS)  ghp-server.ghp.lcl
(same as parent folder) Host (A) 192.168.1.2
ghp-server Host (A) 192.168.1.2
(same as parent folder) Host (A) 99.28.107.226

Reverse Lookup Zones is setup as:

1.168.192.in-addr.arpa

(same as parent folder) Start of Authority (SOA)  [10], ghp-server.ghp.lcl., hostmaster.ghp.lcl.
(same as parrent folder) Name Server (NS) ghp-server.ghp.lcl.
192.168.1.2 Pointer (PTR) mail.450p.com
192.168.1.2 Pointer (PTR) ghp-server.ghp.lcl

I also have another domain out there that I was doing a test  with called mail.ghpstudios.com that is also set to 99.28.107.206 (external DNS only).  I don't think this would cause any issues, but maybe I'm wrong in that regard.  

What I would like is to have the emails that go out say they are from the domain they are being sent from such as 450p.com, not ghp.lcl (which is only an internal domain).

Any ideas what I might be doing wrong here.  The only versions of exchange I have worked with before are Exchange 2000, and 2003.  2010 is very different and stumping me on this issue.




0
Comment
Question by:Ivan_Windon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
14 Comments
 
LVL 30

Expert Comment

by:Britt Thompson
ID: 34131083
How is your send connector configured, DNS or Smarthost? Try switching it from one to the other and see if it makes a difference. If you're using a smarthost it could be that their servers are down or you have been blocked for some reason. Another reason this can happen is if your server, or a client on your network, has been used to send spam or compromised as an open relay. Often, if your ISP finds an open relay they'll block port 25 outbound preventing the mail from going out until you get it fixed. Or, delete and recreate the Send Connector using DNS.

When making changes to the transport you must restart the transport service before they take effect.
0
 
LVL 8

Expert Comment

by:PenguinN
ID: 34132016
Are messages stuck in your outbox or are they bouncing ?
0
 

Author Comment

by:Ivan_Windon
ID: 34132248
It's configured via dns. The emails leave however I get a message saying the email is being delayed and will continue to retry.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132275
Have you run the Exchange 2010 Best Practices Analyzer from the Toolbox?

If not, please run it and report back any issues.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132304
Current issues with your domain:
1. Reverse DNS is NOT setup on your Fixed IP Address (please call SBCGlobal and ask them to set this up accordingly).
2. Your MX record is an IP Address not a Fully Qualified Domain Name
3. Without fixing the MX Record, you may have problems receiving mail

Please correct the above issues to help with your configuration and to help your mail flow both in and out.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132311
"What I would like is to have the emails that go out say they are from the domain they are being sent from such as 450p.com, not ghp.lcl (which is only an internal domain)."

To achieve this - please modify the Fully Qualified Domain Name on your Send Connector(s).  Exchange Management Console> Organization Config> Hub Transport> Send Connectors Tab
0
 

Author Comment

by:Ivan_Windon
ID: 34132724
I tried something else, which I think shows there maybe a loop or something wrong in DNS externally.  I can send emails out just fine apprently, just not to my ghpstudios.com domain.  

Here is what I did.

At some point I want the main MX record to be mail.ghpstudios.com and have that point to 99.28.107.226 (it's doing so now).  I think I have an A record setup for mail.ghpstudios.com for the IP of 99.28.107.226 (maybe this is the wrong thing??).  Then when I setup an MX record I just point it to mail.ghpstudios.com instead of having to type in an IP.  Right now the domain 450p.com is setup internally on my Exchange 2010 server, it can receive emails, and it can send out to other domains, except ghpstudios.com.

Any ideas on what I can do to clean this mess up.  I must not be seen the logic path of the mail or something right in my head and probably have it just going in circles for all I know.
0
 

Author Comment

by:Ivan_Windon
ID: 34132736
One other thing, the email address it says it is from is ivan.windon@ghp.lcl (not iwindon@450p.com), I change the send connector to show mail.ghpstudios.com in the specify the FQDN this connector will provide in response to HELO or EHLO.  Would that be a reply to address setting I make in the client, or something I need to set on the server.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132799
I see the following for your ghpstudios.com MX records:

Your 2 MX records are:

10 mx1.emailsrvr.com. [TTL=7200] IP=72.4.117.21 (No Glue) [TTL=300] [US]
20 mx2.emailsrvr.com. [TTL=7200] IP=72.4.117.8 (No Glue) [TTL=300] [US]

Where do you think they are pointing to 99.28.107.226?

To setup A and MX records properly, you need to setup an A record called mail and point that to the IP Address, then add an MX record as mail.domain.com and then all will be well.

For example:

Name    Type    Result
mail        A        99.28.107.226

Name    Type    Priority  Result
             MX       10         mail.ghpstudios.com

If you have configured ghpstudios.com to be an accepted domain on your server, then the mail will never get sent externally - it will try to send it internally.  If you haven't set this up yet, then the mail will be delivered to the existing MX records as I have posted.

The Send Connector FQDN does not have any bearing on the email address domain name.  That is down to the Recipient Policy and the account used.  Each account will have a default email address (and thus a default email domain).  If you want to send out as different domains, you will need a different user account per domain or Outlook configured with a primary Exchange account and separate SMTP / POP3 accounts with the Receive part disabled or your mail will start to loop and your server will clog up.
0
 

Author Comment

by:Ivan_Windon
ID: 34132827
The ghpstudios.com part is going to be the last thing I move.  It's important email that can not be lost, or interupted.  Right now I'm doing  tests with other domains I own such as 450P.com, I have the following setup for 450p.com now.

Custom A records
*.450p.com      86400      IN      A      99.28.107.226      
450p.com      86400      IN      A      99.28.107.226      
mail.450p.com      86400      IN      A      99.28.107.226      
Add DNS A Record
Built in MX records
Restore default MX records
Custom MX records
450p.com             IN      MX      10 mail.ghpstudios.com      
Add DNS MX Record
Custom CNAME records
Add DNS CNAME Record

Should I change the MX record on the 450P.com DNS setting to say mail.450p.com (it's also registered setup in DNS on the ghpstudios.com domain as mail.ghpstudios.com, all going to the same IP address.  What I'm trying to do is move all my domains I own from external sources into my exchange 2010 server and host my email with Exchange and my web sites with IIS7.  The IIS7 part seems to be working just fine.  Just need to iron out the last few issues on the mail side.  Once I have tested that everything is working and ready to go I'll change the A records and MX records on the ghpstudios.com to point to my server (99.28.107.226)
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34132842
Okay - so now your MX record for 450p.com is pointing to mail.ghpstudios.com which is technically correct.

Please call your ISP and change the Reverse DNS record on your IP address to mail.ghpstudios.com.

The 450p.com domain can happily have mail.ghpstudios.com as its MX record - the name is fine.
0
 

Author Comment

by:Ivan_Windon
ID: 34132852
Do I need to bother setting up A records for each of my domains (such as mail.450p.com), or can I just leave them out and point all their MX records to mail.ghpstudios.com.
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 2000 total points
ID: 34132860
You can point the MX records to mail.ghpstudios.com happily and leave the A records alone unless you want to host a website.

You will need either an Autodicsover A record though with an associated IP address or you can create SRV records and use mail.ghpstudios.com in the SRV record instead.

It all depends on how much you want to spend on an SSL (UCC / SAN) certificate.
0
 

Author Closing Comment

by:Ivan_Windon
ID: 34155163
Ended up having to redo the entire install as there were other issues, and I went the route of Exchange 2007 this time. I set everything up with the A records and MX records and noticed I was still not able to send from a secondary domain to my ghpstudios.com, so since the server looked like it was good to go I switched the MX records on the external DNS and then it started to work as you mentioned.  Everything is great now, thanks for the help in sorting this out.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses
Course of the Month13 days, 13 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question