Solved

Cisco 1861 is stuck in rommon mode

Posted on 2010-11-14
27
1,374 Views
Last Modified: 2012-05-10
Hello All,

I have a Cisco 1861, I did try to Upgrde  IOS image. now  The router does not boot up, Does the (bad checksum) error mean the IOS image is corrupted or formated?  I have Backup of my old Image & new Image,

Can anyone help me on this issue ?

Thanks,

0
Comment
Question by:kavinagpur
  • 16
  • 9
  • 2
27 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34133859
if it is corrupted you need to copy back the old image!

If you have CD card reader please copy the old image with CF reader, if not you need:

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml
0
 

Author Comment

by:kavinagpur
ID: 34133875
Please suggest what is CD card reader & how it use ?
0
 

Author Comment

by:kavinagpur
ID: 34133877
I can't use Xmodem Console   on Cisco 1861 router
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:kavinagpur
ID: 34133886
I'm getting error
rommon 1 > xmodem -r

monitor: command "xmodem" not found
rommon 2 >
0
 
LVL 5

Expert Comment

by:Ahmed Ezzat AbuRaya
ID: 34133893
0
 

Author Comment

by:kavinagpur
ID: 34133900
Hi Zo3FoL,

Thanks for your reply,
 
I have plugged cat5 cable also console cable from 1861 to same computer, although I saw LAN cable is unplugged.......... I need it for upload new IOS through TFTP

What should i do for this situation
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34134008
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34134014
xmodem -c c1861-spservicesk9-mz.124-20.T4.bin
0
 

Author Comment

by:kavinagpur
ID: 34134041
Hi Ikalmar,

I am very upset due to this issue, router didn't take  Xmodem & pls look in help i can't see xmodem in attached list so may be xmodem is not supported on 1800 series..

rommon 9 > xmodem -c c1861-spservicesk9-mz.124-20.T4.bin
monitor: command "xmodem" not found
rommon 10 >
alias               set and display aliases command
boot                boot up an external process
confreg             configuration register utility
cont                continue executing a downloaded image
context             display the context of a loaded image
cookie              display contents of cookie PROM in hex
dev                 list the device table
dir                 List files in directories-dir <directory>
dis                 display instruction stream
frame               print out a selected stack frame
help                monitor builtin command help
history             monitor command history
meminfo             main memory information
more                Concatenate (type) file(s)-more <filenames ...>
repeat              repeat a monitor command
reset               system reset
rommon-pref         Select ROMMON
set                 display the monitor variables
showmon             display currently selected ROM monitor
stack               produce a stack trace
sync                write monitor environment to NVRAM
sysret              print out info from last system return
tftpdnld            tftp image download
unalias             unset an alias
unset               unset a monitor variable
rommon 11 >

Open in new window

0
 

Author Comment

by:kavinagpur
ID: 34134163
I had to do and what has happened, pls help, i'm in remote location & i don't have CF card reader
0
 

Author Comment

by:kavinagpur
ID: 34134367
Please help When we are following the steps to create a tftp connection with the remote computer, it appears to be there is no LAN connectivity at all.
Please help how to get my FastEthernet intefaces back running again in ROMMON mode so I can starrt recover my IOS files.

0
 
LVL 5

Expert Comment

by:Ahmed Ezzat AbuRaya
ID: 34137059
Kindly check this: http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bf9e.shtml

There is an example at the end of the page as well.

HTH
0
 

Author Comment

by:kavinagpur
ID: 34142410
Hello,

Please try to understand,  it appears to be there is no LAN connectivity at all. even after Connect CAT5 cable between TFTP server & Router  due to that i am unable to follow the steps to create a tftp connection..
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34142665
you need crossover
0
 

Author Comment

by:kavinagpur
ID: 34142778
Pls suggest step for CF card in rommon mode
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34142856
there is 3 ways:
1 cf card reader
2 tftpdnld
3 xmodem

0
 

Author Comment

by:kavinagpur
ID: 34142866
Hi ikalmar,

I hope you'll solve my issue
I am doing try with CF card because xmodem is not supported on 1861, &  i am unable to follow the steps to create a tftp connection because it appears to be there is no LAN connectivity at all. even after Connect CAT5 cable between TFTP server & Router. i don't have Crossover cable at the moment that's why i need to use CF, but i got error while using CF.
rommon 18 > boot system usbflash0
boot: unsupported boot device "system"
rommon 19 > boot system usbflash1
boot: unsupported boot device "system"
rommon 20 >
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34142882
0
 

Author Comment

by:kavinagpur
ID: 34142925
I alredy told you xmodem  is not supported on it

rommon 30 > xmodem -c c1861-spservicesk9-mz.124-20.T4.bin

monitor: command "xmodem" not found
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34142935
ok do you have CF card reader on your PC?
0
 

Author Comment

by:kavinagpur
ID: 34143010
yes
0
 

Author Comment

by:kavinagpur
ID: 34143014
please suggest for next
0
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 500 total points
ID: 34143045
put the CF card into CF reader copy delete the bad image, and copy the new good image!
Put back the CF card to the router

0
 

Author Comment

by:kavinagpur
ID: 34143067
You means CF card is Flash of router or Flash is different
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34143070
flash of the router...
0
 

Author Comment

by:kavinagpur
ID: 34143084
Thanks i think we have wasted lot's of time
0
 

Author Comment

by:kavinagpur
ID: 34152119
Hello,

Unable to yet I think you should understand very well for help me, I hope you will solve my issue.
pls check this
rommon 49 > dev
Devices in device table:
        id  name
    flash:  external compact flash

I entered above & got this, also when i tried to boot flash:c1861-spservicesk9-mz.124-20.T4.bin
Readonly ROMMON initialized
loadprog: error - on file open
boot: cannot load "flash:c1861-adventerprisek9-mz.124-24.T.bin"
because
rommon 1 > Dir flash:

monitor: command "Dir" not found
rommon 2 > dir flash
dir: missing device identifier.
dir: "dir" to get list of devices supporting filesystems.
rommon 3 >

I hope you understand
0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now