• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1521
  • Last Modified:

How to use CF card reader for LOAD new IOS in rommon mode

Hello Friends,

 
I was trying  to upgrade my IOS software, cisco router 1861, unforunately  the software crashed.
At  the  moment i am in ROMMON mode and cannot go back  to  the enable  mode. Now I  need to copy back the old image!  but i don't know How to use CF card reader for LOAD new IOS in rommon mode.. may be xmodem procedure is not supported on Cisco 1861 so please help me how to use it

Regards

VIkrant
 
 
 
 
If someone would help  me, as  i want  to have  the procedure for deleting my previous IOS.

Thanks,
0
kavinagpur
Asked:
kavinagpur
  • 11
  • 11
1 Solution
 
Ernie BeekExpertCommented:
0
 
kavinagpurAuthor Commented:
Thanks for your reply,

Can you suggest which card i need for it ?
i means like SD or something
0
 
Ernie BeekExpertCommented:
Eh ?

If there is a card in the router it should be a PCMCIA Flash card.

Did you try it by usin tftp?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Ernie BeekExpertCommented:
Some info on upgrading in rommon (should also work for 1861) http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bf9e.shtml
0
 
kavinagpurAuthor Commented:
Hello erniebeek,

I did try by TFTP but i'm unable because When we are following the steps to create a tftp connection with the remote computer, it appears to be there is no LAN connectivity at all.  I have plugged Cat5 cable  from router to remote system ( interface FastEthernet0/1/7), Please help how to get my FastEthernet intefaces back running again in ROMMON mode so I can starrt recover my IOS files.

Regards

Vikrant

0
 
Ernie BeekExpertCommented:
0
 
kavinagpurAuthor Commented:
Thanks for your quick reply,

For uploading through we need to enter xmodem -c but i couldn't  see this option on 1861 router
I'm getting error
rommon 1 > xmodem -c

monitor: command "xmodem" not found
rommon 2 > 

pls look in attached help command
alias               set and display aliases command
boot                boot up an external process
confreg             configuration register utility
cont                continue executing a downloaded image
context             display the context of a loaded image
cookie              display contents of cookie PROM in hex
dev                 list the device table
dir                 List files in directories-dir <directory>
dis                 display instruction stream
frame               print out a selected stack frame
help                monitor builtin command help
history             monitor command history
meminfo             main memory information
more                Concatenate (type) file(s)-more <filenames ...>
repeat              repeat a monitor command
reset               system reset
rommon-pref         Select ROMMON
set                 display the monitor variables
showmon             display currently selected ROM monitor
stack               produce a stack trace
sync                write monitor environment to NVRAM
sysret              print out info from last system return
tftpdnld            tftp image download
unalias             unset an alias
unset               unset a monitor variable
rommon 45 >

Open in new window

0
 
Ernie BeekExpertCommented:
Ok, then we have this : http://www.cisco.com/en/US/products/hw/routers/ps214/products_tech_note09186a0080110ed1.shtml

And I quote:

'If you are still in ROMmon, that means your boot image is either missing or corrupted. If your router has no valid image in Flash or Bootflash, and no other ROMmon upgrade procedure, the only way to recover is to have a similar router with a compatible Flash card, download the image on that router, and then move the Flash card to the one that is stuck.'

But first lets have a look at your interfaces, hopefully we can do something about that. You said:'I have plugged Cat5 cable  from router to remote system ( interface FastEthernet0/1/7)' So I assume you plugged it in to a switch on port FastEthernet0/1/7 ?
On the switch, can you see if the interface comes up/is up ?
0
 
kavinagpurAuthor Commented:
May be if i will use FE 0/0 then we'll get connectivity, because it's WAn interface...
from http://uc500.com/en/rommon-ios
0
 
Ernie BeekExpertCommented:
Looks like that should work.
0
 
kavinagpurAuthor Commented:
Pls let me know i will load through Mem card that time which command need to run on router in rommon mode for copying IOS
0
 
Ernie BeekExpertCommented:
So you have a network connection now? Ok!

Then you can follow the steps as described here: http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bf9e.shtml
0
 
kavinagpurAuthor Commented:
Hello All,

I have copy Image in Flash card & insert on router, but how to load Image in Flash from CF card in rommon mode, i'm unable to see CF card in Rommon mode..
0
 
Ernie BeekExpertCommented:
First, check what devices you have, command: dev
Aflash card should be in slot0 (or slot1).
Check wether the image is there, command: dir slot0: (or dir slot1: )
you should see something like: c1861-adventerprisek9-mz.124-10.bin
try to boot that image, command: boot slot0:c1861-adventerprisek9-mz.124-10.bin (or boot slot1:c1861-adventerprisek9-mz.124-10.bin).
Offcourse you use the image name you found by using the dir command and not the name I used here.
0
 
kavinagpurAuthor Commented:
Please let me know CF card is Flash of router or not ?
0
 
Ernie BeekExpertCommented:
I'm not sure what you mean by that.

You did the 'dev' command? What exactly dou you see?
0
 
kavinagpurAuthor Commented:
Now i'm in rommon mode i can't use  above command
0
 
Ernie BeekExpertCommented:
?
Is it giving you any error?
0
 
kavinagpurAuthor Commented:
I got below error i am very frusted from this issue

rommon 18 > boot system usbflash0
boot: unsupported boot device "system"
rommon 19 > boot system usbflash1
boot: unsupported boot device "system"
rommon 20 > 

also

rommon 42 > boot c1861-adventerprisek9-mz.124-24.T.bin
boot: unsupported boot device "c1861-adventerprisek9-mz.124-24.T.bin"
rommon 43 > boot flash:c1861-spservicesk9-mz.124-20.T4.bin
loadprog: error - on file open
boot: cannot load "flash:c1861-spservicesk9-mz.124-20.T4.bin"
rommon 44 >
0
 
Ernie BeekExpertCommented:
So you have the device usbflash0 and 1?

Did you try: boot usbflash0:c1861-spservicesk9-mz.124-20.T4.bin or boot usbflash1:c1861-spservicesk9-mz.124-20.T4.bin

0
 
kavinagpurAuthor Commented:
Hello,

Unable to yet I think you should understand very well for help me, I hope you will solve my issue.
pls check this
rommon 49 > dev
Devices in device table:
        id  name
    flash:  external compact flash

I entered above & got this, also when i tried to boot flash:c1861-spservicesk9-mz.124-20.T4.bin
Readonly ROMMON initialized
loadprog: error - on file open
boot: cannot load "flash:c1861-adventerprisek9-mz.124-24.T.bin"
because
rommon 1 > Dir flash:

monitor: command "Dir" not found
rommon 2 > dir flash
dir: missing device identifier.
dir: "dir" to get list of devices supporting filesystems.
rommon 3 >

I hope you understand
0
 
kavinagpurAuthor Commented:
Thanks for your help, Issue has been solved, issue was in IOS, it was corrupted

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 11
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now