We help IT Professionals succeed at work.

Installing Moodle on Freebsd, installer stops on php-curl

dreki
dreki asked
on
2,017 Views
Last Modified: 2013-11-22
I'm installing Moodle 1.9.9 on FreeBSD 7.2-RELEASE i386, so far I have got the basic system running with; apache-2.2.17_1, mysql-server-5.0.90_2 (+created a database for moodle) and php5-5.3.3_2, I can connect to the box from another machine and get the "it works" from apache. Also phpinfo works, I get all the php info in a web browser. So I went on and started the Moodle installer moodle-1.9.9 (make install clean) on the Freebsd machine. But the installer stops when trying to configure or install curl (php5-curl-5.3.3_2), see text file. The error message says: "curl-7.21.1 may only use GNU TLS if OpenSSL support is disabled. *** Error code 1". I'm litte lost what to do next, how can I disable OpenSSL.
curl-error.txt
installed-ports.txt
Comment
Watch Question

Most Valuable Expert 2011
Author of the Year 2014

Commented:
Just a guess, but check the advice on this page:
http://us2.php.net/manual/en/curl.installation.php
Top Expert 2015

Commented:
Do you need gnutls at all?
OpenSSL is in base system to provide same functionality.

Author

Commented:
gheist: the Moodle installer wants to use gnutls when it tried to install curl, doing make-install-clean in moodle diectory. I don't need gnutls.  OpenSSL is installed, found it in usr/bin/openssl, it starts and works fine (says OpenSSL 0.9.8e 23 Feb 2007).  I want to try it disable gnutls to find out if that works. How can I do that? When I do make-config in in /usr/ports/www/moodle/ -  I don't get any gnutls option (see screenshot-1.jpg), also when I do make-config in /usr/ports/lang/php5 - I don't see any gnutls option (see screenshot-2.jpg).  
screenshot-1.jpg
screenshot-2.jpg
Top Expert 2015
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
gnutls deleted, but when I started moodle installer again, its stops on curl with the same error, see below:

moodle2# make install clean
===>  Installing for moodle-1.9.9
===>   moodle-1.9.9 depends on file: /usr/local/include/php/main/php.h - found
===>   moodle-1.9.9 depends on file: /usr/local/www/cgi-bin/mimetex.cgi - found
===>   moodle-1.9.9 depends on file: /usr/local/lib/php/20090626/session.so - found
===>   moodle-1.9.9 depends on file: /usr/local/lib/php/20090626/gd.so - found
===>   moodle-1.9.9 depends on file: /usr/local/lib/php/20090626/mbstring.so - found
===>   moodle-1.9.9 depends on file: /usr/local/lib/php/20090626/iconv.so - found
===>   moodle-1.9.9 depends on file: /usr/local/lib/php/20090626/tokenizer.so - found
===>   moodle-1.9.9 depends on file: /usr/local/lib/php/20090626/curl.so - not found
===>    Verifying install for /usr/local/lib/php/20090626/curl.so in /usr/ports/ftp/php5-curl
===>   php5-curl-5.3.3_2 depends on file: /usr/local/bin/phpize - found
===>   php5-curl-5.3.3_2 depends on file: /usr/local/bin/autoconf-2.68 - found
===>   php5-curl-5.3.3_2 depends on shared library: curl.6 - not found
===>    Verifying install for curl.6 in /usr/ports/ftp/curl
===>  curl-7.21.1 may only use GNU TLS if OpenSSL support is disabled.
*** Error code 1

Stop in /usr/ports/ftp/curl.
*** Error code 1

Stop in /usr/ports/ftp/php5-curl.
*** Error code 1

Stop in /usr/ports/www/moodle.
*** Error code 1

Stop in /usr/ports/www/moodle.
Top Expert 2015
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
gheist: hope I'm following you correctly, went to /usr/ports/ftp/curl

moodle2# make clean
===>  Cleaning for php5-curl-5.3.3_2
moodle2# make config
===> No options to configure
moodle2# make install
===>  License check disabled, port has not defined LICENSE
===>  Extracting for php5-curl-5.3.3_2
=> SHA256 Checksum OK for php-5.3.3.tar.bz2.
===>  Patching for php5-curl-5.3.3_2
===>   php5-curl-5.3.3_2 depends on file: /usr/local/bin/phpize - found
===>   php5-curl-5.3.3_2 depends on file: /usr/local/bin/autoconf-2.68 - found
===>   php5-curl-5.3.3_2 depends on shared library: curl.6 - not found
===>    Verifying install for curl.6 in /usr/ports/ftp/curl
===>  curl-7.21.1 may only use GNU TLS if OpenSSL support is disabled.
*** Error code 1

Stop in /usr/ports/ftp/curl.
*** Error code 1

Stop in /usr/ports/ftp/php5-curl.
moodle2#

its seem that "curl.6 library" is missing, can that be the problem?
Top Expert 2015

Commented:
you need to remove gnutls before build apparently and fill a bug report for port.
Top Expert 2015
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I didn't solve this problem, so I think I will start over and reinstall everything, thanks for giving tips gheist.
Top Expert 2015

Commented:
install packages via sysinstall, that saves a lot of time.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.