[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 609
  • Last Modified:

Initial delay browsing files

When doing a browse of drives in windows explorer to the Win2008R2 server, if the workstation has been inactive for say 1/2 hr, it takes about 30 seconds to initially display, then it is quick to display the share information.

Is there some way to easily set this globally so there is no delay.  I know I had to do a directory access every 10 minutes in a program to avoid the problem but need a global way to handle this.
0
cwsoft05
Asked:
cwsoft05
  • 10
  • 6
1 Solution
 
Darius GhassemCommented:
What AV are you running?

Make sure clients and server is only pointing to internal DNS servers.

Check these settings as well.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_26176031.html

Go to your properties of your NIC then go to the Advanced Tab make sure you disable Large Send offload then reboot server
0
 
cwsoft05Author Commented:
AV - Symantec Endpoint

Only point to single DNS 192.168.1.10

No Large Send offload setting.

I have read that Microsoft 2003 and I expect 2008 after 15 minutes of inactivity, suspends the connection to release and conserve resources.  Then it takes 30-45 seconds to reconnect and then everything is normal.  

It only has the tcp checksum offload setting.

There was a different setting I think.
0
 
Darius GhassemCommented:
Symantec Endpoint the problem. SEP has been causing this type of issues with Server editions. What I recommend for testing is to download the cleanwipe tool then running on the problem server and client. SEP is most likely your issue
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
cwsoft05Author Commented:
Where do I get the cleanwipe tools.  SEP is not running on the server.  It is provided via a different server not connected to the domain.  It is on the workstations though.

I don't have SEP on my laptop.  Can I just map a drive to the server (I am not a member of the domain) and test whether it works or not prior to loading cleanwipe.  I have a new computer that I am rebuilding and I can also test prior to added SEP.

And if this is the problem, what is the solution.  also, could it be related to the autodisconnect 15 minute timing or what.

In addition, if you lock the computer and wait about 15 minutes, it freezes the computer in the applying computer settings portion of the process.
0
 
Darius GhassemCommented:
test the new computer without SEP
0
 
cwsoft05Author Commented:
It appears to definitely not be a autodisconnect issues.  I went to one computer and via the command prompt went to the drive and the directory lists immediately.  In Windows Explorer it was still slow the first time and appears to be somewhat similar in Word 2003 file browse.
0
 
Darius GhassemCommented:
Did you test withou SEP?
0
 
cwsoft05Author Commented:
I am in the process of rebuilding the machine.  Then I will test.  Prior to testing without SEP,  It appears that at the command prompt the files display fast but can still take time to load word if you type in the document name.

Hopefully I will have an answer shortly on the machine without SEP.
0
 
cwsoft05Author Commented:
Okay on the server with not SEP.  It still occurs the same.  If I have 5-10 minutes of inactivity, browsing in window explorer is slow to display the files.  Even if they display files quickly, if I click on a word doc, it takes initially 45 seconds to open.  If I then select a different document, it opens quickly.  The same happens if I do it at the command prompt.  I was running teamviewer on the server and shut down that service to avoid any issues.  It appears that something is causing initial access/file open slowdowns after a period of inactivity.

It appears to not affect a Windows 7 machine on the network, only the winXp machines.  What is causing this?????????
0
 
Darius GhassemCommented:
Could be IPv6 causing the issue.

0
 
cwsoft05Author Commented:
I have IPv6 disabled on the network card on the server.  What do I look for to make certain it is not an issue.  We are not supporting it at this time.  The 2nd network card is disabled.  Only want IPv4 and appears to only affect WinXP machines.
0
 
cwsoft05Author Commented:
It is specific to the WinXp machines.  The Win7 machines do not appear to exhibit this problem.
0
 
cwsoft05Author Commented:
It would appear that if I remove the novell client from this test computer, leaving just the windows login, then the problem does not occur.  When I reinstall the latest Novell 4.91sp5IR1 client for windowsxp, then the delay after inactivity reappears.
0
 
Darius GhassemCommented:
Must be Novell
0
 
cwsoft05Author Commented:
It appears to be an issue with the binding order of the providers.  Novell is the first in the line.  If you switch the order to put Novell last and Microsoft first, then several individuals say it fixes the problem.  I am testing this now.  

It apepars that the unc request goes to Novell and it waits to timeout before sending it to the Microsoft provider.  Need to also do for the print provider.

I will see what testing provides.

Cliff.
0
 
cwsoft05Author Commented:
The solution was related to the ordering of the providers.  WinXP provides the Novell client as the first in the chain of providers.  Win7, Novell is last.  None of the expert comments provided this as a solution.  I found it out via other forums.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 10
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now