Link to home
Start Free TrialLog in
Avatar of ob1_
ob1_

asked on

Mail stuck in SMTP queue (C:\inetpub\mailroot\Queue) on Windows Server 2008

I have a Windows Server 2008 box with IIS7. I have added the SMTP role/feature in Server Manager.  I have an asp web page that sends mail from the server to 1 or 2 support addresses over the internet.

This worked fine on our 2003 box. We have upgraded to 2008 and now mail is stuck in the queue folder.

If I go into IIS 6.0 Manger I see that the SMTP Virtual Server is started. Any ideas?


thanks,
Bobby
ASKER CERTIFIED SOLUTION
Avatar of Rich Weissler
Rich Weissler

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ob1_
ob1_

ASKER

Ok I have turned on logging.

I am not sure if the support addresses are configured to receive mail from the Windows 2008 Server - I don't have any admin access to that system.

Does a smart host get configured with MX records on the internet like a regular mail server? Maybe the old server had a smart host on it I am not sure...


thanks,
bobby
> I am not sure if the support addresses are configured to receive mail from the Windows 2008 Server - I don't have any admin access to that system.
*nod*  Logging should show you pretty quick.

Smarthost is a setting within SMTP -- it defines where to send mail.  (It also simplifies troubleshooting outbound mail issues.)  If it was set on the old server, it'll probably be a good idea to set it to the same on the new server.  Screen shot on where the setting lives attached. User generated image
you'll have to look at the logs to view the reason for the problem....
Avatar of ob1_

ASKER

I turned on logging yesterday and sent an email from the website but strangely enough there is no SMTP folder or log file in C:\Windows\System32\LogFiles... any ideas on that?



thanks,
Bobby
Yeah... that's the default location (in c:\windows\system32\LogFiles\SMTPSVC1\<blah>.log)
But... I've had enough wacky/crazy/stupid stuff happen with UAC in Windows 2008 that I'm going to suggest this -- go ahead and tell it to log to a different location.  Create a new directory, and make certain the system has permission to write to the directory.

And/Or .. .make certain to stop and restart the SMTP service after making changes.
Avatar of ob1_

ASKER

Strange - still nothing. Do I need to check anything on the advanced tab in SMTP logging?
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ob1_

ASKER

ok.. i have a 64 bit OS so this makes sense.

i have added the role service, moved the logging folder to the D: partition, granted full permissions to the System account and Administrators group, restarted SMTP service and IIS, stop/started the virtual server, and telnetted from a command prompt to localhost and google.com.

both return "could not open connection to the host on port 23: connection failed" - should this be enough to create a log entry? i set the log schedule to hourly. still the log folder is empty.


thanks for your help!
Are you trying to get mail into this server, or out of?  
If you want to test receiving mail -- telnet to tcp/25 on this server... but I suspect that isn't want you want.

Try sending another SMTP message out... that should generate some log traffic.
Avatar of ob1_

ASKER

i am trying to send mail from the server not receive it. i sent a new message and still no log :(
Okay, dropping back -- what queue folder is the mail stuck in?  (This is starting to sound like the computer twilight zone...)
Avatar of ob1_

ASKER

no doubt - turns out the ISP was blocking traffic I believe on port 25. we contacted them and everything is working great now. thanks for all your help!