Exchange 2007 server sp3 failed brok owa now there are no roles

Problem:
Exchange will not start. Can not add CA roles or start store
Server:
2003 64 bit
2007 exchange server no service packs installed.
Background:
I went to upgrade exchange 2007 server to sp3. There was a waning on the hubs ( I for got what it was) I went ahead an ran the upgrade. After it failed the exchange server did work, exept for the OWA . I ran exsetup.exe /mode:remove /roles:ca then exsetup.exe /mode:install /roles:ca.  With the hopes it would fix OWA from what I read. The install failed and I now get an error  This role cannot be installed because the following roles are not current:BridgeheadRole MailboxRole.  After looking at the setup log file. I have found that the exchange server is still trying to  update to SP3. I was updating exchange server to SP3 with no current updates insatlled on sever.No Exchange services will start.
Help:
What  do  I need to do to fix this.  How do I tell exchange server not to try and update. I want to go back to the original version.  Is there a way to tell the setup to use original updates.

ERRORS:
C:\Documents and Settings\administrator.FSC>exsetup.exe /mode:install /roles:ca
Welcome to Microsoft Exchange Server 2007 Unattended Setup
The following server roles will be installed
    Client Access Role
Performing Microsoft Exchange Server Prerequisite Check
Configuring Microsoft Exchange Server
     This role cannot be installed because the following roles are not current:
BridgeheadRole MailboxRole
The Exchange Server Setup operation did not complete. For more information, visi
t http://support.microsoft.com and enter the Error ID.
From log:
11/15/2010 11:28:02 AM] [0] Setup will run the task 'Install-ClientAccessRole'
[11/15/2010 11:28:02 AM] [1] Setup launched task 'Install-ClientAccessRole -DomainController 'fsc-srv-exch-01.fsc.org' -updatesdir 'D:\sp3 exch\Updates''  
[11/15/2010 11:28:02 AM] [1] Beginning processing.
[11/15/2010 11:28:02 AM] [1] Attempting Install for ClientAccessRole.
[11/15/2010 11:28:02 AM] [1] The following roles are installed: BridgeheadRole MailboxRole
[11/15/2010 11:28:02 AM] [1] This role cannot be installed because the following roles are not current: BridgeheadRole MailboxRole
[11/15/2010 11:28:02 AM] [1] This role will not be configured because of the following exception: This role cannot be installed because the following roles are not current: BridgeheadRole MailboxRole
[11/15/2010 11:28:02 AM] [0] The Exchange Server Setup operation did not complete. For more information, visit http://support.microsoft.com and enter the Error ID.
[11/15/2010 11:28:02 AM] [0] End of Setup
[11/15/2010 11:28:02 AM] [0] **********************************************
desert-slothAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
desert-slothConnect With a Mentor Author Commented:
Problem Solved. The answer is to remove exchange server from the server and reinstall it. The exchange server was stuck in limbo thinking it was exchange server with no SP and part SP3 installed. You may want to have MS help you out. I had MS support to help me. Their was a lot of regedits and ADSiedits. Once the server was reinstalled with SP3 all was good. I was able to mount my old databases and connected the users back to exchange server.
0
 
desert-slothAuthor Commented:
pic of an store error
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.