Avatar of MARKWILKY
MARKWILKYFlag for United Kingdom of Great Britain and Northern Ireland asked on

OWA not working internally on SBS 2008.

Hi all

Please can somebody help with a issue a client has. The Customer rang to say there IT support company would have to rebuild the entire server. They wanted a second opinion

Issue

OWA not working ..... They also said the company has reinstalled IIS which I know is not advisable on SBS 2008

Please can somebody help me check all the config in IIS to confirm it is correct.

I have looked at many articles and none have worked.

when we got involved, OWA would not work at all, it said cant display web page. After checking some setting in IIS, I noticed the binding setting where not set right in the SBs web application. Since I have changed this I now get an

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Can anybody help me resolve these issue.


SBSMicrosoft IIS Web ServerExchange

Avatar of undefined
Last Comment
MARKWILKY

8/22/2022 - Mon
Jdtuck

Have you seen this article?  http://forums.iis.net/p/1023069/1390229.aspx
ASKER
MARKWILKY

I have looked at this but when i try and run it it says )

C:\Users\Admin>%windir%\system32\inetsrv\appcmd.exe unlock config -section:s
ystem.webServer/security/requestFiltering
Unlocked section "system.webServer/security/requestFiltering" at configuration p
ath "MACHINE/WEBROOT/APPHOST".
ERROR ( hresult:80070005, message:Failed to commit configuration changes.
Access is denied.
 
e_aravind

Can you please try renaming the web.config to web.config.old
Starting using the .bak file by renaming th web.config.bak to web.config
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
pcsmitpra

Could you please try to see if browsing it directly works https://server name/exchange ?
ASKER CERTIFIED SOLUTION
pcsmitpra

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
MARKWILKY

Hi ,

When i try the https://servername/exchange i get the same page


Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid. Detailed Error InformationModule IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070021
Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".  
Config File \\?\C:\Program Files\Windows Small Business Server\Bin\WebApp\SBS Web Applications\web.config
Requested URL https://servername:443/exchange 
Physical Path \\.\BackOfficeStorage\domainname.local\MBX
Logon Method Not yet determined
Logon User Not yet determined
 Config Source
   17:   <system.webServer>
   18:     <modules>
   19:       <add name="HttptoHttpsRedir" type="Microsoft.WindowsServerSolutions.IWorker.IIS.Modules.HttpToHttpsRedir,HttpToHttpsRedir,Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
 
ASKER
MARKWILKY

I have granted the  IIS_IUSRS group read perrmission for the ApplicationHost.config file and restarted IIS but still getting same error..

Any other ideas please
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
MARKWILKY

Thansk for your help

I have fixed the issue now.

TO resolve I did a number of things

First I tweaked permmsions for the  IIS_IUSRS
The I edited the  ApplicationHost.config file , as it was denying access.
then I had to install some modules in IIS as the previuos guy had unistalled IIS.

Then all was working