• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 882
  • Last Modified:

Disconnected mailbox

I disable a mailbox account in exchange 2010 but I don't ever see the mailbox go into the disconnected mailbox view.  Why?  

Versions Exchange 2010
AD runs on windows 2003 - is this the issue?
0
dianetuschl
Asked:
dianetuschl
  • 3
2 Solutions
 
lecretiaCommented:
Run Clean-MailboxDatabase against the database.
0
 
dianetuschlAuthor Commented:
Is this on a timed schedule to run?
0
 
lecretiaCommented:
When you delete a mailbox it does not go into the delete mailboxes immediately, to speed it up you need to run that command.

This is the structure of the command:
clean-MailboxDatabase -Identity <DatabaseIdParameter> [-Confirm [<SwitchParameter>]] [-DomainController <Fqdn>] [-WhatIf [<SwitchParameter>]]

normally you would just run it on the database without other parms.
ie. clean-MailboxDatabase groupdatabase

Replace groupdatabase with your database name.
0
 
lecretiaCommented:
The server will clean up on a schedule, you can override it by using that command.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now