Avatar of mariobrown
mariobrown asked on

Citrix IMA Not working

I have 4 citrix servers (CTX01 - 04) in my farm with 2 AAC and 2 Access Gateways. Recently my server 2 (CTX02) is not longer responding to client request. Users can login via the gateway but when they click on application, it says "The resource you requested is no longer available from the servers or the specified user no longer has access to it" CTX04 holds my DS and a qfarm from CTX02 replies with IMA services not available. Other server can see the DS but CTX02 cannot.

I have done the little troubleshooting i know but no possible solution. I thought of removing CTX02 from my farm and re-adding it again but don't what effect this might have on my farm.

I recreated the LHC successfully but IMA services not still starting. I will appreciate any assistance i can get please.

Thanks,

Mario.
Citrix

Avatar of undefined
Last Comment
Carl Webster

8/22/2022 - Mon
Carl Webster

On CTX02 do a CHFARM to a local access database and then CHFARM back to the original.
ASKER
mariobrown

Dear CarlWester,

My database (Citrix_rm) is on a SQL server. What effect will this have? .
Carl Webster

Nothing.  DOing a CHFARM on CTX02 will just create a new farm and then you will turn right around and CHFARM back to the original farm/data store/database.  The whole process "should" take less than 10 minutes.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER
mariobrown

Sorry, am really new to Citrix. In essence, i should create a new farm with local access database and then chfarm back to add CTX02 to my sql database base?
Carl Webster

Running CHFARM on CTX02 will create a new farm with an access database/data store.
ASKER
mariobrown

Ok, i will implement this in the office later this morning and get back to you. Thanks
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
mariobrown

The following erros occur while running CHFARM command.

Stopping the IMA service has returned an error. Farm membership may not be changed successfully. Do you want to continue?

Windows could not start citrix IMA on local computer -  2147483588

Failed to load plugin C:/programme files\citrix\syst 32\citrix\IMA\subsystems\imaAppSs.dll with error

Error on CTX03.
The RPC server cannot be contacted on the server CTX03

Carl Webster

This is on CTX02?
ASKER
mariobrown

yes
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Carl Webster

I would uninstall all Citrix components from CTX02 and then reinstall XenApp and join to the existing farm.
ASKER
mariobrown

I used forced removal on Access Management Console to remove CTX02. I will reinstall componets again and try to add it to the farm. Will keep you posted.

Many thanks
ASKER
mariobrown

the remaining citrix components have refused to uninstall. All hotfix and patches are not ready to go, how do i handle this. I need help here please
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Carl Webster

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
mariobrown

Thanks Carl. Will be in touch.
ASKER
mariobrown

I re-installed PS 4.5 on ctx02 and added it to my farm but still get the same error "The resource you requested is no longer available from the servers or the specified user no longer has access to it"

Any more help please?
ASKER
mariobrown

The second issue now is the my new server is also a DS. Is this right?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Carl Webster

CTX02 does not have a data store unless you did not join it to the existing farm when you reinstalled XenApp.

When are you getting the "resource you requested..." error?
ASKER
mariobrown

I have fixed the 2nd issue now. Removed and re-added the 2nd server to the farm. i still have this error "The resource you requested is no longer available from the servers or the specified user no longer has access to it" trying to acces applications.


ASKER
mariobrown

when trying to open applications on the web interface
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
mariobrown

Error is "All of the configure STAs failed to respond to this XML transaction"

Any ideas please
torque_200bc

For the error:
"The resource you requested is no longer available from the servers or the specified user no longer has access to it"

If you removed the server from the farm you will probably have to add that server to the published apps again.

The STA`s are a configuration of the WI. Do you still have problems with it?
Carl Webster

For your Web Interface site, what server or servers do you have listed in Farm Maintenance?
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes