CISCO 1841 Firewall?

I have a cisco 1841 Router that i have been trying to figure out.  is there a module that i need to upload into the device for the Firewall to be active?  i

my current IOS is

12.4 (25c)
ROM is 12.4(13r)T

I need to create VPN's and i can not; i dont know whether if it is the config or if i am missing something

Help :)
johnkesoglouAsked:
Who is Participating?
 
Faruk Onder YerliConnect With a Mentor OwnerCommented:
at least below have to be for crypo.
C1841-ipbasek9-mz

0
 
Faruk Onder YerliOwnerCommented:
please send output of "show version" command.
0
 
johnkesoglouAuthor Commented:
Code is below

thanks!
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(25c), RELEASE S
OFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Thu 11-Feb-10 22:45 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

yourname uptime is 50 minutes
System returned to ROM by power-on
System image file is "flash:c1841-ipbase-mz.124-25c.bin"

Cisco 1841 (revision 7.0) with 232448K/29696K bytes of memory.
Processor board ID FHK142774Q1
2 FastEthernet interfaces
2 Serial(sync/async) interfaces
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Open in new window

0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
Faruk Onder YerliOwnerCommented:
your IOS version is not supporting crypto function.

You will see below default IOS and others.

http://www.cisco.com/en/US/prod/collateral/routers/ps5853/product_data_sheet0900aecd8016a59b.html
0
 
johnkesoglouAuthor Commented:
Which IOS would i need to upgrade to?  
0
 
johnkesoglouAuthor Commented:
THANKS!!! :D
0
 
avilovCommented:
i think you need an advanced images something like c1841-advipservicesk9-mz.xxxxxx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.