Avatar of jakek
jakek asked on

Setup Cisco with dual WAN and 2 internal subnets each using a separate WAN interface

I am trying to configure a Cisco 2611XM router with an Ethernet card in it's NM slot so it has 3 FastEthernet interfaces.

FastEthernet0/0 is connected to Static IP address WAN connection
FastEthernet0/1 is connected to the internal LAN with 2 subnets (10.0.0.0, 255.255.255.0 and 10.1.1.0, 255.255.255.0)
FastEthernet1/0 is connected to DHCP IP address WAN connection

I don't want or need a failover connection. What I want is to send all traffic from subnet 10.0.0.0 over FastEthernet0/0 and subnet 10.1.1.0 over FastEthernet1/0

As best as I can tell I need to setup something call policy based routing but I haven't been able to get it to work properly. I can get all traffic to flow through 1 WAN or the other by making various adjustments but I can't seem to get each subnet to flow through it's own WAN. As it's configured at the moment all 10.0.0.0 clients can access the Internet and do so over FastEthernet0/0. Clients with 10.1.1.0 addresses can not access the Internet. Here are the relevant parts of my config:


!
version 12.4
!
ip cef
!
interface FastEthernet0/0
 description External Static Connection
 ip address 208.97.xxx.xxx 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip accounting output-packets
 ip nat outside
 no ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet0/1
 description Internal LAN
 ip address 10.1.1.1 255.255.255.0 secondary
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 no ip virtual-reassembly
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet1/0
 description External DHCP
 ip address dhcp
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip accounting output-packets
 ip nat outside
 no ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 208.97.xxx.xxx
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0 dhcp 20
!
ip nat inside source route-map static interface FastEthernet0/0 overload
ip nat inside source route-map dhcp interface FastEthernet1/0 overload
!
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 2 permit 10.1.1.0 0.0.0.255
!
route-map static permit 10
 match ip address 1
 match interface FastEthernet0/0
 set default interface FastEthernet0/0
!
route-map dhcp permit 20
 match ip address 2
 match interface FastEthernet1/0
 set default interface FastEthernet1/0
!
RoutersNetworking

Avatar of undefined
Last Comment
jakek

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Les Moore

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
jakek

Thanks lrmoore! That worked, just 1 minor addition. I had to remove the following items from my config as the routes were now defined in the policies.

ip route 0.0.0.0 0.0.0.0 208.97.xxx.xxx
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0 dhcp 20

ASKER
jakek

Had to take 1 additional step to the instructions given but pointed me in the right direction. Very helpful!
Your help has saved me hundreds of hours of internet surfing.
fblack61