Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2629
  • Last Modified:

FTP Server stopped working "The connection with the server was reset"

Hello everyone,

I'm running a windows 2008 server with Filezilla as an FTP server. I configured the FTP server and for about a year it has worked without issue. About a week ago the the FTP server stopped working, no users are able to connect to it. The error Message that is recieved is:

"An error occurred opening that folder on the FTP Server, Make sure you have permissions to access that folder.  Details: The connection with the server was reset"

As I mentioned before the server was running correctly with no issue until recently. The only change made recently was Disabling SMB on the server to help improve network file access speed. I don't believe that had anything to do with it but to troubleshoot I re-enabled it on the server.

The troubleshooting steps I have taken are as follows:

1) Attempted to connect to the server after disabling the "Use passive FTP" option in the internet explorer options
2) Attempt to connect after Disabling firewall on server
3) Verified all FTP rules in router
4) Verified folder permissions to FTP share and home folder for ftp users
5) tested connectivity of port 21 via http://www.canyouseeme.org, port 21 is open
6) tested connection to ftp server via http://www.ftptest.net, the test completes successfully
7) created a new test user in file zilla and attempted to connect
8) created a new FTP Share on the server and a new user folder and attempted to connect.
9) typically I connect to the ftp server using windows explorer, i installed and tested it using FireFTP with no success.

I'm Completely at a loss on this, have no idea why it would work fine then materially stop working.

Another piece of information which may or may not be related is this issue started around the time daylight savings time changed.

Any help is much appreciated.

Thanks
0
Suigenris85
Asked:
Suigenris85
2 Solutions
 
ken2421Commented:
Install the latest filzilla server and test again. Something had to change.

Ken
0
 
workgaCommented:
you should try the basic steps, dos commands.  Can you ping the server? what about ftp from a command line?  Do you have an anti-virus software that blocks certain ports?  Did you check the logs on the anti-virus software?  Did you check the logs on the server to see if anything suspicios is cuasing this issue?
0
 
giltjrCommented:
What exactly do you mean by:

8) created a new FTP Share on the server and a new user folder and attempted to connect.

Just as a F.Y.I, I interpret the term "share" as a file share and SMB is what allows shares.  So SMB is disabled then you can't have any shares.
0
 
Suigenris85Author Commented:
Thanks for the quick response everyone.

Ken2421: I installed the latest filezilla server, i was using 0.9.33 now i'm using 0.9.37 still not working

Workqa:  I did do basic troubleshooting. Everything connects correctly internally and externally except FTP. VPN connects fine, the users are able to access all the shares on the server fine. One thing I found out yesterday that was very interesting is if I connect to the ftp server internally using the internal ip everything functions correctly. So the FTP server functionality is working it must be something regarding the external ip address.

Qiltjr: correct I was referring to a SMB share, i disabled smb on the server using a registry entry because we were experiencing extreemly slow download speeds when retrieving office 2010 docs off the server. the microsoft workaround was to disable smb on the client and server side. I ended up reenabling it because it caused problems as you mentioned.

On step 8) that I was referring to, currently the local FTP files are stored on an SMB share called FTP, I created a new SMB Share called FTP2 and set that as the home directory and was still unable to connect.

Kind regards,

Thomas
0
 
Suigenris85Author Commented:
DING!!

Thanks so much for your help! It just occurred to me that an admin recently made a change to the firewall. We use a hosted VOIP providor and were experiencing call quality issues with our phones.

The company reccomended setting our DLink DIR-655 Router firewall to "Endpoing independant" for NAT Endpoing Filtering. I changed this setting back to "Address Restricted" For both UDP and TCP and everything works.

thanks
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now