Solved

FTP Server stopped working "The connection with the server was reset"

Posted on 2010-11-15
5
2,441 Views
Last Modified: 2012-05-10
Hello everyone,

I'm running a windows 2008 server with Filezilla as an FTP server. I configured the FTP server and for about a year it has worked without issue. About a week ago the the FTP server stopped working, no users are able to connect to it. The error Message that is recieved is:

"An error occurred opening that folder on the FTP Server, Make sure you have permissions to access that folder.  Details: The connection with the server was reset"

As I mentioned before the server was running correctly with no issue until recently. The only change made recently was Disabling SMB on the server to help improve network file access speed. I don't believe that had anything to do with it but to troubleshoot I re-enabled it on the server.

The troubleshooting steps I have taken are as follows:

1) Attempted to connect to the server after disabling the "Use passive FTP" option in the internet explorer options
2) Attempt to connect after Disabling firewall on server
3) Verified all FTP rules in router
4) Verified folder permissions to FTP share and home folder for ftp users
5) tested connectivity of port 21 via http://www.canyouseeme.org, port 21 is open
6) tested connection to ftp server via http://www.ftptest.net, the test completes successfully
7) created a new test user in file zilla and attempted to connect
8) created a new FTP Share on the server and a new user folder and attempted to connect.
9) typically I connect to the ftp server using windows explorer, i installed and tested it using FireFTP with no success.

I'm Completely at a loss on this, have no idea why it would work fine then materially stop working.

Another piece of information which may or may not be related is this issue started around the time daylight savings time changed.

Any help is much appreciated.

Thanks
0
Comment
Question by:Suigenris85
5 Comments
 
LVL 9

Accepted Solution

by:
ken2421 earned 250 total points
ID: 34142092
Install the latest filzilla server and test again. Something had to change.

Ken
0
 
LVL 5

Assisted Solution

by:workga
workga earned 250 total points
ID: 34142099
you should try the basic steps, dos commands.  Can you ping the server? what about ftp from a command line?  Do you have an anti-virus software that blocks certain ports?  Did you check the logs on the anti-virus software?  Did you check the logs on the server to see if anything suspicios is cuasing this issue?
0
 
LVL 57

Expert Comment

by:giltjr
ID: 34142117
What exactly do you mean by:

8) created a new FTP Share on the server and a new user folder and attempted to connect.

Just as a F.Y.I, I interpret the term "share" as a file share and SMB is what allows shares.  So SMB is disabled then you can't have any shares.
0
 

Author Comment

by:Suigenris85
ID: 34149760
Thanks for the quick response everyone.

Ken2421: I installed the latest filezilla server, i was using 0.9.33 now i'm using 0.9.37 still not working

Workqa:  I did do basic troubleshooting. Everything connects correctly internally and externally except FTP. VPN connects fine, the users are able to access all the shares on the server fine. One thing I found out yesterday that was very interesting is if I connect to the ftp server internally using the internal ip everything functions correctly. So the FTP server functionality is working it must be something regarding the external ip address.

Qiltjr: correct I was referring to a SMB share, i disabled smb on the server using a registry entry because we were experiencing extreemly slow download speeds when retrieving office 2010 docs off the server. the microsoft workaround was to disable smb on the client and server side. I ended up reenabling it because it caused problems as you mentioned.

On step 8) that I was referring to, currently the local FTP files are stored on an SMB share called FTP, I created a new SMB Share called FTP2 and set that as the home directory and was still unable to connect.

Kind regards,

Thomas
0
 

Author Comment

by:Suigenris85
ID: 34149821
DING!!

Thanks so much for your help! It just occurred to me that an admin recently made a change to the firewall. We use a hosted VOIP providor and were experiencing call quality issues with our phones.

The company reccomended setting our DLink DIR-655 Router firewall to "Endpoing independant" for NAT Endpoing Filtering. I changed this setting back to "Address Restricted" For both UDP and TCP and everything works.

thanks
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now