Exchange 2007 message size limits

I can't seem to increase the message size limits in Exchange 2007 on SBS 2008.

I've used the following two lines in the Exchange Management Shell to increase the message size limit to 40MB's and restarted the server but to no avail:


Set-TransportConfig -MaxReceiveSize 40MB -MaxSendSize 40MB

Set-ReceiveConnector “CONNECTOR NAME” -MaxMessageSize 40Mb

When I attempt to send a large message from outside the server it gets rejected.

What am I missing?
Thanks.
b1dupreeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

getzjdCommented:
what does your get-transportconfig command show?
0
getzjdCommented:
As well as your get-receiveconnector
0
getzjdCommented:
What are your user level and server level limits set at?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Olaf De CeusterCommented:
Have to set new limits in 3 spots:
Exchange Managemnt console:
1: Organzation Config>Hub Transport> Send Connectors>Windows SBS Internet Send sbs 2008: Set Maximum Message sixe
2: Server config> Mailbox>Mailbox database .Limits (Set limits)
3: server config>Hub Transport> Default SBS2008> Set Maximum Message size.
Restart the information Store under services.
Hope that helps,
Olaf
0
Radhakrishnan RSenior Technical LeadCommented:
It will take upto 2 hours to update these new settings with clients.
0
Rob WilliamsCommented:
If you require additional information there is an excellent article on Technet outlining the procedure, specific to SBS2008:
http://blogs.technet.com/b/sbs/archive/2008/10/28/how-do-i-change-message-size-limits-in-exchange-2007.aspx
0
b1dupreeAuthor Commented:
get-transportconfig command

shows

MaxReceiveSize 40MB
MaxSendSize 40MB

It shows correctly but when I send a 12MB message to the Administrator address it gets rejected.  

0
Radhakrishnan RSenior Technical LeadCommented:
Try to send the attachment via OWA
0
abt-itCommented:
You also have to update the message size limitations of the Fax Connector. Don't ask my why, but after upgrading this, it works on my clients SBS Server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
abt-itCommented:
Have a look at the exchange console -> Server Configuration -> Hub-Transport, there you should find the Windows SBS-Fax Sharepoint Receive Connector.
0
b1dupreeAuthor Commented:
abit-it:
Thanks  Okay tried that.  What about the Windows SBS Internet Receive SERVERNAME connector?
Do I need to change the maximum message size in that as well?
0
b1dupreeAuthor Commented:
Regarding the previous message, I'm still waiting for the changes to resolve on the SharePoint/Fax connector changes you suggested.  Just want to know about the Windows SBS Internet Receive connector while I wait for it to resolve.
0
abt-itCommented:
If it's activated, you should also change it.
0
b1dupreeAuthor Commented:
It was the Fax/SharePoint connector and SBS Internet Receive Connector that did the trick.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.