?
Solved

Running IIS and JBoss on the same server (SBS 2008)

Posted on 2010-11-16
9
Medium Priority
?
1,336 Views
Last Modified: 2012-05-10
One of our clients has installed HMS Jboss application server on SBS 2008.
From this moment, we're unable to use the IIS websites such is OWA, and unable to use windows update.

I'm sure it's far from being  a best practice to run both of those applications on the same machine.

What do you recommend us to do?

Thx  

BTW, the SBS2008 was installed yesterday...
0
Comment
Question by:IT_Group1
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 86

Expert Comment

by:CEHJ
ID: 34143979
>>I'm sure it's far from being  a best practice to run both of those applications on the same machine.

True

First of all, stop JBoss and see if IIS returns to correct operation
0
 

Author Comment

by:IT_Group1
ID: 34143981
Tried that, nope. The error is:
HTTP Error 500.19 - Internal Server Error
Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" failed
0
 
LVL 86

Expert Comment

by:CEHJ
ID: 34143992
That's an IIS problem, so i'll leave it to the other zone people
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 

Author Comment

by:IT_Group1
ID: 34144049
Thx. But from your experience the Jboss could have done it right?
0
 
LVL 15

Expert Comment

by:pcsmitpra
ID: 34144063
Please provide complete error logs from event viewer.
0
 
LVL 24

Expert Comment

by:Radhakrishnan R
ID: 34144065
Try registering this dll
start - run - regsvr32 (just drag and drop the owaauth.dll ) file into the run box so you will get the full path - regsvr32 c:\programfiles....

I think bez of 2 web server running in a single physical server and some files got corrupted.
0
 
LVL 15

Expert Comment

by:pcsmitpra
ID: 34144090
Probably you wont need to change any thing on IIS end. To verify, Stop Jboss and restart the phusical server and see if IIS and OWA works. If yes, then you should opt for changing the ports for Jboss. You may try : run -Djboss.service.binding.set=ports-01
or some other method to change the port binding.
0
 
LVL 86

Accepted Solution

by:
CEHJ earned 2000 total points
ID: 34144207
>> Stop Jboss and restart the phusical server and see if IIS and OWA works.

I already suggested that - apparently it doesn't
0
 
LVL 86

Expert Comment

by:CEHJ
ID: 34247295
:)
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
Viewers learn about the third conditional statement “else if” and use it in an example program. Then additional information about conditional statements is provided, covering the topic thoroughly. Viewers learn about the third conditional statement …
This tutorial explains how to use the VisualVM tool for the Java platform application. This video goes into detail on the Threads, Sampler, and Profiler tabs.
Suggested Courses
Course of the Month6 days, 10 hours left to enroll

592 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question