Solved

How to install ftps in AIX 5.3

Posted on 2010-11-16
20
1,827 Views
Last Modified: 2013-12-09
Hi experts,

I need to install FTPS on my AIX 5.3 server. The server already had ftp package installed.

Could you please help me with FTPS package and How to check connection b/w server and client.

Thanks in advance.

SK
0
Comment
Question by:sivakumar_experts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
  • 2
  • +2
20 Comments
 
LVL 5

Expert Comment

by:balasundaram_s
ID: 34147206
What FTP package is installed?   For FTPS, the following may be used.

http://lftp.yar.ru/   (LFTP)

For Testing, 'Curl' may be used.

0
 

Author Comment

by:sivakumar_experts
ID: 34147390
Hi Bala,

My AIX server is client server. Already FTPS configured in remote server (Master server). Now we need to set up AIX servers as client as do FTPS. and need to check the connection. it more help full if i get package and configuration detials.

Thanks
sk
0
 

Author Comment

by:sivakumar_experts
ID: 34147987
Hi woolmilkporc sir,

Could you please help me with above requirement its very very urgent. If required i will increase points.

Pls help.

sivaji.
0
Forrester Webinar: xMatters Delivers 261% ROI

Guest speaker Dean Davison, Forrester Principal Consultant, explains how a Fortune 500 communication company using xMatters found these results: Achieved a 261% ROI, Experienced $753,280 in net present value benefits over 3 years and Reduced MTTR by 91% for tier 1 incidents.

 

Author Comment

by:sivakumar_experts
ID: 34172533
Hi experts,

I had installed lftp package to my server ,, How i need to test whether my server capable of SSL? and how to test
0
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 34172570
I would start with simply trying the session with Master Server, since this is the final purpose. Or you can grab any SSL-capable client listed at http://download.pureftpd.org/pub/pure-ftpd/doc/README.TLS, for example CoreFTP, and try to connect to your server by SSL.
0
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 34172715
Here's an example of the FTP over SSL session log. The server is of course different since I don't haev AIX, but the FTP should be the same. I have highlighted the pieces that tell that it's indeed secure session.

[07:42:09] 220 Polyscience FTP Server
[07:42:09] AUTH TLS
[07:42:09] 234 Using authentication type TLS
[07:42:09] Connected. Exchanging encryption keys...
[07:42:09] Session Cipher: 128 bit RC4
[07:42:09] TLS encrypted session established.

[07:42:09] PBSZ 0
[07:42:09] 200 PBSZ=0
[07:42:09] USER vadimrapp1
[07:42:09] 331 Password required for vadimrapp1
[07:42:09] PASS (hidden)
[07:42:09] 230 Logged on
[07:42:09] SYST
[07:42:09] 215 UNIX emulated by FileZilla
[07:42:09] Detected Server Type: UNIX
[07:42:09] FEAT
[07:42:09] 211-Features:
[07:42:09]  MDTM
[07:42:09]  REST STREAM
[07:42:09]  SIZE
[07:42:09]  MODE Z
[07:42:09]  MLST type*;size*;modify*;
[07:42:09]  MLSD
[07:42:09]  AUTH SSL
[07:42:09]  AUTH TLS
[07:42:09]  UTF8
[07:42:09]  CLNT
[07:42:09]  MFMT
[07:42:09] 211 End
[07:42:09] CLNT SmartFTP 2.5.1006
[07:42:09] 200 Don't care
[07:42:09] OPTS UTF8 ON
[07:42:09] 200 UTF8 mode enabled
[07:42:09] PWD
[07:42:09] 257 "/" is current directory.
[07:42:09] Compression disabled for private IP addresses.
[07:42:09] TYPE A
[07:42:09] 200 Type set to A
[07:42:09] PROT P
[07:42:09] 200 Protection level set to P
[07:42:09] PASV
[07:42:09] 227 Entering Passive Mode (127,0,0,1,12,18)
[07:42:09] Opening data connection to 127.0.0.1 Port: 3090
[07:42:09] MLSD
[07:42:09] Connected. Exchanging encryption keys...
[07:42:09] 150 Connection accepted
[07:42:09] Session Cipher: 128 bit RC4
[07:42:09] TLS encrypted session established.

[07:42:09] 4143 bytes transferred. (64.2 KB/s) (63 ms)
[07:42:09] 226 Transfer OK
[07:42:40] NOOP
[07:42:40] 200 OK
0
 

Accepted Solution

by:
songchai earned 125 total points
ID: 34173286
1. Download and install openssl from https://www14.software.ibm.com/webapp/iwm/web/preLogin.do?source=aixbp
2. Download and install openssh from http://sourceforge.net/projects/openssh-aix/

sftp connect to secure ftp server.

 
0
 

Author Comment

by:sivakumar_experts
ID: 34173941
Hi Experts,

My AIX server acting as client, Not as server.

In client AIX server i installed lftp ,OpenSSL and Curl . Now How  i need to check the connection ?

thanks
sk
0
 
LVL 40

Assisted Solution

by:Vadim Rapp
Vadim Rapp earned 125 total points
ID: 34174013
Connect to your ssl server and see if it works. There's tutorial at http://tutorials.papamike.ca/pub/lftp.html .
0
 

Author Comment

by:sivakumar_experts
ID: 34204052
Hi vadimarapp,

Thanks for all your support. Still i am facing some file dependence error. However i installed all the require libstdc++  rpm files.


# lftp
exec(): 0509-036 Cannot load program lftp because of the following errors:
        0509-150   Dependent module libstdc++.a(libstdc++.so.6) could not be loaded.
        0509-022 Cannot load module libstdc++.a(libstdc++.so.6).
        0509-026 System error: A file or directory in the path name does not exist.
0
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 34204564
Sorry, can't help in this, since have no idea about neither Unix, nor C.
0
 
LVL 62

Expert Comment

by:gheist
ID: 34205249
you need to add /usr/local/lib to LIBPATH in /etc/profile
0
 

Author Comment

by:sivakumar_experts
ID: 34229001
Hi vadimrapp1,

Good morning !

Update: Successfully installed lftp on AIX 5.3 as clinet. Now i need to ensure how SSL connection establishing !  i am able to connect to remote ftp server . But i need evidence? How ? where i can find lftp log file , where u got FTP over SSL session log (in above post)

Thanks.
0
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 34236349
In my post, I used windows-based client, totally different, and only as an example of what to look for. Presumably, your lftp also produces some log, like every ftp client does, and that's where you will find the lines similar to my example. You will probably find out where the log is created in the documentation on lftp.
0
 

Author Closing Comment

by:sivakumar_experts
ID: 34705673
its not solved my purpose
0
 
LVL 62

Expert Comment

by:gheist
ID: 34710627
Where is the problem? Did you fix the LIBPATH?
0
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 34710981
Probably for the two months, the purpose has changed sufficiently from "Successfully installed lftp on AIX 5.3 as clinet" to "its not solved my purpose" to suggest C grade.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
moving away from .local domain 5 98
Field name with special character (Ñ) in Oracle 11 190
Equivalent of WSUS for Solaris, AIX and Cisco devices 11 136
sed command 3 28
FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question