Solved

Goole and Facebok links to Sharepoint

Posted on 2010-11-16
1
382 Views
Last Modified: 2012-05-10
Hi,

I am configuring Sharepoint 2010. I was wondering if anyone has a method to add a goole search box and also a Facebook link to our page. Is this straigh forward?
0
Comment
Question by:cglynn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 5

Accepted Solution

by:
tzarad earned 250 total points
ID: 34145966
Use a HTML Form Web Part linking to an external web page containing the google search form

<WebPartPages:SimpleFormWebPart webpart="true" runat="server" __webpartid="{5DD01AA0-8C42-4879-8392-52B476CCB9A7}">
<WebPart xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/WebPart/v2">
  <Title>HTML Form Web Part</Title>
  <FrameType>None</FrameType>
  <Description>Connects simple form controls to other Web Parts.</Description>
  <IsIncluded>true</IsIncluded>
  <PartOrder>1</PartOrder>
  <FrameState>Normal</FrameState>
  <Height />
  <Width />
  <AllowRemove>true</AllowRemove>
  <AllowZoneChange>true</AllowZoneChange>
  <AllowMinimize>true</AllowMinimize>
  <AllowConnect>true</AllowConnect>
  <AllowEdit>true</AllowEdit>
  <AllowHide>true</AllowHide>
  <IsVisible>true</IsVisible>
  <DetailLink />
  <HelpLink />
  <HelpMode>Modeless</HelpMode>
  <Dir>Default</Dir>
  <PartImageSmall />
  <MissingAssembly>Cannot import this Web Part.</MissingAssembly>
  <PartImageLarge>/_layouts/images/mssfwp.gif</PartImageLarge>
  <IsIncludedFilter />
  <ExportControlledProperties>true</ExportControlledProperties>
  <ConnectionID>00000000-0000-0000-0000-000000000000</ConnectionID>
  <ID>g_5dd01aa0_8c42_4879_8392_52b476ccb9a7</ID>
  <Content xmlns="http://schemas.microsoft.com/WebPart/v2/SimpleForm"><![CDATA[<!-- Google Search Box HTML Start --> <iframe src="http://myserver/Igoogle.html" name="googlesearch" allowtransparency="true" scrolling="no" frameborder="no" height = "60px" width="400px"></iframe> <!-- Google Search Box HTML End --> ]]></Content>
</WebPart></WebPartPages:SimpleFormWebPart>



igoogle.html code :

<html>
<head>
<link rel="stylesheet" type="text/css" href="http://webserver/_layouts/1033/styles/Themable/search.css?rev=Uoc0fsLIo87aYwT%2FGX5UPw%3D%3D"/>
<style>
.ema01{
font-style:italic;
border:1px solid #e3e3e3 !important;
color:#476382;
margin-top:0;
font-size:12 px;
height:19px;
border-right:0 !important;
width:191px !important;
background:url("http://webserver/_layouts/images/bgximg.png") repeat-x -0px -511px;
border:1px solid #e3e3e3 !important;
background-color:#fff;

padding:2px 3px 0;
}
/*ema01 ms-sbplain */
</style>
</head>
<body >
<form method="get" action="http://www.google.com/search" target="_new" class="ms-sbcell" name="googleform">

<table class="ms-sbtable ms-sbtable-ex s4-search" cellpadding="0" cellspacing="0" border="0">
                        <tr class="ms-sbrow">
                        <td><a href="http://www.google.com/"><img border=0  src="google.gif" align="middle" /></a></td>
                              <td class="ms-sbcell">
                              <input  type="text" value="Search the web ..." maxlength="200"
                              title="Search..." class="s4-searchbox-QueryPrompt ema01" name="q" alt="Search web"
                              style="width:170px;" /></td>
                              <td class="ms-sbgo ms-sbcell"><a  title="Search" href="javascript:document.googleform.submit()">
                              <img title="Search" onmouseover="this.src='http://ws2008shp2010/_layouts/images/gosearchhover15.png'"
                              onmouseout="this.src='http://ws2008shp2010/_layouts/images/gosearch15.png'"
                              class="srch-gosearchimg" alt="Search the web" src="http://ws2008shp2010//_layouts/images/gosearch15.png" style="border-width:0px;" /></a></td>
                              <td class="ms-sbLastcell"></td>
                        </tr>
</table>

</form>
</body>
</html>


0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last week I faced a strange issue recently, i have deployed SharePoint 2003 servers for one project and one of the requirements was to open SharePoint site from same server. when i was trying to open site from the same server i was getting authentic…
When installing SharePoint 2010 RTM I came across a strange error, I was getting timeouts during the installation. I searched the web and found the best solution to be found here (http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010genera…
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question