SharePoint 2010 multilingual & variations


Overview: When I change Language from a menu, site does not redirect to the right variation.

I have SharePoint 2010 in native English installation with few additional language support as German, French, Slovenian,... I've created one site collection and enabled multilingual support (Site Administration -> Language Settings). So far so good, depends on selected language all menus and ribbons changes their content.

After this procedure I created few variation labels. I have English as my source variation and additional Slovenian and German. On every label I selected the correct site template language and Locale for this variation. After hierarchies creation I re-enabled multilingual support for every site (variation).

And here comes ms. trouble :). I suppose when I change the language from a menu, sharepoint should use the right variation I specified in variation label settings. Or I suppose wrong?

pic1 shows english version of the page
pic2 shows you slovenian version but the variation page didn't change
pic3 shows how should be when slovenian language is selected

If someone has an idea what I did wrong or miss, I would appreciate.

Thank you and Best Regards,
Who is Participating?
abdulwriteConnect With a Mentor Commented:
I hope you already tried : Variations Root Landing Logic
 If not  check out :
atrbandaAuthor Commented:
Anyone please?
atrbandaAuthor Commented:
I solved the problem that I left embedded "select display language" menu and created simply href links on the webpage which they are targeting to each language.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.