Ubuntu Fog Server Slow to image Thinkpads

I have setup a Ubuntu system with the newest Fog cloning system.  I can image Dell D620's in like 5 minutes, but when I image an IBM Thinkpad T410 it takes over an hour.  On the Dells I get gigabit speed but on the thinkpads it's way slower.  I was doing some research and found this.  wonder if this is current and if it might work?
To make a long story short: I built a new kernel without the old IDE modules, and now FOG works like a charm - I get about 1 GB/min deployment rate on a 100MBit switch.



Here are the steps needed:

- download the kernel sources for the current 2.6.25 release from kernel.org and untar them

- copy /opt/fog_0.xx/kernel/kitchensink.config to <kernel source dir>/.config

- run "make menuconfig" in the kernel source directory (you might need to install the ncurses-dev package first)

- go to "Device Drivers"

- disable "ATA/ATAPI/MFM/RLL support"

- make sure "Serial ATA (prod) and Parallel ATA (experimental) drivers" is enabled

- quit the config app, save the settings

- run "make". Wait some time until the kernel is done.

- copy arch/x86/boot/bzImage to /tftpboot/fog/kernel - you might want to make a backup of the existing kernel first.



Now, when you boot the client machines, they should access the harddisk as /dev/sdX instead of /dev/hdX, and the speed should improve dramatically.

Open in new window

LVL 6
Ryan SmithSr. Systems EngineerAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
Follow the troubleshooting section in the manual

http://www.fogproject.org/wiki/index.php?title=FOGUserGuide

You may have to compile your own kernel with working drivers that initialise the network card and connect at 1Gbe
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Is it the network card on the IBM Thinkpad being initialized at 1Gbpe?

are the hard drives the same size?
0
 
Ryan SmithSr. Systems EngineerAuthor Commented:
It happens on all the thinkpads I image.  X201, T400, and T410.  I doubt they are running at 1Gb/sec.  That's the problem.

I can image 80GB gateways in under 5 minutes.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
so the network card is not running at a 1G?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what you posted above, was nothing to do with network settings?

you'll need to change the network settings to force the network cards to initialize at a Gig speed, if you think this is the issue, can you tell from the network switch, what network speed is?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
and do the gateways connect to the switch at 1Gbe
0
 
Ryan SmithSr. Systems EngineerAuthor Commented:
The dells connect at 1GB, but not the thinkpads.
0
 
Ryan SmithSr. Systems EngineerAuthor Commented:
I meant to say Dells, not gateways in the above posts..
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Ok so this the root cause of the issue, which is nothing to do with the kernel changes for the disks.

You need to check the settings for the nics, and maybe obtain correct drivers for the network cards to initialise at 1Gbe speeds.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.