Link to home
Create AccountLog in
Avatar of blkfoot
blkfootFlag for United States of America

asked on

How to change Exchange server banner for outgoing email

Hi,
I have been fighting this problem since I installed Exchange 2007.  I see other folks have the same issue but I haven't found how to resolve it.

My Exchange 2007 SP3 server has all services installed on one server.  The server is a Windows 2008 server.  My Send Connector specifies the FQDN of mail.domain.com and yet when it sends email out the header shows my internal server name, servername.domain.com, causing other mail servers to reject email because our reverse dns resolves to our external FQDN mail.domain.com.

How do I change the outgoing email to show as coming from mail.domain.com instead of servername.domain.com?  Below is content from email header:


Generating server: EXCH2007.domain.com

user@craigslist.org
mxi5p.craigslist.org #554 5.7.1 <unknown[216.14.xxx.xxx]>: Client host rejected: rDNS/DNS_validation_failed._Please_setup_matching_DNS_and_rDNS_records:_http://www.craigslist.org/about/help/rdns_failure xabd-4 ##

Original message headers:

Received: from EXCH2007.domain.com ([2002:5900:8::5900:8]) by
 EXCH2007.domain.com ([2002:5900:40::5900:40]) with mapi; Mon, 15 Nov 2010
 13:27:15 -0700


Thanks!
Avatar of MegaNuk3
MegaNuk3
Flag of United Kingdom of Great Britain and Northern Ireland image

Do you have any other Send connectors setup?
Avatar of blkfoot

ASKER

I have one set up for Faxmaker.
Also looks like your server is connecting out via IPv6
Avatar of blkfoot

ASKER

I have IPv6 disabled and set the registry key to complete the process but I have been unable to reboot the server.  Is that why it is showing as servername.domain.com???  Because it is going out via IPv6?
Err no, it looks like it is by design on a single server setup:
"If the Send connector is configured on a Hub Transport server that also has the Mailbox server role installed, any value that you specify for the Fqdn parameter is not used. Instead, the FQDN of the server that is displayed by using the Get-ExchangeServer cmdlet is always used.
For servers that have both the Hub Transport server role and the Mailbox server role installed, the only way to remove the server name from the Received: headers of the outgoing message is to use the Remove-ADPermission cmdlet to remove the Ms-Exch-Send-Headers-Routing permission from the security principals that use the connector. This action will remove all the Received: headers from the message as the message leaves the Hub Transport server. We recommend that you don't remove the Received: headers for internal messages, because the Received: headers are used for maximum hop count calculations. For more information about the Remove-ADPermission cmdlet and the Get-ExchangeServer cmdlet, see the following topics:"
Avatar of blkfoot

ASKER

Thanks, MegaNuk3.  And, thanks for the link.

I have to say Microsoft is not making any friends with this one.

ASKER CERTIFIED SOLUTION
Avatar of Alan Hardisty
Alan Hardisty
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
If you change the IP associated with mail.domain.com to your fixed IP address (216.14.xxx.xxx) you should be fine.
Avatar of blkfoot

ASKER

SWEET!!!  You are absolutley right.  We had originally created the 216.14.xxx.xxx IP address as a bookmark for the new Exchange 2007 until we converted over from Exchange 2003 server.  After we migrated we moved our internal IP address to the new Exchange 2007 server but forgot that the outbound rule in the firewall was sending email out as the 216 IP instead of the 12 IP.

Thanks tons, Alan!
The clue was in the question!

mxi5p.craigslist.org #554 5.7.1 <unknown[216.14.xxx.xxx]>: Client host rejected: rDNS/DNS_validation_failed._Please_setup_matching_DNS_and_rDNS_records

Easy to overlook though : )

Change that and Craig's List will like you - so will the rest of the world!
Avatar of blkfoot

ASKER

True story but when I tried a reverse lookup for the 216.14.xxx.xxx IP address it resolved correctly to mail.domain.com so it was throwing me off.
It will - but if you resolve mail.domain.com in DNS, you get a different result!  Which is what receiving servers will check and if you don't match up - an excuse to reject your messages.
As part of the question "and yet when it sends email out the header shows my internal server name"

Hence probably the reason I went off on the header tangent.

Alans solution should be the accepted solution though as that is really what this question is actually about. Not email headers.
If MegaNuk3 is happy about that - sounds reasonable to me : )
Avatar of blkfoot

ASKER

The original question was about how to change the banner name being presented in outbound mail headers.  The comment in 34148146 pointed me in the right direction with an answer to that question.  it didn't solve the problem but it did answer the question.  I think both contributors deserve credit for their answers.
Sometimes the answer to the question may not be what you are expecting it to be!

Your issue is solely caused by DNS issues with IP's not setup properly.

Whilst you may wish to change the banner - that is not causing you rejection issues - the DNS issue is.
Fine with me, serves me right for reading the question quickly on my IPhone. Luckily eagle eye Alan swooped in and saved the day ;-)
Avatar of blkfoot

ASKER

Ok, whatever.  Thanks to both of you for your contributions.  It answered the questions that I had!
Get an iPad - much easier to read ; )  It just doesn't fit in your pocket quite as easily - and I haven't managed to make mine ring yet!
Thanks MegaNuk3 and blkfoot.
No problem, glad your question got answered.

As for the iPad idea. Sorry, I like to travel light when going to customer sites using public transport(train). If it doesn't fit in my pockets it doesn't come with me, apart from an umbrella ;-)
@MegaNuk3 - The answer is bigger pockets ( ** laughing ** )
@Alan - I was waiting for that comment ;-) didn't take you long.
Sorry to be predictable!  My iPad travels everywhere with me - especially on trains.